English

Parts of the touchscreen don't work - See first post for troubleshooting

Troubleshooting:

Do the following steps:

  • Remove the screen from the phone (if you have troubles check out this guide)
  • Carefully clean the connectors. Then put the screen back.
  • If the problem persists go to Settings > Maintenance > Checkup and use the “Free drawing” tool. (Do this while the phone is not plugged in)
  • If there are parts of the screen where you can’t draw then make a screenshot and send it to support to get a replacement.

Original Post:

Hi,
the touch screen of my FP2 does not react in the lower part of the screen. It affects mainly the writing of SMS and Emails, because the delete button does not work.
Unfortunately when I rotate the screen, the “,” and “.” do not work. Is this a known problem?

1 Like
[1.3.6] Left side of the touch screen stopped working
Touch screen does not work on its whole surface
Bottom-left of screen does not work in writing
Touchscreen Problems - "q" can't be tipped
Touchscreen problems
Lower right part of touchscreen not working
FP2: Screen needs a calibration
Right side of screen not working
Side of touchescreen doens't work
Fairphone-2 does not regcognize log-in pattern
FP2 Screen can't be reactivated during/after calls - See first post for Workarounds
Can't type i or k
Screen does not run
FP2 dead TouchScreen zone
:de: Touchscreen defekt (?) - nicht mehr alle Tasten auf Tastatur erreichbar
Touchscreen keyboard issue (no 1 or Q!)
The left side of the screen doesn´t work
Fairphone really has to sort out its warranty support
Letters "i" and "p" do not work using all keyboards
Can not press all letters on my fp2
Screen disabled in the middle
Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay
:fr: Tactile tout seul
Keyboard malfunctioning
Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay
How to repair a non-reacting FP2 Screen
FP2 display module sold out?
My touchpad is not working properly
:de: Touchscreen defekt (?) - nicht mehr alle Tasten auf Tastatur erreichbar
Right side of the screen unresponsive
FP2 rings, but swiping on display to answere calls doesn't work
Out of stock/missing FP2 spare parts from online store
:fr: A part of my screen no longer works / Une partie de mon écran ne répond plus
:de: Meine Fairphone 2 Probleme
:de: Kann nicht auflegen seit letztem Update, ist aber nicht der Proximity Sensor
:fr: Fairphone en Français
Update gets stuck at "just a moment" after downloading
The left side of the screen doesn`t work
:de: Tastatureingabefehler
:de: Touchscreen defekt (?) - nicht mehr alle Tasten auf Tastatur erreichbar
Wifi not working after factory reset and update of Fairphone Open
Why is the touch screen not working?
:de: Display funktioniert am linken Rand nicht
FP2 sudden death
Do girls have a better Fairphone 2 experience?
:gb: :fr: FP2 screen wanted because warranty is over and can't afford 87€
Display on FP2 not working
:fr: Erreurs de saisie sur le clavier
Left side of screen unresponsive
Out of stock/missing FP2 spare parts from online store
Screen problems
Error regarding touch
Touchscreen keyboard problem
Touchscreen has gone crazy
Cannot type the letters 'd' and 'x' on my keyboard
Some Areas of the Screen Are Dead
Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay
Fairphone OS 17.12.1 is now available
:de: Touchscreen defekt (?) - nicht mehr alle Tasten auf Tastatur erreichbar
(More or less) common issues with Fairphones
Horizontal digitizer resolution failing
Problems with Android Keyboard
Bright spot on the display
Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay
Cannot click specific letters
Some keys do not work
Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay
Can not press all letters on my fp2
Keyboard Problem: Cannot type '8' or 'i' or blanks anymore
Software problems: 3 disturbing mistakes
Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay
Cannot Type no. 1 and letter q since latest update
FP2: Edges of screen unresponsive and list of app bugs
FP2: Edges of screen unresponsive and list of app bugs
Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay
Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay
1) black screen when calling using the phone 2) no letter "i" on the touch screen
Fairphone 2 touchscreen suddenly freezes
Touchscreen just works partially! Hardware or Software Problem?
Left and Right Side of the Screen doesnt work,System UI crashing etc

Sounds similar to Capacitive buttons and lower part of touch screen not reacting

Yeah, but that was FP1.

@Christoph_Weis: As far as I know, this is a new problem for the FP2, so it might be best to contact support.

1 Like

You’re right, sorry, I missed that.

Exactly. @Christoph_Weis please contact support and report back what they tell you.
On FP1 you’d do a touchscreen test through testing mode, but beware (:warning:) on FP2 the same combination doesn’t get you to testing mode but to fastboot mode.

I think it is a software bug. I did a factory reset and it work - for a few hours. The problem is, that the shortcut menu (right edge of the screen) does not work. Maybe it blocks the screen on the right side.
Do you know, which process it is? Maybe I can stop it, it would be worth to try.

Do you mean the edge swipe? It can’t be disabled, it’s part of the launcher. You could try a different launcher to see if that’s really what’s causing this.

I have tried a new launcher, but it had no effect. It seems that edge swipe didn’t work because of the problem. Is it possible that a connection to the screen is not tight enough? The screen is not flickering, but sometimes it seems that also other areas of the touchscreen are not responding (mainly in the right part of the screen).

Try dis- and reassembling the screen.

…it is really easy to disassemble the screen. But unfortunately it has no effect.

…now it is even worse. All Icons on the right side of the screen are “dead” (the whole column!).

Hi,

  1. maybe the screen display is not calibrated correctly. But when I want do scroll through a list
    of my emails or another list (e.g. entries in file explorer) this is not possible on the right side
    or only with strong pressure…

It is very hard to use the keys (e.g. “p” , “l” and “back” which are on the far outer right side (e.g. back button on the displayed keyboard when editing text (SMS / E-mail) … I have to turn the mobile into landscape mode.

I opened a ticket @support. Has somebody experienced this issue? Is there a workaround?

cu,
vordprefect
Has anybody experienced that or is there a workaround?

1 Like

@vordprefect I moved your post here and edited the title so it better represents your problem too.

I guess we’ll have to wait until one of you gets a response from support.

Hi Vordperfect,

I experienced the same problem, contacted the support, and finally sent back my phone. As far as I could tell, this was really a hardware problem, a dead zone on the touch screen. One way to maybe explore further how your screen reacts is to use some children’s drawing app like kids doodle. I think the test through this app is close to what used to be the touchscreen test on FP1.

Best,

André

Hey
I have the same problem as @vordperfect. Inwriting mode (English keyboard), the middle-right side of the screen seems not to work for “p” or “0”.
I don’t think it is a hardware problem, as it was perfectly working until ~10 days ago.
My workaround is to turn the phone into landscape mode or rely on text recognition. But it is really annoying.
Did anybody open a bug report yet?
All the best
Rey

Hi Rey, I asked the support four days ago but I have no aswer yet. We have to wait until we get advice.

Christoph

Hi,

I tried it with kids doodle… the result is the following:
The dots may display where I tried to press harder:

I will forward this picture also to my ticket @support - I didn`t hear anything since I opened the ticket (and posted it in the forum).

The next strange behaviour I experienced, when the display is on, the apps are opened and different screens are showing up as if a ghost is touching the screen. Workarounds as recommended didn`t solve the issue.

cu,
vordprefect

Hi vordprefect, I even can’t save the picture because the save-button is in the dead zone. But the picture looks similar, only the single dots are missing.

The support has given me no reply to my ticket yet. It would be good for whoever has first contact to the support team to point out that others have the same problem.

Christoph

Hello,
I also have exactly the same problem on both sides of my FP2.
I didn’t have the problem in the beginning, and i even have the feeling that the area that is not responding is expanding.
I coloured the parts of my screen that work with a drawing program.
I also have tried to contact support for help on this (6 days ago), but no reply yet.

Let’s keep in touch about possible replies from support.

Boris

Since 1-2 days I have the same problem, it’s especially annoying with texting: in portrait p,l,m does not work and in landscape space and all lower buttons. I hope to hear something from your support tickets soon!