Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay

Sounds like your touchscreen is going a bit beserk. I’ve moved your post here as it contains some tips that have helped improve the situation for others (see the first post for a summary). I also remember reading that removing and putting back the screen sometimes helps.

Thanks, I’ve completed the suggested fixes and it is behaving, for now. Part of my screen is still not responsive. I checked on a drawing app to test and the area is at the bottom of the screen in the middle. when texting in portrait I can’t use y,g,h,v,b or part of the spacebar. is this a hardware issue?

I’m afraid it is a hardware issue. See here for mor info:

Thanks for your help.

Hello People!

I have the problem too, i mean the ghost multitouch issue.
I also have a dead zone on the lcd.- if i put the finger on it, it makes two inputs like on the picture.
I cant use my phone anymore.- I have sent a support mail and got a ticket number .

It is definitly a hardware problem.- i set the option for “show the touch input” in a problemfree minute. (doesnt know how it is called in english android, but you understand, right?)

I tried to clean the screen best i can, short time it was better but not the yellow from the egg.

What shall i do? Calling the support on my cost?

Thank you well!
Greets from Austria,

1 Like

Looks mainly like this issue:

(In short: For some people removing and reassembling the screen solves the issue.)

Somtimes (but quite often) the touchscreen of the FP2 gets into chaos-mode and delivers erratic positions. I switched on “Entwickleroptionen → Zeigerposition” (“Developer options → Pointer position” ?). In this mode it displays crosshairs at the pointer-position and draws a graph of the movement.
I moved the finger slowly horizontally, but as you can easily see the movement in y-direction jumps around totally erratic. Apps that require scrolling, zooming etc. are nearly unusable in this state.
I experience this behaviour at about half time of usage, possibly connected to the charging-state of the phone.
The problem exists since the first day, my hope that it will be fixed in the first software-update was deceived.
Update: still exists in 1.3.6.

did you try cleaning the screen? I found my FP2 works a lot better if I take the cover off and clean around the edge of the touch screen and around the inside edge of the rubber bumper. I have a theory that crap gets stuck between the cover and the screen and gives it false inputs (ie like when you get drops of water on the touch screen).

Worth a try anyway.


Hey Chris, sorry to hear your FP2 is experiencing these issues. I’m not sure if anyone from our team has been in touch yet, can you give me the 6-digit request number of the message you sent us? Thanks in advance. Michiel

I’ve got the same issue. If I touch the “e” on the keyboard it selects “w” and “r” - this alone makes my phone unusable. Additionaly to this my phone runs crazy with swiping and tapping randomly. Please fix this asap.

Could any official say something about that issue, please? Is there any sense in writing a ticket? I hope enough people already did this.

Thank you very much in advance.

- protux.


  • I tried the fix above - with no result
  • I booted into recovery mode and cleared the cache - with no result
    Please help… :confused:

Thank you Michiel, i have got a submit from support. I already created my account at return portal and be waiting to send the phone back.

Why do we need 3 Accounts for Fairphone-shopping, Zendesk AND Return=? does something go wrong?

Is there any idea that 1.3.6 makes this worse? It has for me so far

I think so, too. Before 1.3.6 I had this issue just while loading the phone, and shortly after the patch my phone went crazy…

Our webshop, support system (Zendesk) and return portal are three different systems and therefore three different accounts are needed. We realise this is highly annoying and are working on improvements for the future!

1 Like

Hey, I’m sorry to hear your phone is behaving like this. Give us a call at +31(0)20 - 788 400 to make sure we can fix this as soon as possible!

Thank you very much, I did so and need to return my Phone for repair. :frowning:
Btw: there was a little typo, it is +31(0)20 - 788 4400 (for future people who want to call.)

OMG this is just the most crazy and annoying bug I ever had with a smartphone!

It used to happen just from time to time, now it’s just impossible to use the phone at all, I can barely unlock the sim (pincode).

Another aspect of the bug that i thin wasn’t mentioned before. The letter E and D are almost impossible to type (even when the bug doesn’t happen). Whe I try to type E, both Z and R letters are typed in instead (im on a french azerty keyboard).

The workaround did not help much.

1 Like

Sounds like a problem with the screen or the connection between the screen and the rest of the phone. Reassembling helps in case of the latter. See also this topic:

1 Like

Having this issue, seems to happen whilst plugged in on charger more often than not but not always. Will try the workaround to see if it helps. It seems to fix itself as well, it’ll do it later on in the day and ill just leave it and the next day it’s fine :confused:

Same here too. :angry: