Fairphone 2: Crazy touch inputs (touchscreen issue) - workaround (for some): increase touch & hold delay

Also getting the crazy jumping touch input when scrolling here.
Setting touch and hold delay to maximum has almost completely eliminated but it’s too long a delay for an impatient git like me so will try koppor’s suggestion and the link from Stefan for a ‘touchscreen test’ posted while waiting for a fix from FP themselves.

Thanks for the tip.

Occasionally my screen reacts erratically when typing or browsing or even moving apps.
Any ideas?

1 Like

I moved your post to this topic as I think you have the same problem.

I experienced erratic moves while dragging icons around the desks for instances. I tried the provided work-around without success.

But in my opinion it’s linked to the fact that the screen is clean or not. If I use the phone during a little while, the screen becomes dirty (finger fat on it) and the touch screen becomes crazy.
If I clean the screen with a dry cotton fabric everything become normal again. So I also clean my hands quite often like a doctor, and clean the screen ofter also, and I think I have less occurrences of the problem.

(already having a touch-screen seems to be a mistake ! I’m always asking for people not to touch my laptop screen, to keep it clean ; and with the phone ? It’s just the way you use it… My previous Nokia E6 did kept its screen clean easily, I was not touching it…)

But a good point of the FP2 is that you can make a call laying the phone to touch your head only with caoutchouc border on your skin, so the screen remains intact ! I enjoying it at each call !

I had the same problem, erratically jumping around while scrolling.

The accessibility feature with the Touch & hold delay works fine, at least most of the time. When the phone gets hot though, it will still jump around like crazy.

The only way, I found it working at least 99% of the time was to enable developer options and check Pointer location under Input. This will paint a cross hair on your screen and visualize the way your finger went. The most annoying thing with it is the overlay of the notification bar, which is quite ugly, as it’s full of running numbers about all input data.
The only occasion, this won’t work 100% is in landscape, though it will be way better than without. I haven’t found out, why this makes any difference, but it apparently does.

So far my experiences with this particular bug. Does anyone yet know, when the update, which promises to resolve these things will appear?

Today I changed touch & hold delay as recommended here. Besides the originally mentioned issue this maybe helped me with a partly non-working touchscreen problem discussed in this thread, I documented the details in this post.

Can anyone approve or reject my suspicion that the two issues might be related?

Regards, Bernd

Hi, thanks to @Irina_Spitznagel who adviced me to this topic. My original post:

Hi, I have an issue with my touchscreen. When I am typing something the
display content goes up and down fastly. This is extremely annoying
because my keyboard always takes the wrong input. At first I thought
that might be a mistake of the keyboard but I tried different ones
(Android standard, hacker’s keyboard, Swipe) and it’s still the same. I
am not quite sure but might be that it has some similarities with the
hypersensitive touchscreen issue of FP1. But it appears on my FP2.
Maybe anyone of you has a similar experience or has a solution on how to
fix it. Cheers, Goody
__
In my case there is nothing like the crazy behaviour showed in posted videos. In my case, it’s just during typing. I tried all advices and it didn’t get any better. It doesn’t appear allways so I couldn’t figure out when it appears. I couldn’t access the menu for making a touchscreen test.

Another annoying bug is that scrolling through menus or websites (e.g. FP forum) it doesn’t scroll smoothly at all. It is rather very stagnant/halting and most inputs are executed very delayed. I don’t know if it’s because of a weak processor or for another reason. In addition to that, the mobile phone gets pretty warm during normal web surfing. I hope this is the right place for those issues! Cheers, Goody

+1 for crazy touch inputs issue

I found my exact scenario in this thread:
- out of control jumps while scrolling (like janmollitor), but only sometimes, and yes the longer Touch & hold delay workaround helps but don’t fix.
- out of control typing, sometimes only again, I’m using a swyping keyboard and as someone else said above it can get to impossible to type sometimes. I have to switch off the screen, breathe, wipe the screen (trying reassure my nerves it’s me not the device), breathe again and flick it back on.

  • impossible to even unlock the screen when in charge, again sometimes only, like Rafl

I’ve updated to gms36_1.1.7 but nothing. Hoping for a fix as it’s quite a serious bug.

1 Like

Turns out that ‘update’ to 1.1.7 is a bug in the updater app - all phones were shipped with 1.1.7 installed, so there shouldn’t be any differences in behaviour after applying the ‘update’. There was, however, a call for testers for the first software update a while back, in which the touchscreen issue mentioned…

I installed the latest update (1.2.8) and it’s worse than before :unamused:

Well it is not fixed, it is improved.

Improvements to correct touch-screen over-sensitivity
(Changelog)

Let’s see how well the update worked:

Did updating 1.2.8 fix the issue for you?

  • Yes, I don’t have crazy touch inputs anymore.
  • No, I still have them
  • Not entirely. I still have them, but it is definitely improved
  • I have them now and didn’t before the update. At least not that many.
  • I never had the issue

0 voters

The same here, after the Update i can’t use my phone anymore. I wrote the support days ago but maybe I got to call Fairphone later …

In my case, I still can use my FP but there is still a misbehaving touchscreen. I am not quite sure if it is the issue discribed here, therefore I made a video of it: Video. If anyone told me how to paste it properly as a video (the upload did work for videos) I’ll fix that.

Most importantly: the bug didn’t get any better after the update. Maybe anyone knows why… If there is anyone else who still has the problem too, please reply so the issue is put on the list of known bugs again.

I still have the bug and have now been told by support I’ll get a replacement screen to try out when they are back in stock. No answer regarding when the spare screens will be back in stock though, except that it’s supposed to be “very soon”.

I wouldn’t get my hopes up about the issue ever being fixed in a software update. It seems clear to me now it’s a pretty common production defect which didn’t affect some owners who apparently have no problems. So I would recommend chasing support on the phone if your phone has the issue.

1 Like

I just thought to do so. Has your issue any similarities to mine (see video link below)?

You can downgrade your device by yourself, if you want. Works a little bit like rooting because you have to flash the different parts of the OS, too. If you are interested in it, I could describe it more detailed.

My phone are going nuts, opening and closing apps v fast and unprompted. The only way I’ve been able to stop it is by removing the battery. When I switch back on it can be fine for a while b4 going crazy again, including making calls. I would have assumed this was a virus, but it is one of a number of issues I’m experiencing including parts of my screen not working and other issues mentioned on the forum.

Sounds like your touchscreen is going a bit beserk. I’ve moved your post here as it contains some tips that have helped improve the situation for others (see the first post for a summary). I also remember reading that removing and putting back the screen sometimes helps.

Thanks, I’ve completed the suggested fixes and it is behaving, for now. Part of my screen is still not responsive. I checked on a drawing app to test and the area is at the bottom of the screen in the middle. when texting in portrait I can’t use y,g,h,v,b or part of the spacebar. is this a hardware issue?

I’m afraid it is a hardware issue. See here for mor info: