English

Android KitKat (4.4.4) for FP1

osupdates
kitkat
Tags: #<Tag:0x00007f9ff790e928> #<Tag:0x00007f9ff790e798>

#1

A continuation of the 4.4.4 ROM from @chrmhoffmann found here.

WARNING: Even though in my testing I didn’t find any real issues, please still make sure you have a backup before flashing this ROM!

INSTALLATION

Only install this on a FP1 with the unified storage partition!

BUGS

  • IMEI loss when coming from the stock firmware. See [1]
  • Logging of Superuser requests doesn’t seem to work.

CHANGELOG

FP1-4.4.4-z3ntu-0.0.1:

  • Initial public release.
  • Android security patch level: 2018-11-01 (see [2])

[1] The IMEIs are written on your Fairphone. Remove the battery and write down the numbers. Then once you have booted the phone, follow this tutorial to fix this (use the “Second Method”): http://web.archive.org/web/20181127210225/https://www.facebook.com/fXDAdev/posts/448292925303711
[2]: frameworks/av is only on asb-2016.04 patch level due to Mediatek changes. This should be fixable soon. Additionally 9 other patches are known to be missing because they conflict a lot with the changes Mediatek did to the various components.


WhatsApp will soon stop support older Android version (2.3.7 and lower)
My FP1 is suddenly getting extremely unstable and irreliable
#4

This is awesome, thanks! I’ll start testing today.


#5

_104444205_945fc269-ad0a-42af-9afa-8411117ef78b-1


#6

Wow, I’m stunned (although I guess I will fail to successfully install it … I never got that whole adb thing to work). Fantastic work!


#7

You can also put the zip on your SD card or your (unencrypted) internal storage and choose that from the recovery.


#8

Thanks, I had actually tried that on an FP1 running Macadamia, but the installation failed sometime whilst I was seeing the green Android on its back.


#9

That sounds like you were in the stock recovery.


#10

Yes, the recovery that was included in Macadamia. I know your instructions include installation of CWM, but so far I haven’t been able to succeed there.


#11

Thanks a lot to @z3ntu not “just” for developing this thing, but also for giving me (PM) help to install this without adb and fastboot.

So far I just noticed that the “missing SIM card” messages are still there.
USB storage and Media Device (MTP) access work unchanged (as) well though.


#12

May I ask how you managed to include all recent security patches? Did you scrape them all manually to decide whether they apply to KitKat or not?

This is awesome work and I appreciate it very much! I sent my FP1 - which was one of the first batch and did its service for my wife until this year’s March with @chrmhoffmann’s ROM - as a gift to someone in France who needed it for spare parts, so sadly I can’t test your new KitKat build.


#13

Fortunately some people still contribute security patches to the cm-11.0 (Android 4.4) branch for LineageOS so I could just take them from there and apply (and sometimes make them apply - thanks Mediatek) them to my sources. But yes, there people review the patches and apply them if possible - see e.g. https://review.lineageos.org/c/LineageOS/android_build/+/224455 for 2018-08-01.

EDIT: Here’s my list of what patches are in the ROM: https://cloud.z3ntu.xyz/index.php/s/GRjM97sPCAKjpxR
The first number in the lines is the LineageOS Gerrit ID (you can paste it in the search box on https://review.lineageos.org to get to the change) and following is the repository name of the patch
ALREADY_APPLIED: Already included in the sources I have
YES: Applied successfully
IGNORED/UNNECCESSARY: Irrelevant (recovery or qcom repositories mostly)
LOS_MERGE: Merged the LineageOS repository into my local one (= free security patches)
LOS: Took the LineageOS repository instead of the AOSP one
FWK_AV: See top post or todo list at the end of the file
TODO: Not yet done, explained in the “BIG TODO”


#14

What is with them? Don’t you like them?


#15

I could do without them, but it’s certainly just something very minor.


#16

Just in case someone else might run into the same problems as I did, I wrote a detailed step-by-step set of instructions how I was able to

Install z3ntu's Android KitKat 4.4.4
without ADB & Fastboot

Click to see 15-point set of instructions

Thanks to z3ntu for pointing me towards all the necessary solutions. The following can be done with variations at some points (especially location of files), but I was just glad it worked out this way, so I’ll just describe the exact procedure that I succeeded with. Please note that the effect of the buttons change in the course of the instructions.

  1. I downloaded the recovery.img and z3ntu’s 4.4.4 zip to my FP1’s SD card (top level).

  2. I installed the first best terminal app (https://f-droid.org/de/packages/jackpal.androidterm/) that I found (and z3ntu also suggested) in order to be able to install the recovery without ADB & Fastboot.

  3. Launch the terminal app, type su and press .

  4. Once the entry is confirmed, type the following and press :

dd if=/storage/sdcard1/recovery.img of=/dev/recovery

Afterwards, it should look like this:

  1. Now you need to boot into the newly installed recovery by holding the POWER button and the VOLUME UP button simultaneously (for a long time) until the display turns black and you eventually get to see five really tiny lines in the middle of the screen. Release the buttons only now.

  2. An <<== arrow should point at “[Recovery Mode]”. If this is the case already, confirm by pressing the VOLUME DOWN button once. If the <<== arrow stands elsewhere, scroll to “[Recovery Mode]” by pressing the VOLUME UP button.

  3. Wait until the recovery has booted (it has a grey textile fabric background)

  4. Scroll to "install zip“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button.

  5. Scroll to "choose zip from /storage/sdcard1“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button.

  6. Scroll to the file starting with "FP1-4.4.4-z3ntu“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button.

  7. Confirm by scrolling to "Yes“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button. The installation of KitKat 4.4.4 should now start, you should get to see the green android with an open belly and an installation log below.

  8. Once completed, the display will return to the recovery. Scroll to "+++++Go Back+++++“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button.

  9. Confirm "reboot system now“ by pressing the POWER button (or scroll there once more pressing the VOLUME DOWN button and then confirm).

  10. Confirm "No“ by pressing the POWER button (or scroll there once more pressing the VOLUME DOWN button and then confirm) in order to keep the new recovery.

  11. Your new Android KitKat 4.4.4 should now boot. :slight_smile:

Feel free to correct the above (please try to not make it even longer).


#17

Just to make sure because I haven’t seen anthing about it explicitly: installing this ROM keeps all the apps and data in place?


#18

Maybe, but don’t complain to me then when apps are crashing and whatnot. :wink:


#19

Better use Titanium Backup, move the backup on the external storage and do a clean install, I’d say. :face_with_monocle:


#20

Well, maybe I should have phrased the question otherwise: does the install wipe/do I have to wipe.


#21

You have to select wipe in CWM yourself if you want it to wipe.


#22

Anyone here know if I can get rid of the grey search bar on the home page? I was able to do so by deactivating the SCAN app, but that seemed to quickly affect another app negatively (“Email” crashed on start).