Forgot my screen lock pattern

I’m afraid there’s not much to do.

Though you may still have a chance to get back your data but only if it is a FP2 and not encrypted. You could then boot into fastboot, then into TWRP and there copy your data. If you have a FP3, then not much chance AFAIK…

Edit: Corrected that the phone must not be encrypted (which the FP3 is by default). Thanks to @AnotherElk.

Not in case encryption is enabled (default on the Fairphone 3 without user interaction, can be enabled by the user on the Fairphone 2).
Then the screen unlock method would serve as the decryption password and TWRP would need to prompt for it to be able to access the data partition.

2 Likes

If it’s a FP2 and not encrypted then @rembremerdeng might also try to remove or rename
/data/system/gesture.key
using TWRP.

1 Like

Does the same procedure work for a FP1?

  • It has WiFi turned on (but unfortunately the WiFi of back then doesn’t exist anymore)
  • mobile data is turned of

So I can’t just reset the pattern because i don’t have internet.

PS: I just want to get my data from that phone. If I have it, there will be a perfectly working FP1 to give away.

Have you checked out some options, the following link is an example I’m trying to find one I saw a few days ago, it was bit fiddly but basically made the phone crash and ask for a new password. Will update when I find it / if I find it :slight_smile:

1 Like

What version of Android are you using?

This is for version 5

https://android.imyfone.com/remove-screen-lock/bypass-android-lock-screen-using-emergency-call/

A Fairphone 1 is usually running Android 4.2; at best it’s on 4.4.4, which is not an official version distributed by Fairphone (see this thread).

1 Like

Thank you for the quick response!
Unfortunately none of this tips worked. I don’t have the Android Device Manager, it seems that makes the problem little more tricky.

I don’t remeber to be honest, but it was an official verison by Fairphone.

Well, if your Android phone (including Samsung) is running Android 5.0 or earlier,

Did you try this

https://android.imyfone.com/remove-screen-lock/bypass-android-lock-screen-using-emergency-call/

Just now i did :wink:

  • The first way (emergency call) doen’t work, because I can’t copy the characters.
  • The second way destroys all data except for Samsung phones.

I remeber that I tried to get rid of the lock pattern some time ago but stopped because of frustration :smiley:

Why can’t you copy the characters?

Can you get to the emergency call option and type in the max stars?
If you can hold you finger on the ‘text’ and you will get an option to copy.
Then you repeatedly paste in the same place.

I can go to the emergency call and type in characters, but if I hold my finger on the text, there don’t appear any options.
There isn’t a curser and I can’t go to a specific point, maybe thats why I can’t see options.

Yes that seems to be a problem as on touch screens a prolonged touch in a text box usually gives and options to cut/copy/paste. Usually the text becomes highlighted and there are ‘tabs’ at the ends for editing.

EDIT: I’ve just noticed on my Android 10 there is no such option to cut/copy/paste either. I wonder if you have a later version of Android than 5 as this option was deemed a security risk and removed after that?

I wonder if you start the phone in safe mode if that will make any difference.

2 Likes

In Safe Mode I’m still not able to copy.
The Android is the latest official of Fairphone, I’m sure I dind’t install anything else

2 Likes

Running out of ideas apart from a paid for option and connecting to a PC etc.

Ok, at least I did not miss a simple solution in my google research :slight_smile:

What do you mean by paid option? Is there a software or do you mean a professional shop?

Yes I meant a paid software, but have you seen this page?

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.