English

Android KitKat (4.4.4) for FP1

osupdates
kitkat
Tags: #<Tag:0x00007f9ff9c9ab58> #<Tag:0x00007f9ff9c9a9c8>

#23

Easiest solution is installing another launcher from F-Droid/Play Store.


#24

THANKS YOU!!!

You are the best! This rom save the life of my FP1!


#25

#26

Made some edits to take into account different behaviour depending on whether you come from Kola Nut or Macadamia.


#27

I finally got around to testing this OS. Thanks @z3ntu - it works great and thanks @urs_lesse for the guide - I don’t think I’d have understood the instructions that involve ABD.

Btw @z3ntu first thing I did was install SatStat to test the proximity sensor and it seems to work perfectly.

@AustrianFairphoners shall I install this on all our spare part-FP1s? I currently have 4 working motherboards…


#28

It seems that I get significantly shorter battery duration (compared to both Kola Nut and Macadamia) even with virtually zero use. I have noticed this now on two different FP1s, two different original batteries. How about your experience, folks?


#29

Fantastic work! I’ll start testing today.


#30

I can’t say I experience excessive battery drain. Since your post 43 minutes ago I lost 1% with the phone just lying on the table.
I’ll now see what happens if I use it more by testing all the functions.
Okay I have to say though that I’m not using a SIM card, and there are not a lot of apps on the phone yet, so not much that can drain the battery.


#31

In airplane mode it basically doesn’t use any battery at all for me. With cellular on, it goes down much more quickly, so maybe with it just lying on the table maybe 2 days.


#32

Maybe it needs some calibration?

@paulakreuzer Yes, why not? :slight_smile: Maybe this can also help to investigate a possible battery drain.


#33

I actually did a battery reset after I first noticed this pattern. Strangely, after the battery reset the running time was shorter (before: Wi-Fi activated permanently, after: permanent airplane mode). I also installed the new 4.4.4 on my primary phone yesterday and despite airplane mode it drained 8% between midnight and this morning (previously that would be just 1-2%). I have switched back the former phone to Macadamia now to see if it makes a difference.


#34

On a positive side, it seems that I can browse the web much more fluently than when I used Macadamia (at least in Lightning). This also applies to using F-Droid. I wasn’t actually able to get app updates through F-Droid on Macadamia for some months now (it would never even search for them) while I immediately got four app updates right on the first F-Droid run under z3ntu’s 4.4.4 :slight_smile:

Maybe valid certificates make the difference? I’d be curious if anyone in Germany could try if ticket purchases in the Deutsche Bahn app work again under this, too.


#35

I’m wondering if the Restart Radio podcast works on this build after having this error message in Macadamia.


#36

Update.

I now have this port running on 3 FP1s.

The proximity sensor only worked out of the box on one of the 3, but I figured maybe it’s not a software issue: I opened one FP where it didn’t work, cleaned the sensor’s window, put in a rubber part that was missing and out screws in the motherboard - before it was loose.
Then the sensor worked. :slight_smile:
Will try with the 3rd phone too.

The battery life is good on all 3 devices so far - charging is fast, discharging slow.

Wifi connection is not great, but that could be just my wifi and the fact that 3 Fairphones more than usually connected to it at the same time. :wink:

Bluetooth & GPS also work fine.

I also tested microG unified NLP - no collusion! I mean, no GAPPS! and it works fine too. It reports “no last known location”, but a location is provided within a few seconds.


#37

Could you try to subscribe to the Restart Radio podcast in Antenna Pod?


#38

Done and done. :white_check_mark: :musical_note:


#39

Hello,

Maybe it’s a dumb question, but I’d like to update my FP1U from stock Android to the latest fully working one.

Is this port the best way to do it ?

Thank you :slight_smile:


#40

This is the latest the community can offer. It’s almost as secure as the FP2.


#41

Well, it seems it didn’t work for my FP1U :confused:

Steps 1-4 as described by urs_lesse.

Below, the next steps & my experience :

  1. Now you need to boot into the newly installed recovery by holding the POWER button and the VOLUME UP button simultaneously (for a long time). Either the display will turn black

-> had that.

and you will eventually get to see five really tiny lines in the middle of the screen (should happen when you come from 4.2.2. a.k.a. Fairphone OS 1.8.7 Kola Nut) – or you might land at step 7 right away (if you come from Fairphone’s 4.4.4 a.k.a. Macadamia 1.9.9). Release the buttons now.
6. An <<== arrow should point at “[Recovery Mode]” . If this is the case already, confirm by pressing the VOLUME DOWN button once. If the <<== arrow stands elsewhere, scroll to “[Recovery Mode]” by pressing the VOLUME UP button.

-> my screen was just black. I waited a bit, then I pressed the POWER button.
Then I had the CWM screen with the grey textile fabric.

  1. Wait until the recovery has booted (it has a grey textile fabric background)
  2. Scroll to "install zip“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button.
  3. Scroll to "choose zip from /storage/sdcard1“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button.
  4. Scroll to the file starting with "FP1-4.4.4-z3ntu“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button.
  5. Confirm by scrolling to "Yes“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button. The installation of KitKat 4.4.4 should now start, you should get to see the green android with an open belly and an installation log below.
  6. Once completed, the display will return to the recovery. Scroll to " +++++Go Back+++++“ by pressing the VOLUME DOWN button and confirm by pressing the POWER button.
  7. Confirm "reboot system now“ by pressing the POWER button (or scroll there once more pressing the VOLUME DOWN button and then confirm).
  8. Confirm "No“ by pressing the POWER button (or scroll there once more pressing the VOLUME DOWN button and then confirm) in order to keep the new recovery.

-> made all that.

  1. Your new Android KitKat 4.4.4 should now boot. :slight_smile:

-> my phone is booting… well, not really. It’s stuck between LOADING (on a blue screen, hope not of death :p) and a shiny ANDROID “logo”.

Waited ~10 minutes before I shut down the phone by pressing the POWER button a long time.

By pressing the button again, had the same loop loading/android. Still looping since I started this post.

I’m starting the procedure again (by pressing volumeup/power together).
-> have the CWM screen.

Should I retry the procedure or thy another option ? (wipe data / factory reset ?)


#42

I had that too with one of the spare parts phones. What solved it was a hard reset in the new recovery. Just press power and volume up again to get there.

@urs_lesse maybe a notice to (optionally) clear data before step 8 should be added to your guide? It can be done later too if one runs into issues.
I upgraded two phones without wiping and it still worked fine.