Android KitKat (4.4.4) for FP1

In a hurry here, feel free! :slight_smile:

1 Like


No, you’ll then have KitKat 4.4.4. and CWM recovery, just no data.

Thanks, it worked !

Thanks to all, great job, having a “new” FP with security updates is AWESOME.

edit : Play Store
I didn’t manage to install the Play Store. Didn’t work with opengapps (both with their app & downloaded APK - the least one (pico)) -> with app, no connection to server, with APK, problem with the downloaded file)

Didn’t work either with Apkmirror (with latest build of Play Store). PS is installed, but crash when I open it. Did several attempts.

Finally, when I try using the website of the PlayStore for previously installed apps, the PS told me they are installed (even if not).

By the way I found all my apps using other stores (known ones, like apkmirror, F-droid), even the FP1 launcher (it made the grey bar disappear).

1 Like

You don’t need Play Store, you can use Yalp Store from F-Droid. The only thing you will not have are paid apps and Play Services that many apps depend on for push messages.

1 Like

I don’t have a FP1 to test it, but there may be an option within the widgets settings for it:

  • Longtap on the screen - three icons should appear at the bottom for background / widgets / settings.
  • select settings
  • disable “show search bar”

@z3ntu It’s awesome that there is now an Android version for the FP1 with current security fixes. I didn’t expect anything like this anymore and was quite surprised when I saw this today - great work!


Strange behaviour since yesterday : the battery dropped significantly with very moderate usage (wifi browsing for 30’, standby most of the time).
At the end of the day, the battery was at ~40% of charge (usually it looses 10-20% a day).
During the night, it lost 21% (usually : 1-2%). This morning, after I left airplane mode, I could see the battery level losing 1% every ~3 seconds (countdown ! :p)

Finally it stopped decreasing at 6% before going down again after I put wifi on, until it just shut down at 0%

This is the first time since the update I have this behaviour. Battery usage was quite normal before (I recharged the battery maybe 3 times since the update).

How old is your battery?

It’s the original one. 4 years, 3 months :wink: I never had this behaviour before the update. Having a quite light use of my phone, usually I charge it every 4 - (6) days.

Yesterday, when I lost quickly about 20% of charge after some browsing, battery usage, according to my phone, was for the screen (set to automatic brightness).

Now it’s fully charge (2 hours needed), I’ll monitor the battery level.

It’s normal for batteries to degrade after some time (that’s why non-replaceable batteries should be forbidden IMO). Usually that’s after about 2 years, but since you haven’t charged it every day, it is quite probable that only now you see the effects of degrading.

As this issue didn’t occur before the update, my best bet is that is update related.

That said, battery usage was quite normal these two past days. I would say, better management in standby, more drain when using the phone.

I’ll check the post about compatible batteries :wink:

Unfortunately I have not been able to track down the cause of my 4.4.4 battery drain so far. As soon as I switch my primary FP1 back to Macadamia, it gets 2-3 times the mileage (read: the battery lasts 2-3 times as long). I have switched back and forth twice now, same pattern each time.

4.4.4 vs. Macadamia:

To make things further complicated, my secondary FP1 does not show any difference between 4.4.4 and Macadamia with regard to battery time – this secondary phone is just lying inactive (airplane mode) on the shelf though.

Now gradually trying to switch all secondary FP1’s settings to my primary FP1’s settings, step by step, in the hope to narrow down which function/setting/app lets my primary FP1 drain so much quicker under 4.4.4 than under Macadamia.


Yes, it worked. Without wiping data/factory reset I ended in a boot loop. Then I retried the whole procedure now with wiping data/factory reset and I succeeded.

Signal won’t work if I install it through Yalp.
Is it possible to install openGapps? And if so, is it ARM and 4.4?
Do I need TWRP?

1 Like

If you’re talking about CPU architecture, most definitely ARM.

I’m pretty sure I’ve linked opengapps with the correct version and architecture in my initial/top post

1 Like

Sorry, I didn’t see it. Thank you very much.
Please, may I ask you how to install OpenGapps?

It’s a flashable zip, so via the “install zip” option in the recovery

@z3ntu Thank you so much. It works. Another Fairphone 1 upgraded!

1 Like

About battery life, here is how my phone behaves, one month after the upgrade.

Battery life seems to be better. Charge decreases slowly, but is a little bit erratic.

Usually I charge my phone when the battery is at about 40-60% of charge.

The last time I let it go, just to see how much battery life I could get.

On the 6th (!) day, the battery was at 43%, at the end of the day.
When I woke up, it was at 13%.

That morning was 7 days and 1 hour since the last charge. OK, I just sent some SMS, had a few calls, checked my emails on 3G maybe every morning, but that’s all. Airplane mode every night.

Before the upgrade, the battery level was more linear. It usually decreased by 10-15% a day (I put it on charge every 4 to 5 days).

I think it’s nice for a 4 years, 5 month’s phone (original battery).

I just have to charge before it reaches 40%, just to be sure.

I a really have a new phone, so glad !


I wished I could report similar progress, but I have only gotten five days out of 4.4.4 in my primary FP1 once – using the battery charged in my secondary FP1. Now that I charged the battery in the primary FP1 again for the first time, it’s already back to the 1% per hour hemorrhaging (without any use other than an active SIM card) :disappointed: I had already done two battery resets in the course of my efforts to get it to normal discharging rates, I really don’t want to stress the battery that way so soon again.

Having ruled out all sorts of individual apps as the culprit, I was temporarily thinking it was about the SD card. But the externally (in my secondary FP1) charged battery then suggested it’s not the SD card.

I have tried so many things to change this pattern and without any usable conclusion, I’m about to give up and go back to Macadamia or even Kola Nut. Battery lifetime and listening to music from a large SD card is more important to me in my FP1 than the ability to go online.

Version FP1-4.4.4-z3ntu-0.0.2 has been uploaded with the following changes:

  • Android security patch level: 2019-01-01

I’ve also added a (relatively) complete list of security patches that have been applied to the sources, to the top post.