English

Android KitKat (4.4.4) for FP1

osupdates
kitkat
Tags: #<Tag:0x00007fefbec16f00> #<Tag:0x00007fefbec16b90>

#63

Version FP1-4.4.4-z3ntu-0.0.2 has been uploaded with the following changes:

  • Android security patch level: 2019-01-01

I’ve also added a (relatively) complete list of security patches that have been applied to the sources, to the top post.


#64

Another one saved from recycling!!! Or sitting in the drawer.

Thanks to everyone involved for producing the various bits of this and sharing - including the step-by-step.

I used ADB (loaded the recovery.img first, went into recovery mode and then sideloaded the file using ADB.exe). All worked ok until I rebooted and got into a cycle of doom - showing the blue ‘loading’ page and then the black ‘android’ page…

I reset into recovery mode and selected ‘factory reset’ and then restarted. It worked fine. No problem with IMEI loss (but then the motherboard of this phone was ‘bricked’ when I bought it and I had to do some jiggery pokery to set IMEI, when I cannibalised it, so maybe that was retained somehow).

I think my battery life is draining quicker now, but that’s a bit subjective so far (just a few hours of heavy use while I transfer / add apps). I’ll get my smashed-screen spare FP1 out and see if I can compare.

I just hope I can hold out until the mythical FP3 makes an appearance (and I hope it’s [around] the same size as FP1!).


#65

Just repaired a FP1 and updated it to 4.4.
Another FP1 prolonged its life.
Thank you @z3ntu


#66

Thank you @z3ntu !! I just updated my FP1 and works like a charm!

Note: I didn’t lose my IMEI :slight_smile:


#67

Simply AWSOME!!

That’s what is soooo exciting and fantastic about Fairphone: the people supporting it.
All those fantastic folk called angels acting as support-crew on- and offline and the ones like @z3ntu developing stuff still even for the FP1 and sharing it with the community!

Thx a lot to all those great people out there!


#68

Dear all,
I am a proud owner of FP1U. I’m trying to install KitKat 4.4.4 according to @urs_lesse 15-points guide (thank you so much) . However, I get and “Error: aborted installation” once I tried to install from sdcard either FP1-4.4.4-z3ntu-0.0.1.zip oFP1-4.4.4-z3ntu-0.0.2.zip.
Moreover, I used the terminal emulator in order to get a backup but now I am unable to know how should I use the recovery.img file since from the menu option “restore” I am unable to find such file.
Can anyone help me with this issue??
note: last calling to save a FP1U prior to a FP2 acquisition… :wink:


#69

Have you tried the original instructions from z3ntu’s original post? My instructions are actually just meant as an alternative way in case you run at a dead end with ADB & Fastboot.


#70

Do you mean that?



Not, I haven’t tried yet. In fact I find them a little more difficult since I have no idea what adb is.
Nevertheless, thank you so much also to z3ntu for his job!!


#71

Finally, I got android 4.4.4. with the 2019-01-01 android security patch. Thank you very much to @urs_lesse and @z3ntu for their development. Again , a FP1U still useful and Google-free :wink:


#72

Having encountered the bootloop myself now that Lidwien reported (thanks!) a while ago, I added a sentence to the final step of the 15-point instructions. I guess I didn’t experience it originally because back then I switched the FP1 from 4.4.2 (Macadamia) to 4.4.4. while now I switched from 4.2.2 to 4.4.4.


#73

I’ve uploaded FP1-4.4.4-z3ntu-0.0.3-pre5.zip with many applied frameworks/av security patches (so media-related stuff). I’ve tested a bit and Netflix, NewPipe and Music playback seems to work but please test everything you can think of about media playback (I already had to revert one patch because it broke playback in NewPipe)!

After that I’ll make a proper release (0.0.3) with February (or March, depending on when I do it) security patches.


#79

Many thanks to @z3ntu for the system update for this lovely old phone and @urs_lesse for the easy instructions. I now have a working 4.4.4 fairphone useable for daily use. Keep it up!


#80

Did somebody test media playback with this new build? I’d love to hear test results.


#81

Hi, I might test the build sometime this week.
However, I have a question beforehand: When I upgraded from stock FP Android to your 0.0.2 release I had to wipe my user data because the phone ended up in a boot loop.
If I now update from 0.0.2 to 0.0.3 the chance that I need to wipe the user data again should be pretty low, correct?

Thank you for your work :slight_smile:


#82

If you’re staying on 4.4.4 builds, it should be fine - at least I didn’t wipe between flashing my builds for testing.


#83

Hi, I just installed the 0.0.3pre5 version. I don’t have that much multimedia software installed, but NewPipe, VLC and “Vanilla Music” (F-Droid) seem to work fine (even at the same time :wink: )
Also Cythara and Tuner (both musical tuner from F-Droid) seem to pick something up.

On the other hand I had trouble with the play store and had to reinstall the open gapps zip, but everything seems to be okay now.

Sidenote: The denied/allowed per application permissions were reset. EDIT: Only Google Apps?


#84

Hi @z3ntu,
I think I will be also able to install it during the weekend!
Just with a security purpose: if I want to maintain all the apps and data I have right now on the phone, it will be right using the backup&restore option, right?
I will let you know regarding the version!
Though, I am looking forward to install the new release!
Thank you very much


#85

Avoid the backup & restore app - it backs up surprisingly little. I’m not even sure what it does backup, just that it’s far less than what people assume.
I’m not sure whether restoring apps from one Android version to another is entirely foolproof, so you may run into some odd issues (or it may be fine). If you want to have a shot at it, Titanium Backup has often been recommended for the FP1.
Make sure to check whether personal files (photos and such) are also backed up. If in doubt, do a manual copy. Don’t store backups (only) on the phone itself.


#86

For me the pre-installed backup & restore app worked flawlessly when migrating from 4.2.2 to 4.4.4, however I only use it for contacts, calendar and messages (i.e. solely for data from other pre-installed apps). Photos, music and videos I backup manually to my computer all the time anyway.


#87

Hm… anybody else has problems accessing (writing?) to the sd card? Many apps report the device is write protected… but I don’t see how.

Tested with two cards already. (This was already a problem with 0.0.2)