English

Android KitKat (4.4.4) for FP1

osupdates
kitkat
Tags: #<Tag:0x00007fefc1bb50b8> #<Tag:0x00007fefc1bb4e10>

#88

Done! Upgraded to 0.0.3pre5 version. At first glance it seems performing all as expected. Writing on SD card, apps permissions, internet radio app, antenna pod (as media apps) … Let me know if I can help regarding some specific apps.
And, of course, thank you so much for your great job @z3ntu.


#89

Upgraded to 0.0.3pre. Had to do a full wipe in order to stop the bootloop, but since all seems to work fine so far.
WiFi, BT, GPS, etc are OK, media Playback as well.
Thanks for keeping the FP1 alive @z3ntu !

The one thing I cannot get to work is the X-Posed Framework… (Installer states: API 19 not supportet ???)
Anybody else trying? Ideas what I did wrong?


#90

That likely means you are trying to install a version of X-Posed intended for a different Android version.


#91

One would think so…
In the meantime I figured out that the regular X-Posed installer is NOT working on Android 4.4.4…
Solution is found on XDA:


Hope this is useful to somebody.


#92

Having struggled to figure out what caused my battery drain under 4.4.4. (see here, here, here, here), I cannot provide 100% certainty about the exact cause now, but I believe I can finally say that I have been able to overcome it. I don’t get record duration out of the battery under 4.4.4 (4.2.2: 10+ days), but the difference is now significantly smaller (20-25% less). My most recent two discharging cycles:

I strongly suspect that starting the original migration not from Jelly Bean (4.2.2), but from Macadamia (4.4.2) to Fairphone z3ntu OS (4.4.4.) is to blame. After numerous cross testing coming from that migration path, I noticed this interesting pattern at one point: While a full battery charge done in the FP1 kept giving me a meagre 3 days battery life at best, battery life was dramatically better (more like what’s it’s now, see above) when the same battery was charged either in a different FP1 or in an external charger. To make sure it wasn’t about an imperfect USB port or any other hardware weakness, I switched back to 4.2.2 and promptly got the previous level of 9-10 days out of the battery again. Eventually, I did give 4.4.4 one final shot, starting directly from Jelly Bean unlike before.

So … I cannot exactly express what caused the drainage, but it strongly seems that something disturbing the charging process under Macadamia might have been carried over in my original migration. It was taking the same time for a full charge as under 4.2.2 and 4.4.4, and yet the battery would discharge much quicker (and btw, also by an unnaturally steady rate going by the battery life graph).


#93

Hi there,
I am in need of some assistence, I’ve tried the 1-15 steps trying to go from 4.2.2 tot 4.4.4 (0.0.3) but it’s not working. My fp1 keeps ending up in the loop (between black screen ‘android’ and blue screen ‘loading’) sometimes it will ask me for the password to decrypt storage, and then it will go back into the loop.
I’ve wiped the data already serveral times. I went through the steps 5-15 already a couple of times each time with the same result. Going through the steps seems to go well, but the rebooting is not working.
Any one any advice on what I can try now? And would it otherwise be possible to go back to kola nut?
thanks!


#94

Just to be sure,
Did you do step 7a

This step was needed by my Fairphone 1 to be succesfully install Android KitKat (4.4.4) .


#95

Hi Lidwien,

thanks for your response, Yes I did a few times and also the wipe cache partition at some point, just to be sure. Now I am trying the 0.0.2 version to see if that maybe works.


#96

Is your storage unified (no split into internal storage and phone storage)? Other than that, I can only guess it might have to do with your encryption.


#97

Yes storage is unified. I am also afraid that the problem might be the encryption. Is there from this point on an option to disable the encryption?
I do get some info at wipe data/factory reset that gives me the impression that it not working as it should:
– wiping data…
Formatting/data…
Error mounting /data!
Skipping format…
Formatting /cache…
Formatting /sd-ext…
E:unknown volume for path [sd-ext]
Formatting /sdcard/.android_secure…
Error mounting /sdcard/.android_secure!
Skipping format…
Data wipe complete.

The file FP1-4.4.4-z3ntu-0.0.2.zip gives the same problem.


#98

I haven’t got a clue about this. But @z3ntu as the expert here might be able to chip in.


#99

Thank you for thinking along!
Well I managed to get my fp1 working again. I reinstalled Kola Nut, then it asked for the encryption pw, but the pw was not working anymore. Strange. I once more wiped data and asked for factory reset and that did the trick the phone was back to factory reset. After that I could install KitKat, just as the 15 steps guide instruct. But then working with KitKat I found out that I still couldn’t update Signal, and that was the reason why I wanted to update the OS. The Signal app stopped working a few days ago as an update wasn’t possible anymore. The Signal site explains that Signal works under OS with a minimum of 4.4.4.
Anyone any idea why an update of Signal is not possible with this KitKat package?
Have a nice day!


#100

After install of Android KitKat (4.4.4) I installed OpenGapps via the “install zip” option in the recovery.
I can send messages through Signal real time. But Signal receiving messages automatically won’t work.
The only way to receive messages is starting Signal manually.
This happens with version FP1-4.4.4-z3ntu-0.0.2 and with FP1-4.4.4-z3ntu-0.0.3-pre5.
It’s a pity that I can’t remember if it worked with version FP1-4.4.4-z3ntu-0.0.1.

After installing OpenGapps again I have no problem any more with Signal. Sending, receiving and getting notifications are working now.


#101

Thanking all involved I was able to upgrade my FP1 from Jelly Bean (4.2.2) to Fairphone z3ntu OS (4.4.4.). I did need to do a hard-factoryreset as I got the bootloop, but that was no problem.
Being now the proud owner of an up-to-date FP1 I do have one issue that bothers me very much: the battery drain is excessive (around 5-6% per hour while in standby).
Looking at the battery information on the GUI it seems there is something wrong: it states the screen to be responsible for over 90% of the battery usage. While I do see the screen actually going off (dark).
I did a (soft) factory reset and a ‘battery reset’, but both made no difference.
Any clues about this issue?


#102

Has this happened over at least two consecutive battery cycles with neither a reboot nor a shutdown in between? Do you use an SD card with a lot of media files on it?


#103

Yes/Yes
Upgrade has been carried out some two weeks ago or so by now, and the draining (related to the screen (???)) remains the same.
There is an SD-card with a lot of media files, but they haven’t even been used since the upgrade to 4.4.4


#104

I asked about the reboot and the media files because e.g. the default MUSIC player (once launched) triggers a complete scan of all storage (including the SD card) for media files. As far as I know, the system app doing this is “media storage”. For me this scan can take up to three hours (I have a 200 GB card 90% filled with music). However, once this scan is complete, it should not restart from scratch unless the phone was shut down for more than a few minutes. So this doesn’t seem like the cause for your drain.

Now I can only wildly guess. Do you have any app installed that adds a “layer”, “skin” or “theme” (on top of the usual visible user interface) that might keep the screen active while just appearing off? If it’s not that, you might need to have a look case by case on your installed apps and try to detect a “wakelock” – i.e. an app is kept permanently running even when you are not actively using it.


#105

Not as far as I’m aware. Only a few apss have been installed, as this is now a ‘secondary’ phone.
I’ll have a look at the debuglogs from Greenify.

Otherwise: would/could it be useful to upgrade to the latest pre-xxx version?


#106

hi all together, i managed it to update to Kitkat because some apps does work anymore on icecream sandwich. it works well. But: i´ve one question how to install the googleplay store, i can´t manage it, i tried to download older version on APKpure and the installation runs well but the app won´t run. does anybody know how?


#107

Hi Fairphoners,

I have a GPS-Question:

I updated my FP1 to Kitkat 4.4.4 some days ago…

Before this (in the very beginning of my FP1-Days) I optimized GPS with all the stuff postet in the www. and got a fix after about 16 seconds.
After the years this changed to 40 seconds despite nothing at my system had been changed.

Now after the Kitkat-Update it takes about 70 seconds.

As I tried to optimize everything again I recognized that there seems to be no EPO-Option any more.

Is this (70 seconds) poor GPS a matter of fact using Kitkat?

Or is there something I can do? What happend to EPO?