Fairphone 2 TWRP 3.3.0-0/3.3.1-0 can't decrypt Android 7/8/9 encryption

As TWRP 3.3.0-0 is out and still can’t decrypt Android 8/9 encryption (as with LineageOS 15.1/16.0) …

@z3ntu: I saw that adding support for this in TWRP 3.2.3 didn’t work out on the Fairphone 2 in the end.
Is there any hope that support for this encryption could be brought to 3.3.0 now?

Edit: TWRP 3.3.0-0 also can’t decrypt Android 7 encryption. (Thanks, @Volker)

Edit: TWRP 3.3.1-0 … no change.


I really don’t know what the problem is - I’ve spent a bit of time trying to get TWRP to build with the omnirom 9.0 tree but that didn’t work out. I’ll try building it in an omnirom 8.1 tree next, maybe that solves the problem…


@z3ntu: it would be great seeing a working decryption with twrp! if i can be of any help please let me know. i can bring basic coding knowledge, an installed android sdk & the willingness to learn :slight_smile:

did you try this fix with 3.3.0-0 (would this be applicable?) https://github.com/omnirom/android_bootable_recovery/issues/224#issuecomment-454282103


What does “can’t decrypt” mean in your case? Does it not accept the correct decryption pattern oder does it not even show the pattern request to decrypt/mount data?

I’m running a system with /e/ (version 0.5-201905018716, resp. Android 7.1.2). Decryption in TWRP 3.2.3-0 works perfectly, but when using TWRP 3.3.0-0 it even doesn’t ask for decryption password/mount data partition.

1 Like

It doesn’t ask for the password/pattern.
Message on the terminal output is:

“Could not mount /data and unable to find crypto footer.”

Oh, ok. I hadn’t checked with my LineageOS 14.1-encrypted data partition, but I did now, and I can confirm your finding. It’s the same as with the newer encryption.

@z3ntu: TWRP 3.3.0-0 also doesn’t seem to be able to decrypt Android 7 encryption. So regarding encryption, the Fairphone 2 TWRP 3.3.0-0 seems broken in general.


I can confirm this, I needed to downgrade


Spend now nearly a day with testing and installation of Lineage 16.1. Came from encrypted 14.1. which was updated to 15.1. Encryption after update to 15.1 still working.
Made a complete TWRP backup prior to starting next steps.

Can report as follows in short without details and hope that I remember to all steps – all steps made under Ubuntu:

  1. Additional backup under Ubuntu with:

sudo adb backup -apk -noshared -all - f backup.ab.

Worked and created „backup.ab“ file

  1. Formated under TWRP „data-partion“

  2. TWRP was still available after reboot, but of course all data and encryption were lost.

  3. Updated TWRP to twrp-3.3.0-0

  4. Installed via TWRP lineage-16.0-20190520-nightly. Did not yet try to encrypt but tried to install data back with ADB command :

„adb restore backup.ab“

No success! There was no failure report but after procedure there were no backed-up apps and no further other data on the phone. Phone was as it was before.

  1. Encrypted phone. Encryption worked without problems and phone rebooted directly and to TWRP. TWRP now suddenly shows data-partion with „0 MB“ despite the fact that there were some data. Furthermore, back-up of data not possible. All other partitions were backed-up.

  2. Made again a backup with ADB as TWRP does not backup data-partion. But backed up only APPS installed additionally with „adb backup -apk -noshared backup.ab“ Attention: Prior USB-debugging necessary!

FP2 asks now for password as the phone is encrypted and saved apps under „backup.ab“ on my computer.

  1. Deleted the newly installed APPS again.

  2. After „ sudo adb restore backup.ab“ and answering passcode question there was no failure notification but as above no apps returned.

Summary for my tests:

a) TWRP and Android 16.1. successfully installed

b) Android 16.1. can be encrypted and phone boots to recovery and also restarts but

  • no backup of „data“ possible (neither with TWRP nor under ADB). Other partitions seem to be backed-up. I do not want to try Titanium as I have no Google and do not want to root.

If nobody finds a better solution I have only 2 options:

Option 1: Use encrypted phone without backups

Option 2 : Use unencrypted phone with backups and hope that there will be any solution in future.

I moved your post here because of the emphasis on encryption and because of the TWRP version you chose …

See topic title. TWRP 3.3.0-0 on the Fairphone 2 seems broken regarding encryption.
You could try the custom TWRP 3.2.3 available here …

1 Like

A post was merged into an existing topic: Custom TWRP 3.2.3 to decrypt Android 8/9 encryption

Same for TWRP 3.3.1-0 unfortunately.


But this here and the changelog fortunately kept my hopes low :slight_smile: .


Just for the reference, here is the link:

This version doesn’t even offer to mount /data… No question for the password at start, not even the option of data in “mount partitions”

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

Added Fairphone 2 to the topic title, because a custom TWRP 3.3.1-0 for the Fairphone 3 is out, and it can decrypt.