FP2: Fairphone Open 19.05.2 release

The modem/baseband files should be exactly the same as in Open 19.02.1. Also the proprietary blobs are the same. Please let us know if you notice any difference! In fact, we didn’t change anything on the modem layer since the upgrade to Android 7 (18.10.0).

Thanks for the comment, we will keep that in mind and explicitly mention if we change anything on the modem files.


Hi, during installation appeared console log “Running Recovery Commands” with error message “unable to find partition for path ‘/system’”.
The installation however is gone successfully (in about 10 minutes).
Should I get scared from this message? thanks

I have trouble flashing opengapps again.
Before and after I updated TWRP in the official app, I get the zip verification error. I downloaded the current version of opengapps. Why is this so difficult with every update? And how do I solve this problem this time?
If I don’t uninstall all gapps I use, the phone drains >25% battery per hour and gets very warm.

1 Like

Which TWRP version is installed now?

For troubleshooting purposes you can make absolutely sure not to use Fairphone’s TWRP by booting a signed image of community TWRP without flashing it, see #twrpwoflashing.

Sadly my FP2 is not happy with the updates tp 19.05.2.
I had reboots before updating, but now the phone is rebooting several times a day.
The drain on my battery is huge and the phone is feeling very warm. In the app Temp. monitor the reading for pm8941_tz is around 58 °C and rises to temps between 60 °C and 75 °C when I am using the phone.
A full battery lasts for 5 hours only when hardly used.
I am thinking of running the update again this evening, through the manual update which I found on https://code.fairphone.com
But first I will re-install Gapps.
I switched my phone of overnight and now I am charging the battery again.
Screenshot of the battery last evening.

First impression after re- installing Gapps is good. Phone is at temp 53 °C.
Of course I used the Official TWRP app to get the right TWRP version to be able to re-install Gapps.

I have trouble flashing xposed. even if I do not check the “check verification” flag, it checks and declines… Did xposed work for the rest?

Before the update I used twrp-3.2.3-0, as it was neccessary for the last Open OS update.
I got the latest version in the TWRP app which is twrp-3.3.1-0.

My problems sound very similar to Lidwien’s, but I have not managed to solve it yet.

UPDATE: Problem solved by updating to latest TWRP and directly booting to it. At the first try, the phone was plugged to a charger, thus automatically rebooting after shutting down (this must be a common bug?), and booting Open OS instead of TWRP. So even with the official TWRP app, it’s still a problem that you must directly restart into it after flashing, otherwise it seems to get overwritten by the old version again.

If your TWRP version is 3.1.1-0 (Fairphone’s own TWRP bundled with Fairphone’s OSes), try community TWRP, I still recommend 3.2.3-0 as the most reliable version.

1 Like

Had the same issue. Updating to TWRP 3.2.3-0 solved it. :slightly_smiling_face::+1:

Hy there,

My FP2 runs FP Open OS 19.02.1, and the update won’t work. The download just won’t start, the process is stuck at the very beginning : “Please wait” and no data get loaded.

Does anyone have the same issue ?

Yes, I have the same problem and you’ve got no answer. Frustrating!

Have you read the whole thread?

If there is a solution, could you be so kind and tell me, were I can find it.

You could try to clear cache (and maybe even data) of the updater app and then try again.

Having planned to update during summer vacation, I’m happy that I finally did it and that it went smoothly. Manually installed a clean version, updated to the latest TWRP version, then added OpenGAPPS pico and Widevine. No problem whatsoever, all apps could be reinstalled to their latest versions and are working perfectly. Battery consumption has never been so low. Solved the problem of the latest versions of some apps which wouldn’t work anymore under Marshmallow. Thanks Fairphone for another job well done! :clap:


For the record, a video streaming app called OCS Go wouldn’t work without Widevine since an update a year ago. Problem now solved.

1 Like

The update to Fairphone Open 19.08.1 is released.