FP2: Fairphone Open 19.08.1 release

I’m really sick and tired of this in the meantime. With my FP1 I had hardware troubles already and now with FP2 OS I’ve got the very same problem as described above. Phone overheats after update. Set up the phone completely anew, updated TWRP to 3.3.1-0 and tried to install open_gapps-arm-7.1-pico-20191029: zip file corrupt. After downloading Open GApps via my laptop and transferring it to the phone, same result. I don’t know what to do anymore. I have been spending minimum a total of 8 hours for fixing this

Did you confirm TWRP 3.3.1-0 is really installed now?

TWRP not wanting to install Open GApps would be a behaviour of the older TWRP version bundled with Fairphone (Open) OS currently.

After a newer TWRP got installed, you have to reboot right into the newer TWRP to let it make itself resident. If the OS gets rebooted first instead, it will restore its own older TWRP version.

A workaround in case of problems with this would be to boot a newer TWRP without flashing it, see #twrpwoflashing .


Yes, on top of TRWP it says 3.3.1-0. I also tried installing TWRP via Fastboot on my Mac still the same result: zip file is corrupt

I just figured that TWRP is updated after going into recovery mode right after installing the TWRP update. When I then reboot my phone and then boot it in recovery mode again, the update is gone again. Do you have an idea why?

When you boot a newly installed TWRP, it will ask you to allow modifications to the system partition, else it can’t prevent to be overwritten again.
Did you allow this?
Can’t think of anything else, installing TWRP worked reliably for me so far.

Concerning the ZIP to install, you will have to make sure that “Zip signature verification” is disabled in TWRP’s settings. Normally that’s the default.

You mean installing Open GApps (TWRP doesn’t come as a ZIP file, it’s an IMG file)?
If you have fastboot working, you should have the adb command, too.
You could put TWRP into ADB Sideload mode and try whether adb sideload ing the ZIP file from the computer to the phone makes a difference.

Con aggiornamento 18.08.1 riconosce WIFI ma non connette, quando sarà disponibile un update di correzione? Grazie


1 Like

I use Fairphone OS, this means I don’t need OpenGapps, right?
Battery drain has been a problem since one of the updates. Don’t remember which one. Long ago. I waited for the next update (the one which took months). It’s become worse as time passes by.
I’m fed up of regressions.
I’m sure, my next phone won’t be a FP, but another Android refurbished one. I changed from refurbished iPhone to FP. I won’t change OS again.

Did you ever do a factory reset to see if this solves your battery drain?

I tried everything!
The whole battery guide. And as I’m rarely on route, mostly can charge it. But otherwise, I doesn’t last a half day, if I use it (Firefox, whatsapp, e-mail, etc.)
The worst is camera (different apps used and not being able/difficult to focus, if close to the object) so I don’t take pics anymore. Just, If battery is over 60% and I’m able to charge in near future,as sometimes a pic costs 20-30% battery, but not always)
Opening Whatsapp if battery is lower than 30% is also like “suicide”
I don’t even know, if it’s worth, trying with a new battery anymore
Also, since I changed the bottom module, it doesn’t “Brumm”, when connecting without battery to “reset”, so I don’t know if it really"works".

I’m afraid of updating every time. I think, It can’t become worst and it might fix a bug… and then came the wifi problem (changing place, new wifi won’t show), the 1%d screen (which is not just cosmetics as asserted at the bugtracker, as it is time consuming and annoying, if something is needed prompt), the wallpaper change…

How old is your battery?

Do you mean that it does not vibrate? The vibration motor is in the bottom module, a bottom module change should fix that.

Bought End Jan 2018. Then the motor in the new bottom module is broken? But the phone vibrates when in vibration modus. It doesn’t vibrate when I connect it to the charger without the battery (as explained in the battery guide)

I’m sorry, I misunderstood that. If your vibration works otherwise, then the module should be OK.

Which battery guide did you use? This one does not mention vibration. There might be other suggestions in that guide which are worth a try.

The rest of the story sounds like a broken battery. I’ve seen that old batteries can suddenly start to discharge quickly when a power-hungry app is opened - probably caused by a sudden drop in voltage. Your problem is similar but more extreme.

1 Like

Seems they reedit. But that process. Thanks for the help.

I finally managed it to update TWRP it properly! When now trying to install open_pps-arm-7.1-pico-20191114.zip it tells me that the Zip file is corrupt. I also tried to install older versions of Open GApps but then it told me that I must download the correct version for my ROM: 7.1.2 (SDK 25). Do you know what to do?

Which TWRP version is installed now?

Else …

I installed version 3.3.1-0 and Zip signature verification is disabled

Could the message be correct and the ZIP file really be corrupt? Did you download it again and/or check the MD5 checksum?

Else … TWRP would be left to check, I guess. I’m not a big fan of the TWRP 3.3.x branch for encryption reasons, but I don’t remember problems simply installing ZIPs with these versions.
Anyway … If it was me with this problem, I would try 3.2.3-0 for comparison … not only because it has proven to be rock-solid and stable, but also because you don’t even need to flash it, you can just download a signed TWRP 3.2.3-0 image and boot it without flashing it, see #twrpwoflashing … ideal for a quick, unintrusive test.

I downloaded Open GApps again and now it worked :raised_hands: Thank you so much!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.