Updating LineageOS 16.0 for microG via TWRP + feature test

Definitely. Amen to that :wink: .

Upgrade from 15.1 without any problem (installation via twrp recovery, system, data and cache deleted). Many thanks to the developer section! :+1:

Just to understand well: What happens or is it working with the following steps:
I come from lineage15.1+microg

  • Saved my pictures etc on computer
  • Backup data partition
  • Wipe everything
  • Install Lineage16+microg
    -restore data partition

Do I have all my apps etc back in this case or will they be broken or cause any other headache?

after upgrade from 15 to 16 Sim Card does not work. :slightly_frowning_face:

Edit: Battery was at 12% and despite the power saving mode, the battery was down to 0% after 6 hours. After switching the phone on while charging, I was able to activate my SIM card again. Maybe the phone was too hot after the upgrade and led to these malfunctions?

Otherwise great work @chrmhoffmann :slight_smile:

here everything works fine :slight_smile: just that restoring the backup doesnt work … :frowning:

And: It’s no longer possible to adjust vibration intensity… very annoying. In 15.1 it was at least possible for typing.

LineageOS 16.0 for microG installed from scratch via custom TWRP 3.2.3.
The custom TWRP 3.2.3 currently can’t reliably decrypt Android 8/9 encryption for me, but it’s a better shot at it than official TWRP 3.3.0-0 (Releases), which seems to have trouble with encryption in general..

So, in the absence of reliable TWRP decryption and thus no data partition in a TWRP backup unless custom TWRP feels like it … adb to the rescue.
You can backup data including Internal Storage using
adb backup -apk -obb -shared -all -system

I’ll make that -noshared for me because MyPhoneExplorer is much faster syncing Internal Storage via WiFi than adb is via USB. You can have a look at what all these options do by executing
adb /?

If you want to confirm what’s in the resulting backup.ab file, then put abe-all.jar from https://github.com/nelenkov/android-backup-extractor/releases/ into the same directory as the backup.ab file and make sure you have whichever Java installed, then in the directory execute
java -jar abe-all.jar unpack backup.ab backup.tar password
(obviously replacing password with your password if you gave one).
You can have a look into backup.tar with e.g. 7-Zip on Windows or with the tar command on Linux/macOS.

Edit: I just tried a restore of this now 3-step backup (MyPhoneExplorer - ADB - TWRP, and restoring the other way around) on a different Fairphone 2, and it’s not looking pretty.
Mainly adb restore doesn’t do what it’s supposed to do, so I had to create the backup.tar file to then copy the contents of it over to the phone and with the Files App on the phone go through every App folder and install the base.apk (from the “a” subfolder) to get the Apps back.
I mean, the pieces are all there, but … meh :slight_smile: .
Perhaps it would be more smooth on the same phone the backup is from? I still hope we’ll somewhen have a TWRP with reliably working decryption again.

  • lineage-16.0-20190513-microG-FP2.zip (Changelog)

    • Security patch level:
      up to date (Settings - Security & location - Trust)
      2019-05-05 (adb shell getprop ro.build.version.security_patch)
    • Vendor security patch level:
      out of date (Settings - Security & location - Trust)
      2018-04-01 (adb shell getprop ro.lineage.build.vendor_security_patch)
  • addonsu-16.0-arm-signed.zip (for Root access)

  • Encrypted phone (LineageOS 16.0 encryption)

The following things work for me so far:

  • call / be called
  • send SMS / receive SMS
  • internet via WiFi
  • internet via mobile network
  • location
  • compass
  • screenshot
  • main camera (new module) works correctly with Open Camera, stock camera App doesn’t operate the flash correctly (same behaviour as with LineageOS 15.1).
  • main camera (new module) video recording
  • selfie camera (new module)
  • selfie camera (new module) video recording with stock camera App works correctly, Open Camera records only black if surrounding light is too dark or changes into too dark while you move (same behaviour as with LineageOS 15.1).
  • USB connection to PC / MTP
  • alarm (Confirmed: no alarm sounding with volume set too low.)
  • MyPhoneExplorer 1.8.11
  • Root access (Settings - System - Advanced - Developer options - Root access)
  • WiFi hotspot
  • Bluetooth (data connection, music playback)
  • FM radio
  • weather (Yorecast with my own OpenWeatherMap API Key, Weather Widget)

For reporting bugs see the bottom of this page.


I had the exact same conclusion a while back… From that time I use Titanium Backup to migrate my apps + their data from one OS to another :slight_smile:

1 Like

Any idea why there is still no update for los+microg?

The updater says there are two new releases on may 22 2019 whereas the listing here [1] says a mtime of the previous two releases on may 22 2019. What’s going on?

[1] https://download.lineage.microg.org/FP2/

Installation of the new updates is not possible for me… was also surprised why they are not listed…

I asked it in the XDA Forum and here the answer:
“Oops may, 22 is the date of some file system modifications on the server. I see no ROM newer than may, 15.”

1 Like

Hi all!

Thank you for this usefull thread.
I made a clean install of LOS + microG 16 from LOS 15 + microG, wiping everything and using Titanium Backup for apps and data.
I installed Magisk and all is working fine but…
I have three main issue.

  1. Yalp and F-droid can’t install app. Actually F-droid seems to be not able to connect to repo because I can’t see any app in latest tab. To install an apk I have to go to the directory where it has been downloaded and install from there. Dose anyone have the some problem?

  2. It seems microG is outdated because some apps works only in a older version than the newer one Yalp downloads for updating. Is anyone else experimenting the same issue? I visit microG official page and it confirm I have the latest version.

  3. LOS updater can download but not install updates. I tried it with the update of 22 May 2019. @cricksterr, are you talking of this one?

With LOS 15 I had none of this issues.

Thank you all…

1 Like

You can flash both via twrp and then they have system rights to install apps automatically…

There is no recent release of offical micro-G, but I think, there will be one soon…
Several things are now implememted and further developed, so it is again active

Yes, the one from 13th May is the latest. Hopefully this hiccup will be solved soon.

Thank you for your answer @cricksterr!

OK, but… Why? I mean with LOS 15 I didn’t need system rights for these apps… Is it the only way? In LOS 15 there was this bug with Magisk, but I already tried without success.

What do you mean?

I flash yalp directly after the install of LOS 16+microG (+ privileged fdroid), so I don’t know any other behaviour.

That there is active development again.
Marvin, the main developer, is funded now forthe developement of microG.
So there is some action on Github, but no official release yet. (Maps API, SafetyNet, parts from the Nanodroid fork implemented…)

Ok, thank you very much for your answer!



“Build server is online again!”


“We build in the order specified in https://github.com/LineageOS/hudson/…-build-targets

… Right now the most current build from today is for d801 … 8 nightly devices to go until building FP2, if I read that right.


Find7 is done, too. So FP2 should be next :grin:

via Updater, I get an installation error…
does that happen to anyone else, too?