Help! TWRP and bootloader not accessable

Hello all, I need help:
After updating to the beta version of Android 7 my phone crashed after a few minutes of use. So I decided to install LinageOS 16.1
I had some troubles with the zip files, but finally it worked.
Then I tried to install the GApps - but not made it right.


  • LineageOS working without GApps
  • TWRP not accessable (on start 3x Vibration, then blue LED and Fairphone-Logo forever)
  • Bootloader not accessable (same as TWRP)
  • ADB seems not fo find the phone although it is listet in the manager

Can anyone help me?

Sounds a similar predicament to here and device is in "fastboot mode"

Does the phone work at all when in Fastboot mode? Because I can work with lineageOS.
Unfortunatelly the descritption is for ubuntu, and I work with windows. I’ll try to figure out what to do, but if anyone has a descritopn/manual, please link!

That is the bootloader, also known as fastboot mode.
Normally you would boot into it by keeping Volume - pressed while starting or rebooting the phone.

Please confirm: When you keep Volume + pressed while starting or rebooting the phone, you don’t get into TWRP?

If so, just boot into this fastboot mode and install TWRP again … … section “Fastboot Install Method (No Root Required)”.
I still recommend 3.2.3-0 as the most reliable version.

Luckily not true.

What do you want to do with ADB?

How so?

1 Like

Thank you for the suggestions.

When starting the phone I can either press Volumen + or volume - while pressung start. No matter which one, i get 3 vibrations, then the blue LED and the fairphone logo, and nothing else happens.

I installed the twrp apk and downloaded the image you suggested, but i cannot install it as the phone is not rooted. In the options i can only choose not rooted or only ADB.

Regarding the other things i wrote: i tried many things to geht the phone running, it seems as if most oft them are riddiculous…

You have a working fastboot mode … and I specifically pointed out the

APK? Root?

Never mind … different approach, with screenshots … Please do steps 1 to 3 (not further!) of the following guide and report any errors …


I’d like to hug you very tight!
You saved my phone from a very deep drop from the window!
Now I can access twrp again and do whatever I need to do.

Sorry for some confusion, I was annoyed and nervous when nothing worked and then I seem not to be able to read correctly…

Again thank you so much for the help!


If you still want to install the Google stuff …

  • ARM (not ARM64) - 9.0 - (App package of your choice, minimum to get the Play Store would be “pico”)
  • Download the ZIP and simply install it with TWRP
  • LineageOS isn’t a Google certified Android like Fairphone OS is, so to play it safe with your Google account, you want to have a look at Google’s device registration for the use of Google Apps and services on non-certified Android OSes …
1 Like

Hello, I have a similar problem with my phone here: Fairphone 2 help needed: no os, no twrp, no usb debugging anymore - just fastboot mode
After frustrating hours of or work I was at least able to boot into twrp without flashing using the given description here:

But I have no idea how to continue from this point now as I have no OS left on the phone. How can I bring an image on the phone again that just bootet into twrp wihout flashing. The only thing I have now is the twrp access with nothing else left on the phone? Can you help me? I would really appreciate any help I can get at this point!

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.