Open OS 19.05.2 update : unable to re-install OpenGapps with TWRP 3.1.1-0

After Fairphone Open OS 19.05.2 update : I’m still unable to re-install OpenGapps thru Team Win Recovery Project (TWRP 3.1.1 -0) . I downloaded ( ARM / Android 7.1 / nano selection under ). When booting in TWRP and install it : “zip signature verification failed !”. I tried to update TWRP thru twrp-3.3.1-0-twrp.img without success : still remaining in 3.1.1-0.
Did I miss something ?
Can you help ? … my fairephone is not usable since important battery drain ( < 1h ) - I know that it’s linked to the Google Apps which are expecting to run thru OpenGapps

Probably you missed this bit …

“Note many devices will replace your custom recovery automatically during first boot. To prevent this, use Google to find the proper key combo to enter recovery. After typing fastboot reboot, hold the key combo and boot to TWRP. Once TWRP is booted, TWRP will patch the stock ROM to prevent the stock ROM from replacing TWRP. If you don’t follow this step, you will have to repeat the install.”

The “proper key combo” on the Fairphone 2 is just keeping Volume + pressed when starting or rebooting the phone.

1 Like

I used the TWRP app from the playstore to get an updated version of TWRP.

No I did it properly - even using reboot in recovery inside TWRP: in this case reboot is stuck in fast mode…

No way to use TWRP on Play Store since OpenGapps is not working :wink: Versions on F-Droid, YalpStore or Aptoide are below 3.1.1-0 … so not sure it’s coming from TWRP itself

In any case, there’s still #twrpwoflashing.

1 Like

I have Gapps installed, and I used the playstore in Gapps to download and install TWRP app that is offered there.

TWRP - Team Win Recovery Project

Official app developed by Team Win for TWRP. Use the app to alert you when new TWRP versions are released for your device. When a new version is available, download it using the app and install it (root users only) without rebooting to recovery.

You can find a brief guide and more details about the app here:

The Official TWRP App does not require root to perform version checking, however, additional features are available such as image flashing if you grant root permissions.

Currently the app is only able to flash images from internal storage. We will add the ability to use additional storage locations very soon!

We will be developing additional features in the near future, so check back often!

Please do not ask us to add TWRP support for your device. We simply do not have access to all of the devices or the developer resource to port your device for you. You can port your own device here:

1 Like

… read 1st post please: Gapps is not working anymore after 19.05.2 release. I want to reactivate it …

There are more ways to get an app from the playstore. Either by going to the playstore through a webbrowser. Or get the right app through a webbrowser by another source.

1 Like

I have the same problem.
I downloaded a new version of TWRP but flashing to recovery with the official TWRP app fails. Install adb tools on my laptop, so can update TWRP via that method. But unable to download the complete image of OpenGApps 7.1 ARM nano… every download fails…

After every Fairphone Open update you need to flash a newer version of TWRP to recovery, boot to recovery then reinstall OpenGApps…

But until I can update OpenGApps Play store is not working, and the battery drains in about 2 hours from full… rather than lasting a full day before this last update…

Successfully downloaded the OpenGApps update with the opengapps app, but can’t see it once booted into recovery (with TWRP 3.3.1-0)… any ideas?

Finally success to install OpenGapps ARM / 7.1 / pico zip file ( ) instead of nano after updating TWRP by downloading 3.3.1 thru this link . Everything working again.

I give up, TWRP just can’t see the zip file to reinstall opengapps, despite having updated TWRP… battery life renders phone virtually unusuable… opting for factory reset and starting again… Fairphone Open with nano variant OpenGApps was perfect…(much better performance than Fairphone OS) a pity this update ruined it… better integration please…

Where did you put it?

If an SD card in the phone isn’t mounted automatically when TWRP is started, you can try to mount it afterwards in “Mount”.

When you reach the main menu, TWRP will make Internal Storage (and the SD card if there is one and it isn’t incorporated into Internal Storage) available to a computer via USB connection (at least if TWRP has access to Internal Storage, the 3.3.x TWRP versions have trouble with encryption, TWRP 3.2.3 would work for this), you could copy the install file to the phone then.

By default TWRP shows Internal Storage when you want to select files in “Install”. You have to “Select Storage” and switch it to SD card, if the install file is located there.
By default, TWRP shows ZIP files, but if you perhaps set it to “Install Image” before to e.g. install a TWRP image, you would have to switch this back to Install ZIP files for TWRP to show ZIP files in the file selector.

Thanks @AnotherElk
It seems that having updated TWRP (to 3.3.1-0 via adb has permanently updated the TWRP version).

From TWRP 3.3.1-0 the Downloads folder (where I originally placed the OpenGApps update) was not visible. I tried using a abd push command to put it in other folders /data/, or File Manager on the phone (via root) to /sdcard/ and the zip file was still not visible in either location. Note: my phone is encrypted. I tried mounting other locations but it wasn’t possible.

I tried giving the OpenGApps app root permission to install the update, but that didn’t work either, it just rebooted to recovery - nothing more.

So then I tried entering TWPR recovery (now 3.3.1-0) and sideloaded the OpenGApps update:

On the phone: Advanced > ADB Sideload (and swipe)
On the computer: adb sideload

The text on the phone said OpenGApps installed successfully and the phone rebooted, asked for password, but is now stuck on the “Change is in your hands” animation…

Any ideas?


So, using the latest TWRP should not give you access to Internal Storage, if encrypted. Just use TWRP 3.2.3.

For how long?

Thanks so much @AnotherElk,
The phone was stuck for at least 20 minutes…

So I have booted the phone to fastboot mode
downloaded twrp-3.2.3-0-FP2.img, renamed it twrp.img and then

sudo fastboot flash recovery twrp.img
sudo fastboot flash recovery twrp is now visible /

it installs core apps etc successfully

the phone reboots and…

and everything seems to be fine, thanks so much, hopefully the battery life will be as it was before the Fairphone Open update

Incidentally twrp-3.2.3-0 is now the default, so it looks like I won’t need to flash recovery again to install OpenGApps!

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.