On data backup attempt with TWRP, error "Failed to mount '/data'"

Hi, I am trying to back up my user data before giving Android 7 a try, but currently stuck on OpenOS 18.04.3 because TWRP is giving me an error when I try to backup data.

The list of partitions shows Data as 0MB in size. Selecting only it and swiping to backup leaves multiple errors on the console mostly saying:
Failed to mount ‘/data’ (Invalid argument)
and one saying:
Failed to mount storage
amongst other lines before it tries to start the backup, then aborts and cleans the backup folder.

What can I do to get this to backup correctly, or am I doomed to risk losing data with an ‘upgrade’?

P.S. is the flashlight reboot workaround nonsense still a thing or fixed yet?

1 Like

You’ll be happy to hear that the flashlight backup bug has been fixed in the new update.

As for your issue with backing up your data, this usually occurs when the device is encrypted. Is your FP2 encrypted?

1 Like

… in connection with a TWRP version too old to handle encryption.
If this is the case, just follow the guide thoroughly, it includes “Installing latest TWRP”, which would fix this.

Aye of course, but I’ve always had it that way and I’m sure that I’ve managed to do a backup before.

OK I’ll give that a try once I can download it. I thought there might be something else I was supposed to do like entering the login key or deactivating it.

A TWRP version with encryption support will simply prompt for the decryption password at startup and give a success message on the console once this worked.

I’m sure it’s done that before for something, but don’t know why it wasn’t doing it this time. Maybe that only worked for an update. This is version 3.0.2-0

This is the version which is bundled with your version of Fairphone Open OS.
Fairphone’s own TWRP versions bundled with Fairphone’s OSes don’t support encryption up until now (even the TWRP 3.1.1-0 bundled with Android 7 currently doesn’t).

Community TWRP on the Fairphone 2 supports encryption since version 3.0.3-1.

1 Like

Same problem here, though my phone isn’t encrypted. I have downloaded the latest TWRP 3.3.1-0 but it also shows

Failed to mount '/data' (Invalid argument)

I also tried to use the adb interface to TWRP:

~ # ←[6ntwrp backup SDBOM
Setting backup options:
Compression is on
Digest Generation is off
Updating partition details...
Failed to mount '/data' (Invalid argument)
 * Total number of partitions to back up: 3
 * Total size of all data: 575MB
 * Available space: 8009MB
 * Backup Folder: /external_sd/TWRP/BACKUPS/faa9f6a5/1970-01-02--08-41-28
Can not create '/external_sd/TWRP/BACKUPS/faa9f6a5/1970-01-02--08-41-28' folder (Read-only file system).
Failed to make backup folder.
Backup Failed
Done processing script file

Any ideas how to do a full backup using TWRP?

  1. Try TWRP 3.2.3-0.
  2. Be aware that there’s no such thing as a “full” backup using TWRP, see https://twrp.me/faq/backupexclusions.html.
1 Like

Thanks for the info. I think I have copied (via MTP) all relevant folders from /sdcard/ (which, if I understood this correctly, is the same as /data/media/ and contains all photos etc these days).

TWRP 3.2.3-0 was indeed able to mount my /data partition, which the newer TWRP 3.3.1-0 couldn’t… do you have any explanation why this is the case?

Not really … the 3.3 branch on the Fairphone 2 as of now just seems troubled somehow.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.