English

Bad radio performance caused by oxidation and scratchmarks on display module backside contact pads

Tags: #<Tag:0x00007f05da32b680> #<Tag:0x00007f05da32b540>

Over the past months I noticed that the radio performance of my FP2 got worse and worse. I often got “no service” or “emergency calls only” despite the phone showing full signal for a few minutes when switching flightmode on and off again.
I read posts reporting similar problems in this forum and quite often the antenna connector was mentioned. When I opened my FP2 I discovered another source for radio problems:
For shielding and grounding purposes the back side of the display module is connected to the main part of the FP2 at several locations (red and orange circles on the right image). Each connector consists of a spring contact on the FP2 touching a silvery contact pad on the display module back side. When I opened my phone I could immediately see scratch marks on the pads that looked almost like the contact has ploughed into the metal on the display module. The marks are even clearly visible on the picture here (original image iFixit - creative commons). When I cleaned the pads with isopropanol I got another surprise: Black gunk (oxidation?) on the cloth and the pads looking shiny again. After this procedure signal strength has returned to normal without any problems since! Disclaimer: You clean your phone at your own risk!
I would highly recommend to use harder gold plated pads as it is common in RF equipment in future display module designs. My FP2 is not often directly exposed to moisture and I only took it apart three times, so in my opinion this kind of scratching / oxidation should not happen in normal use.
Although there are three contacts (red circles vs. green circles) that are directly related to the antenna module I would always clean all pads. Radio signals are a strange thing and even a bad contact in another area of the phone can potentially have a negative effect on the radio signal.

19 Likes

A post was merged into an existing topic: Taking Fairphone 2 to USA

Anyone else who have tried this? I might do this as my next try to get better reception, though i do not want to ruin the warranty since i got my phone just a month ago.

I would not do it while under warranty. The oxidation problem occurred when I had the phone for 1.5 years. Yours is much newer.

2 Likes

Neat! My LTE stopped working (could only get Edge) since tuesday. Opened the phone and cleaned it with that stuff you use to clean your glasses (I also cleaned my SIM cards). Not all oxidation is removed, but I got LTE back right after. (Please note my phone is no longer under warranty though.)

3 Likes

That’s great! I hope that at one point there is going to be an improved front/display panel with gold plated contacts…

1 Like

I already tryied this tip a few weeks ago with any positive result.

Now I have been doing some other tests, and seems that maybe there is some contact failure on SIM1 socket, when the SIM is inside SIM2 socket it works better… I will test it a few days to see if it really works, and how to solve SIM1 failure.

1 Like

Just did this (with plain disinfection alcohol and a qtip) and seems to have worked. Thanks !

3 Likes

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.