English

Random disconnects of both wifi and mobile data: hardware or OS?

Yet another connectivity issue! An extensive one. :slight_smile:

My FP2 (in use since 2015) has had connectivity issues for about half a year now. Not just wifi or mobile data but both: every hour or so, I loose internet connection, regardless whether I’m on wifi or mobile data. Sometimes it resolves spontaneously after a few minutes, sometimes a switch to flight mode and back resolves the problem, but most often, a system restart is required to restore connectivity (which drains the battery terribly). The weird thing is: even while connection is down (e.g. I cannot open webpages and apps complain about a lack of network connection), the connectivity indicators in the upper right corner appear normal : a (nearly) filled wifi icon and a filled triangle that says ‘LTE’ for mobile data. The problem seems quite similar to this: Very poor network connectivity, except that mine is not limited to mobile connection.

The network issues usually occur right in the middle of things: often while I’m lazily surfing the internet (suddenly can’t open the next page) but also right in the middle of video calls, both at home and on the road. To illustrate the inconvenience, in the last few weeks it occurred 1) while retrieving a train ticket I just purchased in an app (I knooow I should do that before boarding the train), 2) while trying to show a tram ticket (different app) to the ticket inspector and 3) in the post office while trying to use a mobile ticket to send a package. Seems my phone just doesn’t like tickets.

Connectivity in general has always been poor; at work, for example, I don’t have wifi/data/mobile connection in places where others do, and regular phone calls indoors quite often fail. Mobile data transfer is usually slow. This lead me to believe I might have an antenna problem, similar to what others describe, but I don’t know much about hardware: do all of these connections (wifi/phone/mobile data) share the same antenna, the one flanking the battery? Apart from hardware, I could image such issues being caused by the OS as well.

Phone info:

  • FP2
  • LineageOS 17.1 version 13-11-2020 + openGApps pico
  • located in Belgium, mobile provider Mobile Vikings

Fixes I already tried that did not help:

  • clean LineageOS reinstall
  • upgrade LOS from version 16 (Android 9) to 17 (Android 10)
  • switch from MicroG to OpenGApps (pico)
  • religiously installing weekly LOS updates hoping for a magic fix
  • playing around with router settings (2.4 GHz only, 5 GHz only, dual band) >> I assume our router is not the problem as I experience the same wifi issues at work and at other people’s places, and the connectivity issues are not limited to wifi.
  • disabling power-saving modes
  • enabling/disabling wifi scanning for locations, then turned it on again for Coronalert app
  • turning Blokada on/off (and completely deinstalling the app)
  • monitoring network connectivity using the F-Droid “Network Monitor” app >> Ironically, it shows an error and pauses log collection during network failures. :sweat_smile:
  • cleaning contacts as described here: Bad radio performance caused by oxidation and scratchmarks on display module backside contact pads >> Seem heavily scratched and quite some black oxidation came off - maybe a moisture issue due to taking my phone along on a 12 km bike ride to/from work twice a day? I obviously don’t handle it in the rain, but some moisture might occur.
  • borrowing a T5 screw driver from work to check the antenna as described here: How can I reconnect loose antenna cable >> No visible damage, cable firmly connected at both ends.

…and now I’m at a loss, I don’t know what to try anymore. Would anyone have any suggestions to what the issue might be? If people that are more technical than me (@ar.do?) think this might indeed be an antenna issue, i could try to get my hands on a new cable and fix it like this: How can I reconnect loose antenna cable. But I’m in doubt as the cable looks undamaged. If there’s moisture damage or internal broken connections (due to rough use?), repairability might not be superb.

Last week, the main microphone in my bottom module broke down as well (again, third time) (could well be due to moisture or me dropping my phone). As I’d love to be able to call people during covidtimes, this makes my problems a bit more urgent. I’m basically wondering whether it’s worth spending another €30 on a bottom module in the hope my connectivity issues will get fixed, or whether I should get ready to part from my FP2 and get a new (FP3 or refurbished) phone… Open to any suggestions and thanks in advance for your help!

2 Likes

@Loesje, good work documenting the issue you have. First I’d like to say I think you display much more technical know-how, and I may not have much to add. I can say that the aerial running along on the right hand side of the phone is not also responsible for the WiFi, as I took it out and was still able to access WiFi, which suggests that the issue you have is either a software issue or two hardware issues (or combination?). I have replaced the aerial on two phones,and it seems to have worked on my friend’s bit not on mine. It’s still a fun project if you are interested and a new aerial is not that expensive or resource intensive to make.

Second, in terms of the bottom module - that’s a bit of a bother! I replaced the bottom module under a year ago, but sound has never been the best. I tend to use a headset with a microphone for calls over WiFi.

I am experiencing the exact same issue on my FP2, it was the same with a former one, both running Lineage OS. Enabling flight (airplane) mode for at least 60 seconds and disabling it afterwards usually works, but the same mess starts to happen again after some time…

@ar.do, thanks a lot for this extra info! If the antenna cable next to the battery is not involved in wifi connection, it’s probably not causing my connectivity drops (and therefore no use to replace it), except in the unlikely case that I have two independent hardware issues that result in the exact same behaviour for both wifi and mobile network connection. Would anyone happen to know whether the wifi and mobile data share other hardware components e.g. on the motherboard? If not, this might be a (solvable? :grinning:) soft-/firmware issue after all.

The experience of @DeepSea seems to point to that as well. Would LineageOS be the bugger after all? I didn’t think so at first, as other people in the forums that complain about connectivity mostly run FPOS or FPOpen - but maybe this specific combined wifi-mobile-issue is indeed LineageOS-related? If no one else has a magic solution or new input, I think I’ll try a downgrade to FPOS or FPOpen Android 7 or 9 this weekend.

1 Like

Should you switch back to FP OS, please let us know your experience. Thanks in advance.

Did you have wifi issues as well?
Because I have/had random disconnects of mobile data on my FP@LOS17.1 (this is a known issue on LOS 17.1), but never over wifi (I had some on FPOOS android 7 though).

1 Like

There were times when neither WiFi nor mobile data worked, but that could have been due to a weak reception. I will observe that scenario a little more attentive from now on…

1 Like

Did you happen to observe these kind of wifi disconnections in the meantime? In my phone’s case, the issue is very hard not to notice, as it occurs at least once or twice within like half an hour of trying to read the news. :sweat_smile:

I did not get the chance to switch back to FP OS yet, hard to find a suitable moment in covid times.

But in the meantime… Last Friday, my screen suddenly only showed me multicolored snow. Reboots and battery swap did not help, but after I took the display off, cleaned the connectors with 70% ethanol and let them dry before reassembly, the display worked just fine again. However, ever since (so over the last 2 days) the battery is draining like crazy. Where I usually get about 24h of use after charging to 100%, I now see 100 to 0% drops in about 8 hours of moderate use.

This could of course be completely unrelated to my other issues, but I’m now starting to get suspicious of basically anything. Would I have a general “connector issue”? Did I break some important hardware component the last time I dropped my phone? Do I just have bad luck? Or is this my fairphone telling me it’s time to move on? :thinking:

No, unfortunately not. Does your carrier support VoLTE? (Mine does not.)

Like it is shown in this thread?

If so, that might be a hardware (core module) issue. The screen connector had been revised with the latest batches, so your FP2 might be from an earlier batch produced.

You could disassemble the phone and see if either the core module or the display were bent slightly. Do neither use force nor pressure to straighten it out!! The risk of damaging other electrical components is very high! (You have been warned!)

1 Like