Lineage-16.0 (Android Pie) Nightly

There are some new sim lock fixes coming in next nightly. I think some people here complained about dual SIM / lock issues."master-fixes"+(status:open%20OR%20status:merged)



Any update on this? Still waiting for my LOS16 upgrade until the Wifi issues are fixed :slight_smile:

I have the latest modem firmware, Ubiquiti AP, I run LOS 16 (microG version) and I cannot confirm your issue. You can disable multicasting and IGMP on your APs as well. Maybe I did this, not sure.

AVM Fritz!Box 6490 Cable (Fritz!OS 7.00) and 7590 (Fritz!OS 7.01) on my end with 2.4 and 5 Ghz activated … no WiFi issues for me, and yes, by checking this I just saw there are further Fritz!OS updates available.
Are you on Fritz!OS 7.xx already?

Something of interest in the router’s event log perhaps (System - Ereignisse)?

At home I see quite some automatic channel switches because the router at home detected “a very strong jamming source” or “priviledged user (e.g. RADAR)” on the channels it wanted to use for WiFi … but that doesn’t translate into issues for me, just saying that the event log could be an interesting read.

1 Like

First of all, thanks for @ChuckMorris and @AnotherElk for their help, I was able to wipe and install the latest LineageOS 16.0 (build 29 July 2019) and restored my apps.

However, there is a major problem: My wifi and mobile data connections have become absolutely atrocious.

For wifi, my home, work, and other public connections that didn’t have any problems when I was on Lineage OS 15.1 have become almost unusable. My Fairphone 2 would claim that there is a strong connection, but my communications apps would say the server connection has been lost, and my web browsers (such as Firefox for Android) would give non-stop “server not found” errors. Other apps also appear offline.

If I try all of the above for an hour, including cold-booting my phone, the wifi connection might suddenly work for a couple of minutes but stop working completely again. This includes 2.4 and 5 GHz connections in uncrowded environments, and no other devices have problems.

For my mobile data connection (I’ve tried 4G/LTSE, 3G, and less), I get practically zero connection, which would suddenly work for literally just a few random minutes per day. All apps claim that I don’t have an Internet connection. This is despite getting “full bars” indicating a strong data signal from my mobile service.

In both cases, I made sure the firewall is completely turned off to no effect. Turning off the phone completely and rebooting didn’t help much, either.

This is making my phone practically useless apart from making old-school phone calls (which still works).

I also see sporadic reports of bad wifi in this thread, but not sure if they are related.

Anyway, are these known issues? How do I fix them? Or should I downgrade to 15.1 for now??? Thank you.

This for me is the thing that doesn’t quite fit in the picture.
Do you get any indication of G or E or H or LTE with the full bars?

If not, perhaps the full bars icon is wrong and you should have a look at the antenna connection and the contacts …

I remember back with LineageOS 14.1 on rare occasions I lost all mobile network connection by simply leaving the range of my home WiFi … and the status icon would show me full bars without any indication of G or E or H or LTE, which should mean a mobile network connection with plain 2G data speed, but there was no connection at all.
Turning flight mode on and off or a reboot fixed these, and this didn’t happen for a long time now, so probably your case is different, but you never know …


Today I’ve done a complete re-install with LOS 16 (came from 15.1 encrypted with 14.1) and haven’t had any problems so far. Time will tell if the occasional reboots persist.

I already love LOS 16 for having built-in DNS-over-TLS support which saves me from running Nebulo etc. in the background. Apart from that it seems pretty un-changy.

Big thanks to @chrmhoffmann! :love_letter: :wink:


Thank you @AnotherElk and everyone.

I have done further testing over the past few days, and I can confirm that not only do my mobile signal show full bars, LTE also shows up under the icon like this:

I tried the trick of turning airplane mode on and off to “reset”, and it seems that the mobile data connection would work very briefly because I would suddenly get a series of incoming messages (from IM apps) that I missed. However, after about 3-5 seconds, even though the icon still says LTE, all Internet connectivity would be lost again.

In addition, even though I would receive a few messages just as I turn airplane mode off, my web browser wouldn’t be able to open any webpage even during those 3-5 seconds either with timeout or not found errors.

To reiterate, my Fairphone 2’s mobile data connection (which is 4G/LTE) worked perfectly fine until I wiped LineageOS 15.1 and installed 16.0. The main symptom is that while it would show full bars with LTE underneath the mobile data icon, my phone has no Internet connectivity unless connected to Wi-Fi. I do not have any firewalls or VPNs active on this phone.

Can anyone provide further advice or suggestions?

And would it help if I created a new thread for this?

Thank you!

maybe it’s a stupid question, but did you check APN settings? After clean flashing LOS16 I had a very different (and short) list of APNs


Thanks @lklaus, I didn’t even know there’s a thing called APNs!

I managed to find a Settings page called Access Point Names under my data connection-related settings. It listed about seven of these APNs with the top one selected. But I have no idea what any of this means and if it can inform my current predicament. What do I do???

Your carrier should have a help page for the correct settings. Probably a help line exists also, where you can ask for help. Also, many offer to send the settings via SMS, though that did not work for me with my provider and the FP.


For info, in case anyone runs into a similar problem:

After updating to the latest Lineage version a Cordova app on my device wasn’t working anymore and the log showed the following error:

`'file://' has been blocked by CORS policy: No 'Access-Control-Allow-Origin' header is present on the requested resource."`

After some investigation I found the following bug report:

Issue 991107: [SOLVED - see the Summary section] cordova app could not make XHR requests from a file at the first WebView76 run.

I checked the chromium-webview version on my device: 76.0.3809.89

According to the issue this is the version which has the problem. It should be fixed with version 76.0.3809.111.

Since Aug 2 the master branch for chromium-webview is used, so I guess we have to check here for the update.


After some searching, I managed to find APN settings for my provider. They looked very different from what was shown in the APN settings page, I wonder why???

Anyway, after applying the APN settings I found, my mobile data connection appears to be working!! I will continue testing for a while longer with fingers crossed.

Thank you @lklaus!


Another question… should the FP2 with LOS16 be able to use GLONASS satellites? I’m only getting a fix on GPS, I see that GLONASS is detected but not used

1 Like

Also using LOS16, and I do have connectivity problems as well.
After the first (clean) install I had to manually add the APN because LOS
wouldn’t implement the ones retrieved automatically.
If I don’t use the Internet connection for some time I get randomly kicked out of the Wifi.
Since the last update (17th August) I encounter random app freezes (Spotify, Facebook et al) did anyone do so as well? And if so, can provide a solution?

It depends on the smartphones cpu, which systems can be used. It is the same at my Galaxy S5 with Snapdragon 801: Glonas and Beidou satelites are seen but not used. Galileo satelites are even not recognised.

1 Like

Looks like there’s a problem with today’s nightly update ( : when rebooting after update, my phone was stuck on the boot animation for about 3 min and then automatically rebooted into recovery.
Did it 3 times before I eventually downgraded by flashing yesterday’s update (20190823) through TWRP. No problem, my phone started nicely after that, no data lost.
Anybody else experiencing this?


Since LineageOS releases are being built automatically and not beta-tested, problems can go unnoticed before a release.

As a recent example, you can currently still see in the Changelog that the build at 2019-08-14 11:12 UTC is now “no longer officially available for download”. And this was not the only case.

Exactly the same issue here: No boot after updating to 20190824. Had to sideload 20190823 to fix it. What is the correct way to report broken builds so they get removed? The GitLab bug tracker?

Note to self: Only update LineageOS when you’re not in a hurry (and have a PC nearby)…

1 Like

Or have a previous working version on your SD card just in case.
Or do a TWRP backup before each upgrade…
Things we should but only rarely do… :wink: