Update 8901.4.A.0016.6: Bluetooth control broken on various devices

Hello,

I have bought sometimes ago the earbuds (True Wireless Stereo) from Fairphone and i recently can’t pause music when i’m listening to it while double tapping

It’s not really a big deal but it’s annoying. I tried to pair/unpair, clean the earbuds but still not working I can only change the mode from earbuds or adjust the volume.

Did someone had this problem before? Any suggestions?

Thanks a lot !

7 Likes

I have the same issue with all of my headphones (Bose Sports Earbuds and Genki Waveform) and it worked before I installed the most recent update from August 5th 1-2 days ago.

All controls worked perfectly fine before that update and now none of them work anymore.

So far I only see you and another French speaking user who have the same problem, so I dunno if that’s a big issue for more people or just a very few.

But yeah, that’s quite annoying. With their current speed with rolling out updates it’s gonna take a while before we get a fix, I assume/fear.

5 Likes

Same here, also with different headphones (Bose QuietComfort 35 Series 2 and Tozo A1). Cannot pause/unpause after this week’s update, though strangely I can still skip. In addition, the headphone’s volume is now independent from the phone’s volume, which is also annoying.
I’ll go ahead and report the issue, though in my experience all FP support ever does is ask for the build number which they already have and then recommend to do a factory reset which is a huge hassle and doesn’t help.

3 Likes

Why would they know which OS and version you are using. They will only respond if you are using the default OS and will always ask you to update to the latest. So by asking they are just checking you are using the latest rather than asking you be sure you are using the latest.

There is the option to do a safe mode start to rule out custom apps and if that doesn’t provide any relief then a factory reset is the minimum to get to a common ground as the only test they can do to compare is with a basic unit they have.

If they cannot replicate the issue, it’s reasonable to consider you have a fault, if they can they will log it as a software issue on their side.

A factory reset will only be a hassle for those who have not set up an option to save personal data and that also have custom apps to re-install. The actual reset is pretty simple.

And of course sometimes it is helpful, probably very often with some problems.

Because I entered all this information in the form when reporting the issue.

They should try to replicate the issue before asking users to spend hours reconfiguring their phone, especially if multiple users are reporting the same issue (via tickets or the forum). And of course they should have proper QA so that issues like this one don’t make it into a release in the first place.

Yes, the reset is simple, and (most of) my apps are re-installed automatically. But most apps (and I use many) do not store all the information in the online backup to get the same configuration back automatically, so I have to reconfigure almost all of them. For my banking app I have to ask the bank to send me a letter with a new initialization code and until then I can’t make any transfers (German banking apps… don’t ask).

5 Likes

Which bank? Postbank? I don’t like doing factory resets so I never did it with my Fairphone, so I have no idea if my bank is gonna be annoying like that or not.

Sparda. But this is getting really OT…

1 Like

Me too! - No bluetooth control on my three devices since I ‘downgraded’ to 8901.4.A.0016.6 yesterday (5th Aug 2022 security update), I usually check in here to read what’s been broken before applying updates, but foolishly I didn’t this time. Arrgh!

So I wonder if Fairphone added anything to this update that might have caused this breakage or is this all Google’s handywork? Here’s hoping the next patch resolves this.

Update : I have just sent a bug report to Fairphone support. As it is using their on-line form, I won’t expect a reply in a hurry if at all!

Update 2 : received an automated reply telling they won’t deal with my support ticket until I provide proof of purchase (from my reseller) despite the fact I sent them proof of purchase for a ticket I created a couple of years ago. I sent this latest ticket while being logged in so why do they need it again? I’m not claiming under warranty?!

If anyone out there has purchased their FP3 from FP and has this issue, maybe you will have more luck reporting this issue than me. All I see are FP throwing obstacles in my path. If I find my proof of purchase, I will send, if not my report will not be dealt with. Arrrgh x2!

4 Likes

Same here; can’t pause, can’t skip and volume control is independent from phone’s volume. With both my JBL GO 2 bluetooth speaker and JBL TUNE125BT earphones.

I’ve purchased my FP3 from the fairphone webstore and will try to report the issue too.

6 Likes

That’s great! Thanks for doing that.

I eventually found my proof of purchase (seemingly requred each time for those of us who purchased from a reseller), so sent that off. Hopefully someone will get to read my report as well now. While I hope a patch is hatched quickly, I’m not overly optimistic based on past peformance.

2 Likes

Just a +1 on this topic. Having the same problem here. Getting quite tired of something new breaking with every update.

Headphones are Taotronics SoundLiberty 92.

5 Likes

In a similar case reported here, it’s reported that a long press on the control button of the headset launches Google assistant instead of the expected media function. Is anyone else seeing this or have info?

1 Like

Another user who has the issue:

Getting more and more people who share that they have the same experience. Hopefully tells Fairphone to hurry up with a fix.

3 Likes

With Bluetooth issues, one step before that should be the network reset in the Settings (resetting Wi-Fi, mobile data and Bluetooth).
It’s a hassle, too, e.g. for Wi-Fi passwords which have to be re-entered and for Bluetooth devices needing pairing again, but less hassle than a factory reset.

3 Likes

Do you happen to know whether WiFi credentials stored in a Google account are deleted when doing this? If they’re not and they’re used to reestablish the connection after the reset I’d give it a try, though I don’t have much hope.

Today I used my FP3 in the car and, not unexpectedly, nothing apart from audio playback started on the phone worked. The title of the currently playing song wasn’t displayed in the car; the car’s entertainment system didn’t even seem to know that something was playing and happily displayed a play (instead of a pause) button that of course did nothing.

Since very obviously the problem aren’t the TWS earbuds but the latest FP3 update, shouldn’t this topic be renamed and moved to the FP3 section?

1 Like

I don’t know, sorry.

1 Like

It’s not just earphones. Happens to bluetooth connections in cars, too, at least in my Skoda.
There’s no song title shown in the displays, you can’t skip forward from the car any more (neither from touch displays nor from wheel-steering).That seems to verify, that this is not an issue with my car only:

Doesn’t work. Tried that, even did a factory reset on my cars media and phone settings. Changed AVRCP from version 1.5 (default) to version 1.4, then to 1.3, then 1.6. Nothing helps. That update broke the bluetooth connection.

3 Likes

I have a similar but slightly different issue. When I connect my Fairphone ear phones they now try to start a call to the last person I called, which is rather err annoying not just for me but the other person too. Has anyone else had this issue?

I also have issues with them pausing audio and video unexpectedly whilst in use.

1 Like

Had to hunt a bit, but found it:

3 Likes

Can confirm on JBL headphones, a Polestar car and a speaker (could check the make and model, but I don’t think it changes the point).

Definitely started after the update.