Update 8901.4.A.0016.6: Bluetooth control broken on various devices

I have the same issue. Volume buttons of the bluetooth headset still work, but the media button does not. Single click for play/pause has no effect and double or tripple click also has no effect.

I use these all the time, so this is super annoying. I already had issues with one update regarding display brightness and that took months to be fixed. Not sure if I want to live that long without the media button.

Is there a way to revert the upgrade? Is there a workaround to make the buttons work again?

I don’t know any way to revert the ‘upgrade’. Google don’t make that sort of thing easy.

Does your headphone volume control still control your phone volume or are the two levels now independent of each other? In my case I have “Disable absolute volume” enabled in developer options so phone and bluetooth levels were already independent. When the headphones did work the phone volume, I couldn’t get the level right as the steps were too great. Level was either too loud or too soft.

No reply from Fairphone on my report ticket opened 11:50 Wednesday. If I have time I will try and phone them tomorrow to see if they are aware.

Same issue with my FP3, with both BS Boss and Galaxy Buds+.
Both with PocketCasts and Spotify.

I’ve tried almost all suggestions in the links below.


  • Restart Your Phone
  • Forget Device and Pair
  • Check Bluetooth Device Details
  • Reset Network Settings (which will indeed forget all your wifi passwords).
  • Reset Bluetooth Settings / Clear Bluetooth app cache and data
  • Checked for updates


  • Refresh the Cache Partition
  • Factory Reset.
1 Like

So what about this setting?

No, the volume is also split now. Before the volume buttons of the headset controlled the phone’s bluetooth volume. Now, it doesn’t. It still changes the perceived volume though.

1 Like

Just trying to work out if the volume is controlling the phone or just the headphone volume as nyi states “Volume buttons of the bluetooth headset still work”. The two can work independently. Does that answer your question?

1 Like

This a setting offered in Developers Options if you have it enabled

1 Like

By default that setting is off meaning that physical volume control on the bluetooth device controls both its own audio level and the phone volume at the same time. I set mine to on as soon as I got my FP3 because it was horrid. Better to have the levels seperate (in my case) at as smaller steps means more control.

I disabled the setting just for a moment as a test to see if my bluetooth devices would control the phone volume as well as its own (not that I want it to). It didn’t So though ‘nyi’ says that volume control works, only the headphone level is being controlled, not the phone. If the phone volume was set to mute, upping the headphone volume would have no effect.

As far as I can tell, no bluetooth control functions work since 8901.4.A.0016.6.

Has anyone who put in a support ticket had a reply?

1 Like

Thanks for sharing your findings.

Different people have different issues with the FP3, so thanks for confirming. This issue seems to be the same for everyone so far.

The Fairphone 3(+) release notes make no mention of any Bluetooth meddling.

Exactly. Same here, there’s no work-around. It’s downgrade, wait, use another OS or say good bye to fairphone.

Probably, thats because they didn’t realise the upgrade would, because they did not test the software they produce thoroughly.

It would be good if anyone can capture adb logs when the button(s) pressed and nothing happens.

adb logcat -c && adb logcat -b all > bt_issue.log and adb logcat -c && adb logcat -b all "*:E" > bt_issue_errors.log the next time.

I am just curious to understand what’s going wrong and see if I can do something.



Yes. As I see it, a major problem with this bug seems to be that it has not affected all users in the same way. For example, my Bluetooth headset still controls the phone’s “media” volume and the media control button works, seemingly, as normal.

All that I can see for the moment is that it seems to vary from one phone to another rather than from one device to another. Of course it’s typically bugs like that which slip through the net.

Same issue with my FP3, with both JBL on-ear and Jabra Elite Active 65t.
Both with Spotify.

I have a Fairphone 3 and Jabra Elite 45h Bluetooth headphones. Since the last Android update in August, the Fairphone no longer responds when I press the play/pause button of my headphones. I can press play/pause button of headphones as often as I want, nothing happens.

These have I tried so far:

  • Connecting my Jabra Elite 45h Bluetooth headphones to my Windows laptop (play/pause button works)
  • Repairing my Jabra Elite 45h Bluetooth headphones with my Fairphone 3 (play/pause button does not work)
  • Restarting my Fairphone 3 (play/pause button does not work)
  • Trying multiple apps like Google Podcasts and YouTube on my Fairphone 3 (play/pause button does not work)

Hi Martin, welcome to the Community Forum :slight_smile: I have moved your post here as your problem is currently affecting many FP3 users – see above.

I’ve just spoken to a helpful Fairphone support rep by telephone. He put me on hold while he checked with someone if they knew about the BT problem, after a couple of minutes he reported back that they do. He couldn’t give a timeframe for a patch, but said they are working on it.


Thanks for doing so :+1:
Just for the info of everyone (while it won’t help you folks), I also fed this Bluetooth issue and the even more pressing NFC issue into /e/ development the other day so they (hopefully) can ensure this will never spill over into one of the coming /e/OS updates for the FP3.


Just to add another way to geht a bug report

1 Like

Same thing in my Skoda. Phone functions work properly, media audio does not. Volume change does not work, and neither does skipping songs.
It’s also the same with a couple of headphones I have.