English

Software update: 3.A.0084.20210204

Hi everyone :sunflower:,

Our latest software update for Fairphone 3 and Fairphone 3+ users is now available.

Software Version: 3.A.0084.20210204

Security Patch Level: 5th of February, 2021

List of changes:

  • Fixed an issue that was causing, under certain conditions, the microphone and the internal speaker to stop working during phone calls until the device was rebooted.
  • Fixed an issue that was causing the external storage not to refresh correctly after a file was deleted via mass memory access (i.e. through an external computer).
  • Fixed an issue that was causing, in rare conditions, the camera app to immediately crash when opened.
  • The network compatibility for several carriers has been enhanced.

Please note:

Together with our partners, we test the software before its release, and in some instances where a software update might result in some problems for users on a specific network or in a specific country, we prefer to delay the software release for that specific customer base and fix all the potential issues before making the software available to everyone.

That means that depending on your network provider, some Fairphone 3 and 3+ users may receive this update later. Once the update is available you’ll receive a push notification to automatically update.

25 Likes

Vodafone in Italy … get it! Fairphone, you are awesome! :slight_smile:

Edit: Reading other comments … I’ve never had a problem with my FP3 (only couple of reboots with 0077 OS, now fixed).

5 Likes

FP3, coming from 2020-12 update level to 2021-02 update level. downloaded a while via wifi, applied and worked on the update still from within the 2020-12 level, phone being usable. this took quite a while. rebooted nicely into 2021-02 level. everything seems to work. this phone is located in germany on o2 reseller smartmobile. update was offered after a manual update check from within the system settings, system, advanced, system update gui.

a phone call arriving on this new firmware level via wifi-call worked with good sound quality. cant say much more about this so far.

5 Likes

This sounds all new to my ears. Any of the FP3 experts … do you think this is all unrelated to our beloved “internal SD card” issues? Or maybe not … ?

I’m no FP3 expert but actually, although the problem description doesn’t sound familiar to me, it imho neither fits very well on the often described internal SD card problems…

2 Likes

Wow. that’s a big one this time, 495MB, the last update had only 22,5MB.
So let’s hope it solves some big problems :wink: .
My phone is just loading it, with a Vodafone Germany prepaid SIM.

P.S.: Installation done, worked like a charme, so let’s see, what happens.

4 Likes

Just downloading the update in the UK on EE.

1 Like

I had this one, good to know it is fixed. But what about a bug when (sometimes) taking a photo with a flash but the photo is not saved, only on a second attempt.

Got the update on release day on Vodafone Germany. I really hope now that the most pressing issues are (hopefully) solved, 6 months after the release of the Android 10 update, Fairphone will take on the rest of the embarrassingly long list of bugs. For me Wifi Calling still doesn’t work (though on another Fairphone 3 using T mobile it does), 5GHz Wifi connections on higher channels are dropped every few minutes, the frequency band switch has disappeard from the settings… plus all the cosmetic bugs, plus the camera app improvements that @rae “hoped” to be able to tell us about “in the coming weeks” half a year ago without ever following up.

Edit: WiFi calling does work, but apparently the icon appears in the top bar only if there is a bad mobile signal, or none at all. When I turn on airplane mode and then enable wifi the icon appears and I can make calls.

Frequency band settings? I go to main “Wi-Fi” screen, there at the bottom “Wi-Fi preferences” in there expand the “Advanced” area and there i see a setting with “Wi-Fi frequency band” leading me to hovering layer allowing me to select from three options: “Automatic”, “5 GHz only” and “2.4 GHz only”.
You dont have these settings?

Not any more. It’s one of the many known bugs.

Hi @abittner
Just grabbed the update, but I do not have the options you mention

Maybe the options are dynamic and not there by default.

The options should be there. Them not being there is a bug with a known but annoying workaround (as outlined in the post I linked to).

1 Like

Yes, but the workaround worked great for me. And is less annoying than a factory reset :wink:

But of course this should be fixed, as not every user knows about this workaround.

2 Likes

Hello, I just downloaded the update, sadly people can still not hear my voice in video calls. Voice messages work fine, so it is clearly a software issue

1 Like

The issue was only about phone calls AFAIK:

(emphasise mine)

With which app aren’t video calls working? It may be another issue.

1 Like

isnt this workaround a permanent fix lasting workaround so to speak? booting into that safemode and bringing back those frequency settings and all? why wouldnt you go for that solution or what is the downside of it? why are we still discussing this when there is that workaround solution to this problem? or does the frequency settings vanish again? with reboots? with what? with additional android updates? dont understand just yet.

Note to self and to thread, dont want to call it a day just yet and dont want to jump to conclusions early, but this android update level seemingly brought much better wi-fi call performance on a FP3 where I had serious Wi-Fi quality and trouble with it, very bad and poor performance, Wi-Fi call being used but huge packet loss or unusable calls etc, very often needed to turn off Wi-Fi in the middle of the call, falling back to normal mobile network coverage for the ongoing call etc. Maybe this has got to do with the Wi-Fi layer in general. Where I use Wi-Fi with some FP3 phone, I often only use it with completely open and public Wi-Fi, meshed Wi-Fi of various community Wi-Fi projects etc, non-business grade, non-corporate but even none-home-use-private Wi-Fi even.

With the current android update, this Wi-Fi apparently is much more stable being used in the same places and same number of participating devices and other Wi-Fi clients etc. The FP3 now seems to stay much better connected to this Wi-Fi than before, or the packet loss is much lower etc, thus giving a better Wi-Fi phone-call. Just doing some uneducated and early guesses. Will see how this unfolds in the follwing days and weeks. If this holds true, I am kind of very happy that the Wi-Fi performance of FP3 has much improved.

3 Likes

Update works good here. No audio problems with regular phone calls.

I notice the same problem when using the Jitsi app for video calls. My voice is extremely low, almost not hearable to others. When using Jitsi web it is working fine.
So obviously there is some incompatibility between the FP3+ and apps used for video calls (Jitsi, WhatsApp, Signal, …).

Beside of that I am almost happy with this update - except the clock-space-bug, which is still annoying to me :wink:
And I guess the settings-suggestions-bug is still there (the workaround mentioned in this thread seems not to work anymore - at least in my case).

Oh, and bringing back WPA3 would also be nice (as it is a core feature, officially introduced with Android 10)! This worked before, but not anymore since v77 and not in v84, too.

Maybe @rae can have a look into these bugs.

4 Likes

Very happy with how Fairphone has done good to get out security updates out quickly. While I am happy to see some bugs fixed, I am wondering if this is on the team’s radar, and if there is anything I can do to help: Echo in VOIP calls