Fairphone 3 microphone issues

HI is there a permenant fix for this yet? It does seem to be software releated as both the mic test pass and a reboot fixes it. Please help

1 Like

Hi edd

This is just a user forum, if you want a fix you had better contact official support, and they could do with official complaints as they are not going to read all the posts on this forum.

if you want just other users idea etc. then this is the right place :slight_smile:


See also my post


People cannot hear me. What do you do about it.

Could you give more detail? How long has this been going on, what version, what apps are you using to produced this ~ phone ~WhatsApp etc. ? There’s lots of advice in the posts prior to your asking.

If their is no sound permanently and it’s a new problem and you tested the microphones as described in a post above, send it back.

"I had problems with the secondary microphone (Mic2) and I was given two options by the support team:

  1. Send your FP3 back and get a new one
  2. Send your FP3 back and get a refund"
1 Like

This seem to have started recently on calls on signal and the cell network.

How do I test the microphone without annoying the hell out of my friends and families?

  1. Opening the phone dial pad
  2. Entering *#*#66#*#* to show testing menu with three sub-menus
  3. Selecting Service tests > Test Single > Microphone. This test is for two microphones. First, you need to say something to test the primary microphone (Mic1). Then the test will playback what you just said. After Mic1 test is completed, you can tap ‘Change to Test Mic2’ to test the secondary microphone (Mic2) with the same procedure. If you cannot hear anything, that means there is a problem with the modules. Specify to the support team which one is not working properly

If the mics are working then there is a software issue and it seems that some apps don’t let go of the control. I had to uninstall a recording app to solve the problem.


Yet another case of FP3+ microphone issues here. I tested all changes mentioned in this thread so far, no changes. The service test works fine, the volume of playback for microphone 2 is quite lower than mic 1. My guess is some of these apps are using just mic 2 instead of both of them for background noise correction. Something needs to be done about this, the phone is unusable for regular calls without headphones with their own mic. I can’t believe it’s been going on for so long without any solutions. I’m growing increasingly disappointed with the Fairphone.

BTW when I say “apps” I even mean the telephone Android app, this also happens on regular phone calls, not just WhatsApp or other services.

1 Like

The problem of "it’s’ is that ‘it’ is not a common problem going by this forum i.e. no. of complianants :: no of owners of FP3

Further given the different setups of networks, apps, Android 9/10 and version updates it must be very difficult for Fairphone to pinpoint the numerous instances and find solutions for any, let a lone a common software handover glitch. I say handover as more often that not it occurs when certain apps are invoke/installed. I had to remove a audio recording app to stop it ~ and bot only am I unprepared to re=install the app, a) it took a while to work so I’m not even sure that was the cause.

You start with “yet another case” but you haven’t stated which FP3 you have, which Android or update etc. Add to that how long have you had the phone ~ compare that date to the date you posted and what apps etc you installed since ownership etc. you can appreciate how difficult it is to help unofficially let alone how the official FP team must be see the issue as they probably have dozens of similar issues among others.

It’s a real bummer, that’s for sure.

I am also a user with a FP3 (received in December 2020) where the mic issue underwent a marginal improvement after the 077 January update, however the mic quality is still disappointing on Whatsapp calls compared to almost all other phones. When i’m shouting into the mic I sound “normal volume level” to the conversation partner. Have a ticket still active and hoping there’ll be further improvements.


Hi! I have the same problem. Both mics work, but video calls seem to use exclusively MIC2, which is too weak to be heard. Is there a way to just disable that one? I would rather try no background noice reduction than this. Video calls are right now one of the main uses for my phone, and if it doesn’t work I will have to returne the FP3 :frowning: .

I had hoped the last update would be able to fix it but no…

Hi @Sue1

yes the last update 0084 wasn’t targeted as resolving this problem but one where the call dropped on many occasions.

My daughter is about to return her phone after three months of this issue.

I note from the following that @Sarasure resolved the mic being low on calls by using a headphone only for it to move to WhatsApp. It seems clear that the mic1 control isn’t being released to the app that wants to use it.

1 Like

I am using Official LineageOS 18.1 since about 1/2 year with regular updates. I believe that microphone problems were not there at that time, but that the performance changed due to an update. Nevertheless all problems are now there also with this OS version and current updates:

  • callee gives response that my voice is very muted
  • (wired) headset gives eventually a bit higher voice volume, but there is also the problem that the ear volume is very high even at the lowest setting

This is very bad situation for phone usage.

I have the same issue since I bought the FP 3+ and right away installed /e/OS. Since the FP 3 is sold with /e/OS preinstalled, I hoped to get this issue resolved fast. Maybe more details help to debug it:


  • Network carrier: Congstar
  • Device: Fairphone 3+
  • OS: /e/OS 0.23-20220406175185 (Android 10) [but I have the issue since bought the phone and installed /e/OS 0.13]


  • When making a phone call, at some random time (but usually within the first 5 minutes) the other person tells me that I sound like I would be very far away. The issue disappears after a few seconds (but still already interrupted the flow of the phone call) and reappears several times during a call (depending on the length of the call).
  • I, on the other hand, can understand the other person perfectly throughout the full call.
  • The microphone seems to work fine during Telegram calls and Signal calls, but not with the official phone app using classical phone calls.
  • It is indepedent who initiates the call
  • It happens for all network carriers that the people have that I call (including landline).
  • It happens when using 3G, 4G, or Wi-Fi for making the call.

What I tried but did not work

Is Fairphone aware that the problem still persists?

Welcome to the community forum.

Fairphone only support Fairphone OS, /e/OS is supported by the e foundation, Fairphone OS updates are Fairphone OS updates and don’t automatically translate 100% to /e/OS updates.
So the question would be whether the e foundation knows of this problem.

If the issue doesn’t already exist at Issues · e / Backlog · GitLab, then somebody should open an issue there to get /e/OS developers to take a look.


Thanks for the suggestion, I have created a bug report in the eFoundation GitLab.

Sorry, I got confused. I thought Fairphone sold it with /e/OS, but in fact the eFoundation sold the Fairphone with /e/OS preinstalled, i.e., the other way around than I (falsely) remembered.

So far it seems that only LineageOS and /e/OS are still affected by this bug.

1 Like

/e/OS support is wondering if this bug still persists with the stock ROM (Fairphone OS)? I wonder since the last post from a stock ROM user is already a year ago.

Is anyone with the stock ROM (i.e., still using the pre-installed operating system and not a different one like LineageOS or /e/OS) still having this issue?

Yes since purchase in Oct 2020. There was an ‘echo’ issue that seemed to be resolved after a couple of updates, early 2021, but no other audio issues in the UK on EE , network or Wi-Fi calling, hands free or WhatsApp etc.

1 Like

Okay, so I am joining the club with my slightly own version of the issue and perhaps somebody has an idea what to do: I presume that for me its a software issue with the microphone(s)

  • When doing the *#*#66#*#* test both microphones work but one can hear my voice only muffled and hear a lot of loud background noises/cracking sounds.

  • Sometimes I can record voice messages with the same rather bad quality, sometimes it doesn’t record any sound at all (deleting the cache of the messenger apps helped to come back to the former)

  • In calls, turning on loudspeaker helps (people seem to understand me way better), while in normal calls it seems to be the same muffled/cracky sound I know from the mic tests or voice recordings

  • I tried already the fairphone support (did the tests, set the phone back to factory settings, istalled all recent updated, tried turning of the WIFI LTE call settings) and they suggested to send it in to see if they could do anything and if not get a new one (which I would like to avid for the moment as the rest is still working

→ is there anybody who still has any ideas what I could do to solve this?

As a temporary “solution”, it occurs to me that you can connect a headset with a microphone (wireless or wired) so that the phone uses the audio from the headset microphones.

In the test you did, do both microphones sound equally bad, with these “noises”? I don’t know if activating the loudspeaker in a call activates the upper microphone, maybe that’s why it sounds better (I have no idea, it’s a hypothesis).

By the way, some voice or video recorder applications offer the option to choose different audio sources, maybe you can test them to identify if your problem is related to the to the audio signal processing part. For example, in OpenCamera (F-Droid / Play Store you can choose “Unprocessed” under “Video settings” → “Audio source” and make a recording to check if the problem persist. It might be worth a try.

(Oh, and when you do the tests, try to leave the mobile phone on a fixed surface, as often the “scratches” that the microphone picks up come from the vibrations that we produce by moving it and holding it)

Another thing that occurs to me: have you checked if the microphones have a lot of dirt in them? I don’t know the best way to clean them… I don’t know if a toothbrush could help or spoil it more (sometimes I’ve used a hair of mine to remove, being very careful not to introduce it any more, the visible dust :rofl:).

I guess if you have a fairphoneangel nearby that has an FP3, you could try changing the microphone module(s) and see if you still have those problems…

Just a few suggestions that come to mind, I hope they are helpful!

1 Like

Thank you very much for your ideas and suggestions! :heart:

The “temporary fix” (that is headset) usually works - but not with the fairphone earbuds.

Yes, both microphones sound the same in the test (both a bit like what people describe the mic 2 should sound like).

I already cleaned the microphones (with air, using a vacuum cleaner, blowing into it, using a brush, a needle (trying not to do any (more) damage after none of the former seemed to fix the problem).

I totally agree, that the noises come from moving/ holding the phone, but I would say this is one of the symptoms of the issue, as in the past, it Could record e.g. voice messages without rustling noises being so dominant.

Unfortunately the Video setting change didn’t change much either, but thaks for the hint, i was a good idea!

1 Like