English

Echo in VOIP calls

Hello there,

Sinds a few months I use a voip app (Dubline) for a business phonenummer. All of the people I call and are calling me experience an echo. I’ve contacted the appmaker severall times and recieved app updates. Yet the echo stays an makes it impossible to use the app.

Before I switch to another VOIP provider I want to rule out any problems with my microphone or my phone in general. Do you know any way or troubleshooting the check where the problem originates from?

Any help is appreciated.

Cheers,
Thom

1 Like

There’s a basic microphone test in Settings > Maintenance > Checkup

The primary microphone is the one at the bottom end of the FP2 (a 1 mm hole) and the secondary microphone is the one at the top.

1 Like

It’s a known FP2 bug, hardware echo cancellation is broken:
https://bugtracker.fairphone.com/project/fairphone-android-7/issue/179

4 Likes

I am experiencing the same issue with FP2 in the third-party apps I use for calls (Messenger, WhatsApp).

The issue was first identified in 2017 (from what i can see) and the bug linked by Chuck above has the status “needs more info”.

Super frustrating, but until there is movement I will keep commenting so the bug report at least stays open.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.

Hi there,
Unfortunately Echo in VOIP calls is already closed.
According to https://bugtracker.fairphone.com/project/fp2-android9/issue/25 the problem - callers hear their own echo in VoIP calls (messengers, SIP-apps, …) - should be fixed since Android 9 (beta 20.06.2-beta.0) in June.
Can anybody confirm that this problem does not exist any more?
Does anybody have an idea, wether this will be included in other operating systems (eg. Lineage OS 17)?

Cheers,
FM

1 Like

I opened the topic and moved your post here.

1 Like

A post was split to a new topic: Echo in VOIP calls - FP3

I also experience this issue frequently. My workaround is to plug in with headphones.

In lineage we should use the same OSS aec library. I would appreciate some official fairphone help here. I don’t see what is wrong and it’s quite difficult to test this.

Chris

2 Likes

Yes, I guess I can confirm that in Fairphone Open 21.03.0-rel.2 this problem doesn’t exist anymore. I own two FP2 and I tested this with a friend making a video call with Signal. One FP2 is running LineageOS 17.1 (2021-04-14) and on the other one I installed Fairphone Open 21.03.0-rel.2 yesterday.

I used the FP2 with Fairphone Open to call her, she had the one running LineageOS. I heard my echo loud and clear (now I understand why people complain all the time when I make video calls with them…) but my friend didn’t. She heard no echo at all.

We did only this one test today but the difference was really obvious.

4 Likes

I’m afraid I can confirm that the issue is still present in Fairphone Open 21.03.0-rel.2. I tested it too with two fairphones 2 and the SIP app 3CX. I hoped it would disappear with this android 9 update but my colleagues still hear their own echo. Activating (software?) echo cancellation in the app or the use of AAudio api instead of openSL does not solve this issue.

Is there a way to report this on the bugtracker? I can’t find a way to comment on the issue ( #25Acoustic echo cancellation fails for third party apps) since it has been reported as “fixed”

Since you wrote that the issue is still present for you I tested this with Jitsi Meet today. And again I wasn’t able to reproduce this bug.

Since we get different results using different apps (Signal, Jitsi Meet vs. 3CX) this might be a bug in 3CX… Could you please test this with Jitsi Meet? The app is free software (available on F-Droid) and it should be really fast and easy. Just open the app on both FP2 and type in a conference name.

I loaded stock FP2 rom (FP2 fp2-gms-21.05.0-rel.1-manual) and I can see in adb logcat that the two audio effects aec and ns do actually not load at all:

06-13 05:40:25.985 323 323 E EffectsFactoryConfigLoader: Error querying effect 29dfd020-e88b-11e5-b505-0002a5d5c51b on lib audio_pre_processing
06-13 05:40:25.985 323 323 E EffectsFactoryConfigLoader: Error querying effect e4eb6b40-e88b-11e5-b6ad-0002a5d5c51b on lib audio_pre_processing
06-13 05:40:25.985 323 323 E EffectsFactoryConfigLoader: 2 errors during loading of configuration: EffectsFactoryConfigLoader
06-13 05:40:25.985 323 323 E EffectsFactory: Effect config is partially invalid, skipped 2 elements

Maybe that’s why it “works” on stock rom.

Someone from FP like @karsten could maybe comment. I don’t see what else “fixed” this on stock as mentioned here Taiga.

Chris

4 Likes

Yep that’s indeed what “fixes” the issue. For FP2 we’re missing some license for getting Qualcomm’s acoustic echo cancellation actually activated. So if you load their effect libraries, AEC breaks, but if you don’t load them (as it happens in stock FP2 A9), Android falls back to a software implementation that works well enough.

In Android 7 we had some patches ready actually to disable AEC somewhat cleanly, but they didn’t make it into a release anymore. See here for reference: https://gerrit-public.fairphone.software/q/hashtag:%22aec%22

5 Likes

OK - head over to lineage-18.1 thread and try last build. I tried to directly use asop fx.

Chris

4 Likes

This is really great, thanks!! I tested your last build with Signal (5.13.8) and this bug seems to be fixed – I wasn’t able to reproduce the echo :slight_smile:

I had to post this first impression right away but I’m going to test this some more (with friends, using other apps,…).

Update (2021-06-28): I tested this some more with friends using Signal and Jitsi Meet and I can confirm that this bug is fixed.

4 Likes

Hi, I tested with Jitsi Meet and indeed the echo was gone. I will contact 3CX to see what they can do on their side.
Thanks for your help

2 Likes