English

FP3 Android 10 WiFi 5Ghz unavailable

Here I am looking for confirmation. Recommendations on a solution are welcome too, but I’d prefer an approach without complete phone reset unless someone tested and confirmed its success.

Way to reproduce:
Start from FP OS 8901.3.A.0033.20200815 (already Android 10)
Select within WiFi settings menu to connect only to 2.4Ghz networks
Update to FP OS 8901.3.A.0045.20200905

As the aforementioned menu is (at least with me) no longer available, I am caught to only connect to 2.4Ghz access points. 5Ghz only networks are no longer visible+connectable.

Within the Android settings menu System->Reset Options I already tried the “WiFi, mobile data & Bluetooth reset” without success.

I trust if one would have used the 5Ghz only setting, after the update one would be caught to only connect to 5Ghz Wifi.

2 Likes

I can’t confirm that. I had the ‘only 2.4 Ghz’ option active before and can still change that after the latest update.

2 Likes

Not sure if it helps you. I had the network option set to “automatic” before the update from A.0033 to A.0045 and I still have it: Settings > Network & Internet > WiFi > WiFi Preferences > Advanced > WiFi frequency band.

1 Like

You both indeed helped me in the way that I now know the missing submenu was a bug and unwanted behavior. I went through full phone reset and got finally the menu item back. Not super happy to be forced into that, as I kinda feel like a involuntary beta tester without the satisfaction of a successful error track.
Anyone still updating, I can just recommend to put the WiFi frequency band option on “automatic”. Apparently it won’t impact the occurrence of the bug, but might leave you in a state where you can overcome the time to upcoming updates and hope for it to resolve on its own. I didn’t have the patience for that though…

Any opinions on leaving this open in order to track additional mishappenings of this kind? To be precise, anything concerning the loss of the submenu Settings > Network & Internet > WiFi > WiFi Preferences > Advanced > WiFi frequency band. Fingers crossed, my FP3 was the only one to do so. But I can’t believe my config to be unique and update procedure went flawlessly without interrupt.

3 Likes

I have the same issue. But it’s almost impossible for me to factory reset my phone. Is there ANY way of getting the menu back or changing the settings value without the GUI??

If anyone could help me that would be really great.

2 Likes

That is not an advisable state of affairs. Any smartphone is a complicated device which can fail you partly or completely at any time. Be as prepared as you can reasonably be.

Thx for report. I am sorry to hear that and feel with you most likely facing the reset.

Meanwhile I’m also missing the point in the wifi settings. That’s pretty weird… I think I won’t reset my FP until I install /e/ though

Apart from Google Drive, what is the recommended way to backup FP3? Still MyPhoneExplorer?

Hello everyone! I updated to FP OS A.0033 yesterday, so Android 10 here i go. Before that I also changed/set the wifi band to 2,4 Ghz while using the last Android 9 update. Now I cannot see the submenu/option to select the wifi bandwidth on Android 10. Does anyone know any workaround without having to factory reset the Fairphone?

Thank you

My submenu is back again. I don’t get it… Maybe it depends on whether wifi is active or not. I’ll keep an eye on that topic.

Does anyone know an app or something with an option to switch the wifi band from 2,4 Ghz to 5 Ghz and viceversa?

I can’t promise a reset to work longterm:/ I am back here after one week that the chooser stayed available after the reset.
Just to pitch a few ideas:
I installed and deleted the german corona warning app.
The recovery I went through was the one found within the settings menu by recovery section. In case I am motivated, I’ll go for the fastboot way using the Android image. if someone else wants to give that at try too;) hopefully same version install keeps the data+apps.
Iam having f-droid installed, next time I’ll drop that for the time being.

Actually this time Iam not even sure I used the chooser. It just disappeared and Iam locked to 2.4Ghz Wifi and 5Ghz only access points are not even displayed (same symptons).

1 Like

My band chooser also disappeared at some point, but it seems to still see and use both bands, so it’s ok for now. Some other settings have also disappeared, but funny enough they still show up in the settings search.

As the others have said, I hope a solution can be found that doesn’t involve a full factory reset. (just a hassle and time)

Thank you for mentioning this bug. I thought I am dumb because I can not find this option anymore!

I will not do a factory reset because of that, as it (hopefully) will be fixed with a software update. Sadly there are a lot of bugs in Android 10 on my Fairphone 3+ (including the wifi reconnect bug, around two times per hour) so I guess we have to wait for an update to fix all these issues.

UPDATE:

A few weeks ago I did the Factory reset. Well guess what. It worked…For about a week or so… Now it’s gone again and my FP3 is developing even more bugs over time (or I’m just noticing it over time)

Maybe I really do have to revert to Android 9 if all this continues. If Fairphone still doesn’t give a cr*p about fixing bugs, my next phone definitely won’t be the Fairphone 4. I’m probably going to switch to Shift. Just because I know they’re more reliable.

You are right, there are more and more bugs, which are very annoying.
The “funny” thing: Not only the wifi band chooser disappeared, but also the “Keep on wifi during sleep”-chooser: Fairphone 3 loses wifi connection

After few month owning the new FP3+, I really don’t know what to do anymore. Dozens of bugs, no help from the support and not one single update to fix all these bugs. And even the Google security patches seems to be on hold. Latest patch was from October. November patches are missing, now it is already December.

I can’t comment on the bugs but IIRC the schedule for security updates has always been quarterly not monthly for the FP3. I don’t like this too much myself, but from my perspective this is not part of “an Android 10 desaster”.

2 Likes

Easy, boy. Even the Pixel lineup from Google has no December updates ready, yet…

2 Likes

Yes, sure. But we don’t even have the November updates. That’s what I meant :wink:

Oh, I did not know about that. Thank you for pointing this out! I just was used to get monthly updates from the other smartphone brands I had before.
You are right, the security updates are not part of this desaster. But the limitations while calling are - in my personal view. But this is even more off-topic, I am already in contact with the support since months to get back a normal calling-functionality :wink:

Sorry for off-topic!
So, if there are solutions or hints to get at least the missing menu items (wifi band chooser and wifi sleep chooser) back: Would be happy to know about!