Is WPA3 officially supported? As it does no longer work

Seems the latest update (8901.3.A.0077.20201221) broke WPA3 support. I can confirm this on my device.

Tested with Fritz!Box 6490 in WPA2/WPA3 mode. In the web interface it shows it uses WPA2.
However, for me on the device it here showed WPA2/WPA3 in the WiFi settings.

1 Like

AFAIK WPA3 was never officially supported. AVM says

FRITZ!Box fĂĽr WLAN-Verbindungen mit WPA3 einrichten

Die FRITZ!Box unterstützt WPA3, den neuen Standard zur Authentifizierung und Verschlüsselung von WLANs. WPA3 bietet gegenüber WPA2 unter anderem einen besseren Schutz gegen Offline-Wörterbuch-Angriffe. Dabei lässt der Angreifer eine Kennwortliste (Wörterbuch) so lange durchlaufen, bis der richtige WLAN-Netzwerkschlüssel gefunden ist.

WPA3 mit der FRITZ!Box nutzen

Erste WLAN-Geräte mit WPA3 sind auf dem Markt. Bis sich WPA3 flächendeckend durchgesetzt hat, wird es aber eine Weile dauern und längst nicht alle älteren WLAN-Geräte werden ein Update auf WPA3 erhalten.

Solange Geräte ohne WPA3 noch verbreitet sind, können Sie in der FRITZ!Box den WPA-Modus “WPA2 + WPA3” (Transition Mode) einstellen, der gleichzeitig WPA3- und WPA2-Verbindungen unterstützt.


  • Mit WPA3 verschlĂĽsselte WLAN-Verbindungen mĂĽssen manuell eingerichtet werden. Mit dem WPS-Verfahren ist kein Aufbau von WPA3-Verbindungen möglich.
  • Beim Umstellen der FRITZ!Box auf “WPA2 + WPA3” verlieren einige WLAN-Geräte die Verbindung und mĂĽssen neu an der FRITZ!Box angemeldet werden.
  • Damit die WLAN-Verbindung mit WPA3 hergestellt werden kann wird, muss an einigen WLAN-Geräten die alte WLAN-Verbindung zur FRITZ!Box gelöscht und eine neue Verbindung eingerichtet werden.

WLAN-Geräte mit WPA3

Zur Zeit unterstützen zum Beispiel folgende WLAN-Geräte und Betriebssysteme WPA3:

  • Windows 10 ab Version 1903 in Verbindung mit
    • WPA3-kompatiblem WLAN-Adapter (zum Beispiel INTEL AX200 der neusten Generation)
    • aktueller Treibersoftware fĂĽr den WLAN-Adapter
  • iPhone 11
  • iOS und iPadOS ab Version 13
  • Samsung Galaxy S10
  • Android 10 in Verbindung mit einem WPA3-kompatiblen Smartphone oder Tablet

So somebody from Fairphone should clarify if the FP3(+) supports WPA3 or not. @anon27553248, could you check this for us, please?

Best wishes,

1 Like

I hope it was ok to change the title a bit to say “no longer work” because it in fact did work before the update.

Personally I don’t find this issue too urgent. Outwardly, while using the phone, there is no difference in functionality. But of course I’d prefer to get back the enhanced security features at some point.


Well, in some cases there is. The problem is with some (OpenWRT) routers like mine the fallback to WPA2 does not work properly and thus it cannot connect to the WiFi anymore at all…
That may be related to the router or that I did not change the SSID when changing the wifi to WPA3-mode, but it’s in any case not good. That’s the result a user may get…

Just abstracting from what AVM says (see @teezeh’s post) … to get from WPA2 to WPA3 it can be necessary to delete existing connections and re-establish the connections from scratch.
What if this may apply to the other way around, too? Did you try?

Great to get a security update.

However, WiFi does not connect to WPA3 anymore, but only WPA2 (with Fritzbox 7590, OS 7.21). In addition, the connection is annoyingly unstable: I have to reconnect several times a day (feels like every 5 Minutes). Identical setup worked fine for many month before.

1 Like

I moved your posting here, since this topic is already discussed.

I also experienced the instability with manual reconnect every few minutes. It got fixed once I did a reset of all network related settings. Hope this helps you.


Interesting. I also did the reset of network settings but it did not fix anything for me.

1 Like

Same here. My FP3 was using WPA3-SAE to connect to various AVM Fritzbox and Repeater APs (all running on Fritz OS 7.2x).
But the FP3 only connects via WPA2-PSK since the 0077 update.

Reported to Fairphone with a logcat as #414899.

Tested with WiFi “FritzBoxWPA3Test” (2,5 Ghz + 5 Ghz), WPA2+WPA3.
Fritz!Box shows it is connected as “n/Wi-Fi 4, 20 MHz, WPA2, 1 x 1, 11k, 11v”.
FRITZ!OS: 07.20


Still doesn’t work after the update today. I wonder… no… I don’t.

Clarify? :slight_smile: Do you mean the 0084 update?

Yes, WPA3 is not working with 0084.

For clarification: Indeed, I’m referring to the latest Update: 8901.3.A.0084.20210204. I’m still not able to use WPA3 alone as I have been back in the days.


It wasn’t planned to reinstall WPA3 with this update, see: Software update: 3.A.0077-20201221 - #112 by Incanus


Got a word from support.

In Faiphone OS v.077 we have disabled support to WPA3 because we found out that it was causing issues with some WPA3 routers. We are now working on analyzing this.
Once we solve the issue we will enable support to WPA3 again with a future software release.

It’s basically what I expected: wait until it gets enabled again :wink:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.