GPS doesn´t work on FP Open OS

Continuing the discussion from GPS stopped working:

I continue this forum topic because I have the same problem: my GPS just doesn´t work at all. I try it with OsmAnd~ and SatStat and with settings set to high accuracy, but nothing works. On SatStats I can see some detected satellites, but my position is never detected.
I have Fairphone Open Source OS installed. Any help would be appreciated

Did you try the Privacy Impact?

well yes, I turned if on and off again like you described it in the other post. But it doesn´t work for me

Did you change the parameters for gps.conf? There are some strange defaults…

I saw your posts about that but probably I am still too much a newby into the open source to totally follow what you meant. Could you maybe give me concrete advice on how to change the parameter?

That’s not that complicated. If you know how to mount system read/write it’s not complicated at all. Otherwise, if you want, I can send you via pm my gps.conf and instructions on how to activate it. Right now I’m on holidays in France and use it every day with osmand+

1 Like

yes, I think that would be really helpful :slight_smile:

Let’s have @lklaus enjoying his holidays, maybe I can help out:

Here’s a step by step how to on changing the gps.conf

  1. Activate developer settings (Settings --> about the phone --> tap about 10 times on build number)
  2. Enable root (Settings --> Developer settings --> Root access)
  3. Open “Terminal Emulator”
  4. gain superuser rights by typing:
  5. get write rights on the /system partition
    mount -o rw,remount /system
  6. open the gps.conf file
    vi /system/etc/gps.conf

If you don’t like vi, use this
6. open Amaze and point it to /system/etc
7. open gps.conf in amaze text editor


[quote=“Manel, post:3, topic:17348”]
I turned if on and off
[/quote]Try it the other way round: privacy impact stays on.

@freibadschwimmer: What does this change do?

I think adding/correcting the xtra and NTP config is necessary or at least very helpful to get a speedy fix.

Okay, I have some updates. I followed your steps @freibadschwimmer, were able to write the gps.conf and edited the things @lklaus told me. Still not working (I think one time SatStat was able to get my location, but with an error of 13 km …). So I did a hard reset. Then I downloaded FasterGPS from F-Droid, which can write the gps.conf file just by telling it in which region you are. My gps.conf file now looks like that:




Still it is not working… Maybe it really is a hardware problem in my case?

My GPS on my FP2 is working so well I’m thinking you may have a hardware issue.

While you never can rule that out, I would still try the easier ways…
Do you have an app that tells you the status of GPS, like how much satellites are detected and how much are locked?
And did you test that in an open location or inside buildings or in streets in a city?

I felt bad that to that question I would have to answer that I actually only tried it in closed buildings, but today I did a long test in the streets of Barcelona and I got no location at all… So that wasn´t the problem. I use SatStat to check my GPS and sometimes I can see some satellites, some blue and some red ones. I guess the red ones are the locked ones?

Actually, I’m not that sure about the markings of satstat. But you will see something like x/y satellites. That’s x satellites locked, y satellites seen… You’ll need at least 3,I guess…
Also, there’s some file that helps locating, called agps data. You should be able to download a fresh version. Might help, but I’m not sure

I have exactly the same Problem. No GPS.
I got my phone yesterday and installed FP OSOS. I never got a GPS signal or location.
I didn’t try root because i am a newby.
Could it be the OS?

Hey, so i am not the only one!
I have been on a small trip this weekend and the gps was working now and then, but really only very occasionally…
I also downloaded fresh agps data with SatStat, but that didnt help much.
I contacted the support by now, let’s see what they say

I also contacted them on their support site and tried to call, but the call didn’t go through.
Now wie have to wait. Hopefully they don’t take too long so if it is the Hardware wie can send it back in the next 14 days.

Just for the record:

GPS works for me on FPOOS.

I have only tested it once, but it seems to be just fine:

Btw: If this thread only relates to FPOOS (as far as I have seen only users with OOS discussed here, maybe we should clarify that in the title as well).

1 Like