Living without Google 2.0 - A Google free FP2

I like them all.
You should have at least one offline and one online backend for wifi and cell data each.

3 Likes

As an update. I have installed microG on the phone and it seems to work ok. No google play service messages any more. Yeah. GPS works ok, even though I will put some more effort in trying to get a quicker GPS fix.
BUT the app “outdooractive” (similar to “alpenvereinaktiv)”, which is the one I would like to use and which kept crashing and gave the message “The usage of the map is only possible with google play services”, is still crashing. This time without the google service message.
I have not installed “GsfProxy”, because I do not think that push notifications are necessary for this map app. Can that be the problem?
I have installed GsmCore, BlankStore and FakeGApps. I have not installed XposedGmsCoreUnifiedNIp, because UnifiedNlp is supported by FPOS16.06 and I have installed the app from F-droid together with different backends (and it works well).
I have given the outdooractive app all permits it wants with Xprivacy (to make sure that there is no conflict here).
Does anyone have an idea, why the app still crashes?

Android permissions are granted on app installation. Maybe your app needs some Google custom permission which hasn’t requested yet? Try reinstalling the “outdooractive” app.

Other possible case is that the app requests the location to the fused provider, which is not working and it’s a known error on the FP Open OS. The fused provider is the technical name of the mixed GPS location + network location (high precission location). This is the problem causing PlayStore (with OpenGApps) or transport apps like CityMapper to crash.

Personal thought: only greatly designed, wide compatibility, bug avoiding developed apps which specificly check for the absence of the fused provider work at the moment. And no, it’s not a common practice.

1 Like

I have re-installed outdooractive, so no permit problems.

Therefore the fused provider seems like a good (and unsatisfying…) explanation. This is supported by the fact, that the app works ok until I click “map”. As soon as it tries to open the map (or wants the location I guess) it crashes.
Too bad there is no alternative yet, but maybe soon. I hope so.
Anyway, at least because of your help I have a few useless messages less. That’s an advancement!

And yes, it is not a widely used app, so the chances it is not programmed to the highest standards is quite likely. I will write them an email and ask for it. Will let you know, if I get an answer.

2 Likes

Hope FP team fixes that on the next version. It’s pretty annoying, :frowning:

Writing directly to the developers is a good idea. I’ll do it myself too. Good luck! :wink:

1 Like

7 posts were merged into an existing topic: GPS doesn´t work on FP Open OS

I just moved to FPOOS and I am using Raccoon to get some apps from Google Play.

I have problems with paid apps, like Titanium Backup Pro. This apps unlock the free app but it needs Google Play Services. So I can download the free app and the unlocker, but I can’t unlock the app.
Do you know any way to do it (without installing GAPPS of course)? Titanium is just an example, I have several apps like that.

You can donate via paypal to get a key for the pro version

Once your donation is sent, PayPal notifies me and I send your license ASAP. Keep an eye on your spam folder. Thank you !

http://www.matrixrewriter.com/android/

Actually I already buy the unlocker via Google Play a long time ago, so I don’t really want to pay a second time.
I email the support of Titanium, but my question here was more general, I have several other apps like this.

I run fp open os on my fp2 and I’m trying to install xposed through the instructions above. I downloaded the zipfile, went into recovery mode and installed it, with a message signaling success. When I rebooted the phone, I got a message that read something like “Invalid download: Bad signature”. I’m pretty sure that I disabled the signaturecheck. So as a beginner to all of this, my questions are:

Is there a way to check if the download was succesful?
Can repeating the installation process do any harm?
Can proceeding with the installation of xposed do any harm?

Any suggestion would be helpful!

1 Like

Have you installed the correct version !! of Xposed? It must be the version for Lollipop!

1 Like

xposed-v86-sdk22-arm.zip

I assumed that the xposed-downloader either automatically finds out which version that you have or that it doesn’t matter for the initial zip-file, since the instructions didn’t mention it. I can’t find anything about the version in the setting of xposed-downloader either

It is the right file. You installed it with the recovery and got “successfully installed” so I assume, it is installed. From TWRP as recovery I know that the message comes from TWRP and you get back to the recovery. The message after reboot has another reason. Is there any hint, whatever send this message?

2 Likes

Nope, it appeared as a tiny black box with rounded corner upon unlocking the phone, before fading. I can’t reproduce it by rebooting it again. I have encountered similar messages earlier (also when unlocking phone), but then they were talking about ‘socker errors’ or something like that

Sure, just download the Xposed installed and a module and see if it works.

I sometimes get that message when I have a bad connection and some background app wants to download something automatically. It’s probably not from Xposed.

2 Likes

I installed the installer and it says that the framework is active! Thank you :~)

2 Likes

I just want to thank the people here that have given so many instructions on how to live without google.

Up until yesterday, I was running FP Open OS 16.06.0 with OpenGAPPS, but I was having some troubles, mostly with GPS (it went crazy and didn’t turn off after using it for a few minutes, resulting in a complete battery drain in about half an hour).

I figured it was easiest to just reinstall the complete thing and decided to go Google free this time. It don’t particularly dislike Google neither do I care about privacy all to much, but I just like it better if I know exactly what apps are running on my own smartphone.

Despite being quite the Android-noob, with the instructions on these forums (special thanks to @paulakreuzer and @Roboe) I managed to reinstall FP Open OS 16.06.0 and microG. It works like a charm!

For anyone interested, I’ve used:

  • moosd’s Needle script to allow spoofed app signatures

  • F-droid

  • microG Services Core

  • microG Services Framework Proxy

  • microG UnifiedNlp (no GAPPS) - included in FP Open OS

  • GSMLocationNlpBackend

  • LocalGsmNlpBackend

    downloaded areas from lacells, database update crashed when I tried to use mozilla/OpenCellID

  • FasterGPS (Belgian server, INTERMEDIATE_POS 1)

  • OsmAnd~

    GPS only is quite fast and correct
    Wifi/mobile location is about 250m off

  • BlankStore

  • Lightning - browser

  • Disa - for text/whatsapp/facebook messages, push notifications are fine

  • K9 mail

  • Erat & aCalDav

    syncing with my Blaucloud Owncloud calendar - CalDav sync error all the time
    now using this setup to sync with Google Calendar - ironically
    does anyone know a good - free or cheap - alternative for Google Calendar?

  • a whole bunch of other apps (public transport, Mapswipe, VPN etc) installed via BlankStore

My Fairphone has never run so smoothly before. Yay!

10 Likes

GPS as the service that receives sat-signals can not drain the battery. I think you used something like Maps. Is that true?

I use DAVdroid, Tasks and Etar to synchronize my calendar, contacts and tasks with Posteo.de (they offer an email address, three calendars, and contacts for 1 € per month). Alternatively most email providers grant one calendar per account for free (e. g. gmx.de or web.de). I bet there are Belgian email providers which offer the same.

[quote=“Spielmops, post:325, topic:11587”]
GPS as the service that receives sat-signals can not drain the battery. I think you used something like Maps. Is that true?
[/quote]By ‘using’ I indeed meant ‘using any app that uses GPS’.

As it didn’t work at first with FP Open OS, I tried so much to get it working - changing gps.conf manually and with fasterGPS, installing microG stuff to at least get location services to work, downloading all kinds of maps-apps - that I think in the end just something in the android-gps-locationservices communication went crazy. I configured it to use ‘GPS only’, but it kept switching back to using wifi/gsm location services as well, and each time I used any app that tried to find my location (OsmAnd~ or SatStat while on GPS only, Google Play with location services), my battery drained in about half an hour. I figured re-installing the whole thing was probably easier than finding the source of the problem. :wink:

My Dutch provider doesn’t - and its free web space doesn’t even support PHP to run Owncloud or something like that. I’m very attached to it though, so I won’t switch providers.

But I’ll check out the alternatives you mentioned, thanks! (Seems to be quite a German thing to provide calendars with e-mail, if I google it I get a whole bunch of German websites - although of course that might have to do with the word ‘Kalender’ with a K being the same in Dutch and German. ;))

1 Like