English

Yet another "GPS not working" post

Tags: #<Tag:0x00007f05de7f7700> #<Tag:0x00007f05de7f74f8>

Hello everyone !

Since my girlfriend has the fp3 she gave me her fp2 (running on the regular os, not the openos) hence I know the gps was working back then.

I’ve been struggling since then to make the gps work. I’ve looked everywhere in the forum to find advice.

Whaht should I do ? Is exploring the OpenGapps trail a good idea ?

If you are running the regular Fairphone OS, then OpenGapps wouldn’t do anything for you - you already have Google apps and services on your phone.

Did you check the #gpsguide?

2 Likes

You are so fast !
I’m running the openOS.
Of course I’ve checked the guide you mentioned :wink:

Well then you should be able to describe your issue a bit better.
Do you not get any location at all, or just an approximate (network) location?
Do you see any satellites in SatStat? Too few? Enough, but they are not connected?

2 Likes

In satstat, I see really few satellites.
Sometimes osmand+ tells me I am hundreds kilometers away from my real location. Sometimes the location is correct but it doesn’t follow my movement.

It is not accurate at all…

I’ve seen that, too, sometimes.
If it is at least a location where you once were, then it’s just a “leftover” location displayed before OsmAnd+ gets the current location.
It’s quite irritating, because it isn’t even necessarily the last location the phone got, it can be way in the past.
But the real issue is to get the current location.

Please confirm that Settings - Location is enabled, and that Settings - Location - Mode is set to “High accuracy” (I think “Device only” is set by default).

Only if you want to have Google Apps and services on your Fairphone Open OS. This will include Google’s enhanced location services.

There are other ways, though … you could have a look at UnifiedNlp.
But I don’t know how Fairphone Open OS even handles “High accuracy” technically without additional stuff installed.

Please confirm that Settings - Location is enabled, and that Settings - Location - Mode is set to “High accuracy” (I think “Device only” is set by default).

I’ve tried all 3 settings many times…

There are other ways, though … you could have a look at UnifiedNlp.

I’ve already done that, with pretty much all the location backends I could find.
Is it the right way to configure it ?
Screenshot_20191202-202221|281x500

Only if you want to have Google Apps and services on your Fairphone Open OS. This will include Google’s enhanced location services.

Okay, so I’ll stay away of that. I wasn’t sure.

Thank you guys for your answer !