GPS doesn´t work on FP Open OS

Just called Amsterdam. They told me They have a.bug with osos and the gps. It will be fixed but can take some more days. They don’t think it is the Hardware.

1 Like

Hello everyone,

i just got my fp2 yesterday and i installed fairphone open source OS. I never got a signal for location. The Symbol always shows on the top, but no APP is ever going to find my location.
I already searched for the Problem in the topic but i am a normal user and didn’t find an answer that made sense for me.

Can anyone help me? I am so excited having it and i want to work with it properly. Thank u for your help.

PS: if there is a Chance using the app car2go and drivenow. Please tell me. I couldn’t get it run, and i would need it to geht around in Vienna! Thx

Edit: already talked with Amsterdam. It is a software Problem with open source OS. It will be fixed.

1 Like

Do you have GAPPS installed?
I have the same problems. With Osmand i get a position a view seconds but then it disappears.
I tried a view things, described in this post

I Used xposed Modul for UnifiedNlp. In that post it is said, that UnifiedNlp doesnt work until now.

Maybe another important advice is that the PlayStore crashes every time i activate GPS.

@freibadschwimmer@peter974 you said, GPS works at your FP2. Do you have any GAPPS installed? Or UnifiedNlp? Or did you do nothing after flashing the FPOSOS and GPS worked?

Hello everyone,
I join this discussion because I also have problems with FPOS and GPS.
When using Android the GPS worked perfectly so I assume there is no hardware problem.
However, since I’m with the new os, the GPS (with osmand and high accuracy) barely works, most of the times it cannot get the location or it looses it very quickly. I can make to use the GPS only for a few minutes from time to time.
I see I’m not the only with this kind of problems and I hope they will be fixed soon!

I installed openGAPPS pico, so yes, I have GAPPS on the phone, though no UnifiedNlp.
I applied the INTERMEDIATE_POS=0 to INTERMEDIATE_POS=1 fix though before testing it, so I don’t know if that actually changed anything.

Thanks for the quick answer.
The PlayStore doesnt crashes? And you dont need any other app?
I just changed the intermediate position to 1 (& reboot) but that didnt help.
Where is the problem? :-/

Yes the play store crashes when turning on GPS, though I don’t need the play store when I need GPS.

So basically GPS worked for me without the need to install anything else.

One addition: I have tested GPS only with Oruxmaps.

1 Like

I have fposos, and pico opengapps, but I also “corrected” GPS.conf, specifically the xtra and NTP URLs

1 Like

And it works for you? With Osmand?
This is how the xtra URLs look in my gps.conf


I changed the URLs and erased the # at the beginning.
Same procedure for NTP. Right?

I installed Pico GAPPS and cant get the GPS working.
Tried it with different µg UnifiedNlp Apps. With and without the Xposed Modules. Without Wifi i get a wrong position or no position.
Does somebody has the right combination of apps, getting GPS correctly to work?

1 Like

I opened a topic for that exact issue, but unfortunately nobody replied with a solution or tip yet… :’(

Okay, thank you.
Does GPS works without Gapps?

Hi, in using fposos (now 16.04) with location services. But with problems. If you need the play store, turn location off, if you need location, use GPS, but have play store crashing…

Actually, if I turn the location off everything works well - except for the location obviously. If I turn it on the Play Store keeps crashing every few seconds but location still doesn’t work. No app was able to use the GPS even with the store crashing in the background… :confused:

Well, play store only crashes twice for me, and GPS works OK. But I manipulated the gps.conf file, which at least should correct the speed for getting a fix, not necessarily the functionality, but I’m not sure about this

And, now is your fix faster?
If yes, could you please share your gps.conf?
Thank you!
Lg ivi

Yes, the fix is faster… Just realized there are two threads about this, so, I’ll share my config here as well, of course

the NTP config could also be more specific (de instead of Europe), but I just was in France on holiday so I figured that more comfortable

Yes, GPS works for me without GAPPS. However, as @freibadschwimmer pointed out earlier, I also changed the INTERMEDIATE_POS=0 to INTERMEDIATE_POS=1 in the gps.conf

So, there is no updated software that fixes the nonfunctional GPS since May 11th?

Apparently not. However, you mustn’t forget that Open OS was only officially released on 28 April, which is less than a month ago. The people who experienced this issue before compiled their own OSOS version. FP was aiming to release monthly updates if I remember right, so I’d give them another month to fix this issue… :wink:

And if you cannot live without GPS at all: It worked perfectly well (actually a lot better than on my old phone!) with the stock FP OS 1.2.8!