English

Fairphone 2 Open OS is available

openos
Tags: #<Tag:0x00007fefc157a478>

#1

Hi all,

We are happy to announce that the Fairphone 2 Open Source OS version is ready! You can read all about it in our latest blogpost.

Head over to code.fairphone.com for all the info. We tried to make the transition as easy as possible - just follow the instructions. Once you are on the Open Source OS version you can easily go back to the default Fairphone OS (which includes Google Services) through the Fairphone Updater app on your device.

Happy installing!

Cheers,

The Software team


TeamWin Recovery Project (TWRP) for Fairphone?
Installation of FP Open OS doesn't work on my FP2
Discussion about "First steps on FP Open" Wiki
GPS doesn´t work on FP Open OS
Latest blog posts
TWRP Experiences, Pros & Cons
Fairphone Open Source OS is almost ready. Want to test?
:pencil2: Porting TWRP recovery
:pencil2: First steps on FP Open / first applications
Community newsletter input
Fairphone Open OS roadmap discussion
:pencil2: Rooting FPOS (with GMS) with Superuser (wiki needs updating)
File transfer from Mac
:pencil2: Operating Systems for Fairphones
#3

Update went smooth coming from FPosos beta using method 1 in the instructions.

First things I noticed:

  • User data was NOT erased coming from FPoos beta. Yay!
  • Clock doesn’t reset anymore after reboot (as it did in beta).
  • Superuser still tells me root is outdated, but it works fine.
  • µg UnifiedNlp still not supported

#4

Great to hear! Which exact file did you use? fp2-sibon-16.04.0-ota_from_gms-userdebug.zip or fp2-sibon-16.04.0-ota-userdebug.zip? I assume that when I am running FPoos beta already, the one without from_gms is the right one and only the first one wipes user data?


#5

I simply clicked on the link “latest version” which links to the file ota_from_gms-userdebug.


#6

So do I have to root the device again after fastbooting the image? Please tell me I don’t have to…
Are REALLY ALL old apps getting erased or is some goole sh*t still lying around orphand?


#7

Have you read the blog post? I’m quoting:

I’m not sure about Google Apps, but I highly doubt so. There shouldn’t be any traces left.


#8

Beware, this release has a charging bug. When the phone is shut off and you plug the charger, the Fairphone animation screen doesn’t show up. Instead, the phone shows the Fairphone splash screen and the screen remains turned on. No adb nor fastboot access, and physical buttons don’t work either. Only way to start the phone again is removing the battery and installing it again.

Other things work as expected. I suggest installing Xposed Framework (through preinstalled official TWRP recovery, ;)) and a plugin like Gravity box for further customization. If some of your usual apps depend on Google Services but you don’t want to lose your freedom by flashing OpenGApps pico package, take a look at microG Project.


#9

Power + Volume up gets me to TWRP from where I can Reboot > System. Maybe better for the cover if you don’t remove the battery every time.


#10

I’ve never tried that. Thanks for the tip, Paul! :slight_smile:
It remains a sloooow and non-sustainable battery charge, though, :frowning:. Hope they fix it soon.


#11

How did you do this? I get a whole bunch of errors in TWRP.

  • “unable to find partition size fo ‘/misc’”
  • “unable to find partition size fo ‘/bootselect’”
  • “unable to set bootloader message”
  • “E: Zip signature verification failed: 1”

I used “xposed-v83-sdk23-arm.zip” is that the right file?


#12

You need “xposed-v83-sdk22-arm.zip” :wink:


#13

Thanks, but that gives me the same errors…


#14

Wooohooo, finally :smiley:


#15

That’s right. sdk23 corresponds to Android 6.0 Marshmallow; sdk22, to 5.1 Lollipop. For future reference, here’s the official link to Android API levels.

I’ve not installed it on the official release yet. Tried it in the beta release and had no problems at all, :confused:. I’ll check it later, I’m on the go right now.


#16

That’s really great news. You saved my weekend.
Thank you Fairphone crew,
I’ll have a beer on you!!!


#17

You need to disable signature verification somewhere in TWRP.


#18

Nice. I haven’t looked into this, but thank you for all your hard work.


#19

Thanks, now I don’t get the error and TWRP says “Success” but after a reboot there is still no XPosed Installer on my phone. Tried it twice to make sure…


#20

Installing the Xposed framework zip in recovery is the first step, after that you install the Xposed installer apk in Android.


#21

@rick: Nice! Thanks a lot for your great work! :thumbsup:
Some comments/questions on this:

  1. Have all the changes been included into the downloadable Gerrit code for compiling? I.e. is this code up to date with (the bug fixes of) the FPOS 1.2.8 version? I don’t see much changes in Gerrit code review, but I’m also not that familiar with Gerrit, so I might just have overlooked it …
    I guess that TWRP and root access are not included in the code, as everyone might add this by themselves if they like to?!

  2. I’d be interested in how you incorporated root access?! Have you essentially followed @Max_S’s path of building a boot image including a su binary or did you take a (totally) different approach?

  3. I’d really like to see support for Unified Nlp in the FPOSOS as well, and from your description it seems that you’re already working on it. Just to play safe: You are aware of @jochensp’s patches to make Unified Nlp working, aren’t you? :wink:
    By the way,

There are problems acquiring your geo-location on the device

sounds a bit harsh, given the fact that GPS should work flawlessly and quite accurate, I guess. At least, it does so on my self compiled version.

(@All: Sometimes the forum software sucks. I wasn’t able to get the last two sentences indented. Now it looks as if this paragraph doesn’t belong to the third point - but it should! Any idea how to do this? If I delete the blank line before it, it gets merged into the quote, which is also not what I want. These types of bugs are what I sometimes hate the HTML and WYSIWYG editors for. :rage:)