English

Installation of FP Open OS doesn't work on my FP2

Continuing the discussion from Fairphone 2 Open Source OS is available:

I tried to install the fp osos it doesn’t work:

Method 1.
After loading “amaze” I could find the installation zip-file, but going on it I saw onlly some files and directories and the question to open it with different kinds of software.

Method 2:
After installation of the zip-file I rebooted the phone with pressing the volume down key. After that the sceen has been blockt, and the only thing to get the phone working again, was to take out the batterie and put it back again.

It may be interesting, that I do get messages when I boot my phonr like:
“Ungültige Signatur”, “falsche Datei heruntergeladen” oder “Fehler beim Runterladen von config.file”. I am using the 1.2.8-update on my FP2.

What is wrong with my system?

Did you try opening the downloaded zip file in Amaze with the (Fairphone) Updater App? This worked flawlessly on my FP2 (running with the 1.2.8 update). I downloaded the latest version like mentioned in the Installation Guide.

After installation you don’t need to reboot into recovery or fastboot.

You can however, alternatively to installing from Amaze, install the OS from fastboot or recovery mode.
Note that [Vol down] + [Power] brings you into fastboot mode, not into recovery mode. A black screen (with FP logo) is the normal behavior in that case.

"Did you try opening the downloaded zip file in Amaze with the (Fairphone) Updater App?"
What I did now again:
At the FP2 I loaded down the installation file “fp2-sibon-16.04.0-ota_from_gms-userdebug.zip”. Than I called the Updater App and did the Updat with it. But it again downloaded an Update und installed it and in the end I did not get the google-free Os but the one I already did have before.
So I did something wrong! How do I have to open the downloade zip file in Amaze with the (Fairphone) Updater App, step by step?

I

Try the following: Open Amaze, go to the downloaded file, tap on it - now you should be able to choose how to open that file. Choose Updater and then the installation starts.

Does this work for you too?

1 Like

Yes, it works!!! Lots of thanks to you, Juli_R!
Heiner

1 Like

I have been so happy to get the FP2 with OSOS running. I also achieved to play back my apps and my contacts. But than it happened: Trying to get root access the phone shut down and is booting again in an endless loop. I can’t tell you exactly what I have done to get this reaction. After the boot screen with the “FAIRPHONE”-Logo and the one with saying “loading” or something like that a message appiers, saying: “Android wird gestartet…” and in the next line: "App ‘xy’ von (z.B. ‘207’) wird optimiert… And it runs through all apps and after that is done, it starts again with a reboot. To take off the battery doesn’t help. It goes on again in the same way after replacing the battery and switching on the phone.
Does anybody have an idea what to do now?

Hi Freibadschwimmer,
thank you a lot for putting things right I have done wrong. As you can
read at my answer to Juli_R I have solved this problem and after that I
have got a much bigger one! Probably I have to send in my phone to
FAIRPHONE for repair.

I have read of people getting stuck in such a boot loop for several hours.
Some plugged in their phone and let it run/reboot over night, and in some cases that helped.
The phone seems to optimize something, though I cannot really say what it is doing.So this could be worth a trial.

As long as it still boots to some extent, I doesn’t seem to be completely bricked.
Can you still access the recovery mode? You could reinstall the OS from there (maybe just the boot partition is corrupted). If you can’t get into recovery mode, you could still connect it to a computer and try to fix it in fastboot mode.

see also:

But how do I get into recovery mode? In the moment I can’t even connect to the phone via usb, probably because the phone is still booting? But I will try to run the boot loops to an end.

You can into recovery by:

  1. Turn off your phone
  2. Press both [vol up] + [Power] buttons at the same time for a couple of seconds (until it vibrates)
  3. release the buttons after vibrate.

It should then boot into recovery. To get into fastboot mode, the same procedure but volume down. You’ll need to have software for fastboot on your computer to make it work.

See also:

Now I have done the continuing looping for something like 36 houres. After about 20 houres the phone switched off by itself, showing a black screen and not reacting to any key or key combination. But when I connect the phone to power via USB, the black FAIRPHONE screen with ‘POWERER BY android’ is shown and the loop optimizing apps starts again. So I think, I have to contact the FairPhone support team for that problem.

Did you try to access the recovery mode?

I tried, but I can’t boot the phone in any mode, it allways switches to the app optimization loop.

Even if you take the battery out, put it back in and then keep Power + Volume up pressed until it vibrates after an estimated 10 seconds?

Even then it doesn’t work!

I have to admit, I am a bit surprised that the recovery mode does not work.

However, thinking about it, it is possible that while flashing the recovery.img was not installed correctly or that the image file from which you flashed your system was somehow corrupted.

What happens when you try to boot into fastboot mode (same procedure as for recovery, just with vol down); do you also get the app-optimization notice, or what does the phone do?

It does the same as before.

Hm, that does not sound good.

If neither recovery nor fastboot mode work, then I don’t know anymore what to do or recommed.
Maybe someone else has an idea.

Did you enable root access by using the preferences entry in FPOOS under the developer options or have you tried another method? (Then: Which one?) If you did it in the settings, maybe you should contact FP support and tell them about the major problems that have occurred now.