FP 2 –> Android is starting … Optimizing app X of N –> starting Android –> nothing happens

My friend pressed the power button and the volume down button for 10 seconds.

After that fairphone switched off, than we tried to restart it.
First black screen with "fairphone powered by android"
After that white screen with blinking "loading"
Next: Change between white and blue screen with “Fairphone” or "Fairphone - start a movement"
Than for just a little moment "a small frame which says "Optimizing app x of n"
than back to white screen with blinking "loading"
That changes all the time between a duration of 2 min…
After an hour or so my phone turned off and the red small charging light was blinking…

Please help me, I really don’t know what to do…

Thanks in advance

If the red charging light is blinking, it means that your battery got deep empty. Let it switched off and charge it.
About the optimizing app problem: look for it in the forum, the problem was reported here before ( for example after enabling quickboot). As far as I know, the best thing to do is waiting until all apps are optimized and your phone starts nomally. Since this can take a long time, I would recommend to leave it connected with the charger.

Hi Dave.

One simple thing you could try is still to take the battery out for a minute. Put it back in and start it again.

If this doesn’t help (which I would guess) you could try to boot from the original xxx.img straight from the PC using fastboot, like

fastboot boot boot boot.img

or (more likely to be successfull)

fastboot boot system system.img

to see if boot.img or system.img are damaged somehow on your phone.

For closer information and about where to find the xxx.img files, search and read in the forum.

If this works, you can flash system.img or system.img.

Somehow the phone (Android) seems to “believe” that the system has been updated. Otherwise it wouldn’t optimise the apps.

Thank you for your answer,
the problem still exists 'cause my phone doesn’t connect to my PC. I can connect it, but it’s nowhere shown on my explorer…
One strange thing is, when i put the battery out it turns off. To switch it on I have to put the charger on,
put the battery out and leave it just connected to the charger. Than it switches on and off all the time untill I put the battery in, after that the same thing happens again: black screen, white screen, blue screen, optimizing app… and so on
I left it connected to the charger for couple of hours, but nothing happens, still the same thing… “optimizing app”.
Sometimes it’s like “optimizing app 5 of 140” sometimes “20 of 187” sometimes “15 of 187”. So I don’t see there any progress…

1 Like

Thank you for your answer put no progress yet :frowning:


are you sure, your friend did not turn on “Quickboot”?

Did your charger in combination with the same cable charge your phone fully up before already? If not, try different charger/cable.

Are you able to enter Recovery Mode (Switch off, then Power button + Volume up?
In order to flash (or boot) a new *.img file, you need to install the ADB driver on your PC. Here you can find more Info.

Also, to flash or boot with fastboot, USB-debugging needs to be activated. Did you (or your friend) turn that on?

The easiest thing for now is probably trying wait and sleep


je suis l’heureuse utilisatrice d’un Fairphone 2 depuis un peu plus d’un mois,
mais depuis hier il fait la même chose que celui de Dave_marras, Il m’est donc inutilisable …
je ne pratique pas assez l’anglais pour comprendre ce qui est proposé …
Qui pourrait m’aider ?
Merci !

I have exactly the same problem and I am not able to fix it. Can anyone help me?

Thnak you.