English

Location Service (GPS) issues with FP Open OS running OpenGAPPS and Xposed

I installed FP Open OS, the OpenGAPPS pico and Xposed a couple of days ago. Everything works fine except for the Location Services. After install the error message “Unfortunately, Google Play Store has stopped.” popped up, but I read here (I think from @freibadschwimmer) that this can easily be solved by turning location off. I did and everything does work fine - except for the location services.

I also read that people compiling Open OS themselves in the early days (January ish) had the same problem and @flipreverse found a solution for this. Reading this forum I came across the Unified NLP and had a look at F-Droid. There I saw that I have the NoGAPPS already installed (concluding it comes with Open OS) and that there’s also a GAPPS Version. However, from what I read it seems that I cannot just deinstall or install those like regular apps.

Can somebody help me with this issue? Should I just install the other version, or do I need to run/implement any scripts?

Edit: Implemented the new OS name :wink:

1 Like

I think that comes from GAPPS.You can see it at my Screenshots. If i want do uninstall the one in the middle, it is the Google Play Services.
But i tried the other Version (GAPPS) and (NO GAPPS) without effort.
I try to install the other Apps, listed there. At the description from µg UnifiedNlp (no GAPPS) they talk from different backends which has to be installed.

1 Like

I’m actually wondering right now if microG would a better option than OpenGAPPS and opened a new post to see if other members here have already tried it and what their experience is so far.

I tried the whole microg thing without effort.
The blank store doesnt show all apps and GPS doesnt work either.
As far as i understand you need in each case a Backend App (Screenshot). And every app uses a alternate way to locate the position. But i want simply locate the phone with GPS and without any databases etc.

Please continue here: