English

Sailfish OS 4.1.0.24 release2 for Fairphone 2

Sailfish OS 4.1.0.24 release2 is now ready (Sorry for the long delay with the release). Installation and update instructions can be found at Adaptations/libhybris/Install SailfishOS for fp2 - Mer Wiki. Highlights of the new release:

  • Updated to Sailfish OS 4.1.0.24
  • Based on Android 6 (18.04 release)
  • Kernel update from Fairphone Open Android 9 release (various security and stability fixes)
  • Device shutdown issue fixed

IMPORTANT When updating from Sailfish OS 3.3.0.16 be very careful to use the hack mentioned in the instructions and to not skip the intermediate updates mentioned in the update instructions (wiki link above), your device will not boot successfully if you skip those.

If you are updating for a Sailfish OS release older than 3.3.0.16 please check Sailfish OS 3.3.0.16 release1 for Fairphone 2 for more information. You can also contact me directly.

Known issues:

  • If anyone still notices the previous issue that updating camera configuration fails during camera module change, update or installation please report it to me and use the fix mentioned in earlier release notes (Sailfish OS 3.0.2.8 beta5 release)
11 Likes

Hello SailfishOS fans :wink:,
i installed three FP2s with this new version - two via update as described and one from scratch.
All work fine, the updates and the installation. Here i have to restart the camera detection once, described on the installation instruction (the FP2 have a new camera module).
So thank you @mal again for your high quality releases :slight_smile:.

3 Likes

Thanks for this! But somehow it won’t do. I tried to install it following your instructions on Adaptations/libhybris/Install SailfishOS for fp2 - Mer Wiki on a FP2 where formerly the release FOOS 21.05.0-rel.1 was installed. First I installed twrp-3.5.2_9-0-FP2.img, and then tried to install the older release 18.04, and then the Sailfish OS 4.1.0.24, as stated. But it wont run, the first two times it came into a loop while booting (and funny enough I always had to enter the code I used before), and now, the third time, it shuts itself down. Did I forgot something to wipe out or so? Thanks for a hint.

@unaegeli Maybe you could try wiping data partition before installing Sailfish OS to make sure there are no conflicting things from the previous Android installation in there (Sailfish OS uses some part of lower level android drivers and if there are files from different Android base it might get confused). How fast is the boot loop? What do you mean by having to enter code you used before?

I mean the password to unlock the screen resp. the gesture I used with the FOOS 21.05. So my guess is that the FOOS 18.04 has not been installed properly as, of course, I was not yet able to define a new password. I will have a look where I can wipe out more data.

Thanks anyway for your help!

Hmm, at TWRP it first said cannot mount ‘/data’ (Invalid argument) but then I selected as much folders as possible and then I could install FOOS 18.04 and Sailfish OS 4.10.24 (but I am still working on choosing German as my language… :slight_smile: )

Should work ;-). Take a look to section system on tab system at settings …

Thanks, I’ve found it and all runs well!

By the way: somebody told me that there is also a way to implement Android apps on this OS. Is there an extra store for it?

1 Like

Aliendalvik is a 3rd party plugin that jolla licensed for there releases and is not available for community ports.
You can search the jolla store for native apps or install storeman (take a look here) for access to the openrepos repository.
Before installing apps read the description and look whether the app is maintained or out off support - some apps has its latest updated 2015 :thinking:.

I see - schade, dommage! Because there are some apps I definitely need. You can do a lot of things with an internet browser and via email but not everything. For instance there is no other way to use Threema than with an app. And there is no app for this in the Jolla store.

Therefore Jolla Sailfish cannot be my everyday OS on Fairphone (neither does ubuntu touch for the same reasons). I will continue with /e/OS, quite a good alternative (although with some annoyances, too).

Have a good time everybody.
Dixi.

Some years ago, mal tried to port anbox for Sailfish, but is not working on it anymore…

Issues came from old 3.4 kernel and from anbox <=> wayland backend compatibility, as far as I remember :wink:

2 Likes

Thanks @mal. The update(s) went smoothly and 4.1.024 is running just fine so far. :tada:

2 Likes

Don’t forget OpenRepos. There is no shortage of messanging apps for SFOS. Also, Threema is AGPL software AFAIK. So porting it should be possible. If the company refuses to allow 3rd party apps to interact with centralized servers under their control, that would be a great reason to stop supporting them and switching to another end-to-end encrypted messenger. Personally, I am using neither but see no disadvantage of e.g. Matrix over Threema and there is a client readily available.

IMHO, just the UX improvements of SFOS over Android (and thus /e/OS) easily outweigh the inconvenience of switching an app or two one got used to (or as you put it: ‘needs’).

Either way, enjoy you alternative OS experience (it is all about choice in the end) and have a great one!

Honestly, I don’t understand a lot of your message - there are too many abbreviations not familar to me, sorry.

I don’t have the time to “bastel” as I would call it in German, either the things I need are available, or then I let it be. Dixi.

Sorry for abbreviating so much:

  • SFOS → Sailfish OS
  • AGPL → Affero GNU (sorry for eplaining an acronym with another one, but there is no other way since GNU literally is short for ‘GNU’s not UNIX’) public license; a free and open source (FOSS) software license that the Threema source code is released under.
  • AFAIK → as far as I know
  • IMHO → in my humble opinion
  • UX → user experience
  • OS → operating system

Regarding the non-‘bastel’ solution, my suggestion was to look into Matrix as an altenative to Threema. While not available in the Jolla store, you can easily install the Storeman app to install Sailtrix from OpenRepos. If you find you really need Threema, I’d be curious what it offers that Matrix fails to provide

But like I said: I just wanted to suggest a way forward, if you prefer Threema under /e/OS, who am I to judge?

3 Likes

Thanks for the explanations.

And no, Matrix is not an alternative to Threema, as half of Switzerland is using it now and so there are a lot of lists and chats etc.

@mal Trying to update to first intermediate 3.4.x.x and have a question: Is there a little flaw in the wiki?

version --dup
NOT AUTHORISED. This tool must be run from a privileged shell.

Ran it successfully with “devel-su”.

2 Likes

I thought it mentioned devel-su, if not then I will fix it.

1 Like

A quick status update for next release. I tested updating Sailfish OS 4.2.0.21 and it worked without issues. Based on quick test of all hardware features and built-in apps I haven’t seen any regressions so far. I will continue testing in daily use a bit more to see if everything works correctly.

3 Likes

Hello @mal,
installation works without problems. Also all jolla apps, Nextcloud, email and Browser.
But camera issue occurs as described on earlier updates.
After restart of detection process (three times :thinking:) the camera setting was successfull.
Many thanks for the update
gabs