Sailfish OS release2 for Fairphone 2

Hello, I’m happy with Sailfish on Sony, but I want to try the sustainable path.
My FP2 was a clean 18.04 (I installed no TWRP nor openGApps, and yes, I calibrated the proximity sensor etc).
I flashed it via fastboot as described in the Sailfish wiki (i.e. ./

After fastboot reboot, the app optimalization completed, but it hangs saying “Android starting, preparing configuration” (translated from my language). It takes forever …
(I haven’t begun with the sailfish zip part yet.)

While still hanging at the configuration: The fp2 is listed as an unauthorized device by adb.

What is the recommended path from here? I am bewildered by many different suggestions online, a hint would be great!

I’ve downloaded TWRP 3.5.2_9, but is it safe to “flashboot flash recovery twrp.img” with an unconfigured android from (I would need to turn off the fp2.)

Is TWRP necessary or only recommended?

I run adb/fastboot on a Debian stretch with version 7.0.0+r33-1.

Best regards

@treadmill Hi, if you have already calibrated the proximity sensor and you have flashed Fairphone Open 18.04 as told in the instructions then you then don’t need to boot to Android before installing Sailfish OS, just go to recovery (twrp should be fine) and install Sailfish OS zip on top of the Fairphone Open 18.04 installation.

Thank you, that helped. The pre-installed TWRP worked just fine. Smooth. Only one problem: just after finishing the obligatory gesture teaching tour, the phone froze and the battery looked empty (red LED). A reboot solved that.

Info for people who are not constantly wifi-online: The “semi-permanent” battery power saving mode seems useful to prolong battery life somewhat.

Best regards

Hello @mal,
using the Sailfish OS about two weeks it seems everything is fine, except a small issue with wlan detection.
Some time it seems that known wlan connection did not work when in operating distance.
I did not see a deterministic behave, but sometimes when i leave home and come back (without come in reach of an other known wlan connection) the wlan symbol is in searching state and did not connect within hours. Stop and start wlan resolve the problem (so it is no big problem - but should be known if someone is waiting for emails or messages :wink:).
I dot not use mobile connection when i leave home for a short time.

I think there was some known issue with wlan handling, I will check if it was also in 4.2.0 or some other version. I have also been using 4.2.0 for quite a while now and no big issues so maybe it could be released already.

1 Like

I’m still in release1 and I have now time to update to release2 :slight_smile:

If I understood well, going from release1 to release2 is equivalent to 3 upgrade process:

IMPORTANT! You need to update from first to (note the hack mentioned above), then update to and finally update to Always reboot after each update.

The mentioned hack is a new file to add, here are the step I do in a terminal:
cd /lib/systemd/system/
devel-su mkdir dsme.service.d (this folder didn’t exist before!)
devel-su touch sandboxing-disable.conf
devel-su vi sandboxing-disable.conf (nano is not present :cry: )
Then I tried to paste (with P) but without any success… (error E353: Nothing in register ”)
Paste with “Shift + Insert” :white_check_mark:
Save file with “Esc” + :w :white_check_mark: and exit with :q

@oli.sax Did you remember to use devel-su when using vi to be able to write to the file?

1 Like

Thank you @mal! After this modification, the rest of the upgrades was flawless :slight_smile:

| Sailfish OS (Rokua) → | Sailfish OS (Pallas-Yllästunturi) :white_check_mark:
devel-su rm /lib/systemd/system/dsme.service.d/sandboxing-disable.conf
Error msg: [D] unknown:0 - "No carrier"

| Sailfish OS (Pallas-Yllästunturi) → | Sailfish OS (Koli) :white_check_mark:
Error msg: -bash: /etc/profile.d/ can't open /proc/12829/environ: Permission denied

| Sailfish OS (Koli) → | Sailfish OS (Kvarken) :white_check_mark:
No error msg. :wink:

I also noticed that we have a new screen background :partying_face:

New release now available at Sailfish OS release3 for Fairphone 2


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.