English

Has anybody received the latest security update yet?

Just tried it with a couple of Sim-Cards I have from trips to other countries, no success so far.

1 Like

Last update : A.0111.

OTA url (from A.0105) : https://android.googleapis.com/packages/ota-api/fairphone_fp3_fp3/05f054a6029b23dcd171ded487dedb929ae99dc1.zip

1 Like

Now I was successful and got the update A.0111.
First I switched off the FP3 and removed my Vodafone Germany SIM card from slot 1.
Then I inserted a Telekom D1 SIM card (a prepaid data card which is normally used in my notebook) in slot 2.
I turned the FP3 back on and the update was available immediately. Then the update was installed. The last step was to turn off the FP3 again, remove the Telekom D1 SIM card and reinsert the Vodafone SIM card.

1 Like

OTA url for A.0110 to A.0111:
https://android.googleapis.com/packages/ota-api/fairphone_fp3_fp3/aa5b9a803df448ac71f37e27a0f8088f8e6fc920.zip

1 Like

Hi ,
I am still on update A0105 .Only automatic emails from support, otherwise no sign of life.
Now I tried the OTA update via sideload from the SD card.
I can select the OTA file in recovery mode.
the error always comes - error in sideload package zip status 1.
knows someone there and can help me.
Thank you

Finally i was also sucessful to get the latest update. Removed my Vodafone Germany SIM and put in a Prepaid SIM from Blau Germany. Update was immediatly available. So there must be something wrong with the Vodafone SIM…

Just a thought, but has anyone tried adding ‘fota’ to the APN Type field in the APN settings?

To do this, you’d just add a comma then fota (default,internet,mms,fota)

This is the APN type for enabling firmware over the air updates, so just wondered if perhaps that’s got anything to do with it.

ps I don’t think this will make a difference, but just a thought

3 Likes

I can confirm this solution. The problem is a SIM card from Orange (France) or Vodaphone. You have to replace the “bad” SIM with another SIM from other phone-providers (Even deactivated SIMs work! Of course you need a PIN…). Connect WLAN, goto Settings > Systems > Advanced > System Update > Check for updates. The update was there immediately…

1 Like

In case this helps anyone - I managed to get the update by replacing my current Vodafone (UK) SIM card with an old, deactivated Vodafone sim. It didn’t work with just taking out the current sim and trying to find an update with no sim in the phone at all. Go figure…

But just so you know, you don’t necessarily have to find a sim card from a different provider if you happen to have an old sim card lying around,

2 Likes

I was having just that problem and solved it with a SIM card from Laos…
See my post here:

Yes, looks like it’s not Fairphone’s fault, but something in the connection over internet at operator side which has to be uncovered.

Can you tell me, if you and all other with the problem, as far as they read this thread here, do you have the “SecureNet” product from your (Vodafone) operator or any virus scanner product which comes with many tariffs by default?

@Amber: No, I do not use such security product. It does not come standard with the Lidl Connect SIM either.

Sad is, though, that the supports simply was not willing to help me. Since January I have been mailing back and forth with my support agent and all she kept telling me was that “the update is eventually going to become available”. It is ridiculous, though, not to be able to install a January security update even in mid-April.

Fairphone should be interested to provide satisfying service. My work-around using the SIM card from Laos worked, but it is not by any means an achievement of the customer service.

1 Like

Hi,
When I had an email exchange with Support on the subject in January, they didn’t seem to realise there was a problem.
They obviously thought the problem was on my side and, despite me telling them the contrary, assumed I’d bought my FP2 through Orange (France) and that I should contact them for the update.
I ended the exchange at that point after realising I could update with my work SIM (SFR, France).

1 Like

I got to know that it does not have anything to do with the Vodafone network as previously said by people, but it has to do with the capabilities stated by Fairphone and the OS as delivered by them: The Fairphone OS does not ship the VoLTE and VoWiFi capabilities as stated in the Fairphone shop (see also the answer from Fairphone support in the article How to use VoLTE on FP3). Therefore Fairphone must deliver its OS to Vodafone where it is checked for Google certification, enhanced by the named capabilities and tested afterwards.

In last months there seemed to happen a problem in the agreed process between Fairphone and Vodafone - maybe caused by the Corona homeoffice rules on both sides. Now, even without your intervention on Vodafone side, this process is ongoing again and I hope that a new update can be delivered in the next few weeks. Additionally there is an improvement plan to make this process faster and easier, so that updates can be provided in time.

3 Likes

This explanation does not make sense to me, since updates are being delivered OTA instantaneously (including VoLTE and VoWiFi AFAIK) once you insert a non-Vodafone SIM card and Vodafone does by no means block them after re-inserting theirs.

I don’t see a problem for carrier-specific updates even when stored on Google or delivered via OTA or using another SIM than Vodafone for update. The problem is: Does the result work for the functions in question on the vendor-specific network? Please refer again to the before linked article from Fairphone support (which is why I’ve linked it).

In this case, Vodafone is not blocking the update, just the before agreed process between Fairphone and Vodafone didn’t work out as expected and thus unfortunately cannot be delivered to the customer. Please give another ~2 weeks time.

Fo everybody able to read and write in german language please use -> 🇩🇪 🇬🇧 Kein Update vom Januar 2020. From everybody else, I’m happy to respond here.

Wirth O2 both works fine

1 Like
3 Likes

Amber’s post was not quite clear to me in either language, but as I understand it, the January update enabled VoLTE or VoWifi for some operators but not Vodafone, and Vodafone decided to withhold the update until it was enabled for them as well.

Thanks for letting us know! As I need to change my SIM to get the update, it’s useful to know when I need to do that :slight_smile:

Just installing now…

(and hooray for the notification LED!)