English

FP3 A.0111, Android9 OS update, security patchlevel February 5th, 2020

I’m trying the ADB option. It doesn’t see my phone when I connect it with usb. On the manuel there is no explanation witch option you should put my phone on (ptp, midi, usb-tethering, filetransfer) etc. I’m using macos. Does anyone has an answer on this?

Found out that you have to put usb debugging on. And that you have to tab you device build-number for a number of times to get devellopper options.

And then?
I get: “Fairphone/FP3/FP3:9/8901.2.A.0110.20200109/01092024:user/release-keys”.
adb is working, only I don’t have an image for the A.0110 version to update from. Can anyone provide this one?

Now I was successful and got the update A.0111.
I removed my Vodafone Germany SIM card and inserted a Telekom D1 SIM card (a prepaid data card which is normally used in my notebook). The update was available immediately. I bought my FP3 at Vireo.

1 Like

I’ve tried with a KPN SIM, and it does not work. Even when removing the Vodafone SIM. Enabling USB debugging does not solve the issue for me either. Disabling VPN does not solve the problem either.

1 Like

Thanks for the file. But every file I get ends at exactly 47% of transfer. The message:

Update package verifiaction took 6.5 s (result 0)
Installing update...
E: Error in /sideload/package.zip (Status 1).

What goes wrong here?

I do’t get this update on my FP3. I have the last update from 2019/12/05. What can I do?

Okey, I fooled my FP3. I still had an old T-mobile sim card. It won’t work anymore, since I’m now at KPN. But then the update picked up and now I installed Netflix successfull. And also ASN Betalen can be installed now. I will try paying with it tomorrow. :smile:

4 Likes

I’m also not seeing the update. No matter with or without my SIMs (one of which is Vodafone.de and the other T-Mobile, I think). Also playing with the dev options didn’t change anything. Any other ideas?

Have you just removed both Sims or did you leave the Telekom one in the Phone?
removing both didnt help me, but using my boyfriend’s o2 card was the solution.

1 Like

The trick was to remove both sim cards and replace that with one form T-mobile. After rebooting my phone the update was available. And that T-mobile sim isn’t valid anymore because it stopped working on 1 January 2019. But still it worked.

2 Likes

I just smoothly upgraded to A.0111, temporarily using someone else’s Tele2 SIM as the only SIM.

I would hope that this weirdness will not last and will write my provider. Or maybe switch to Tele2 :upside_down_face:

4 Likes

Same here, it just does not want to work either with Xs4all (KPN) or Vodafone SIM or without a SIM. Could I manually install that zip somewhere?

You need this and this – if you are currently on A.0105

I’m on A.0110. I manually flashed it on, and locked the bootloader afterwards. Maybe the updater does not like that…?

So yeah, the nanosim I ordered by KPN/Xs4all does not solve the problem. I’ve ordered a T-Mobile pre-paid SIM for 10 EUR. After that I’m out of options. I can’t reinstall everything every update…

My experience with the updater is that a supposedly somehow corrupt state of the OS doesn’t prevent the updater from offering you the update.

The update process will start nonetheless and shortly after it will simply end with an “Installation problem” … which you can get the cause of with having adb logcat running simultaneously and having a look at errors of “update_engine” afterwards.

Your case more seems to be the notorious SIM card trouble. Fairphone really should get this sorted out.
Luckily I’m already in update-happy Telekom-land :slight_smile: .

@Lidwien does it work for you with the KPN/Xs4all nanoSIM?

For A.0110 the right .zip is here.

No, it doesn’t work with my only data SIM from KPN/Xs4all nanoSIM.
And my other SIM is from HollandsNieuwe = Vodafone, same result, it doesn’t work.

On the 15th of April I switch to Youfone=KPN. Although the SIM is yet not provisioned I tried it, but no update.
I have to wait and see if I can update when on the 15th of April I switch to Youfone.

1 Like