English

FP3 A.0118, Android9 OS update, security patchlevel April 5th, 2020

I just got a notification for the newest FP3 OS-update with the april security-patches AND (finally) the implementation of the notification-LED :smiley:
I’ll install it later today…

photo_2020-04-24_15-14-01

7 Likes

Heeeey, another security relevant update I am not receiving. :crazy_face::ok_man:t2:

I wonder if the “minor fixes for various carriers configurations” will improve on the no-update-for-vodafone-orange issue (once affected people were actually able to get this update).

Edit: I can confirm that the notification LED works now.
Ask me in a couple of days if I find this a good thing or not :laughing:
Actually I didn’t miss them…

3 Likes

We hopefully are able to decide to switch it off, I guess.

1 Like

So no headphone jack bug fix :frowning:

2 Likes

Update from February 2020 FP3 Android9 level to this April 2020 update level went okay, it booted fine without issues.

Immediately into the Android9 though, I am sometimes using apps like OpenSignal and others to monitor and record e.g. Mobile Network coverage and operators and similar stuff.

OpenSignal 3G 4G 5G Signal and WiFi Speed Test (by opensignal.com) - crashes

Broadmand Measurement (by zafaco) - crashes

These apps seemingly immediately crash when activating the Location function of Android9 and the apps then trying to make use of it, draw on their respective maps and functions like that.

One other more simple one for general GPS and tracking usage named GPSTest

does not seem to have problems making use of locations services and draw its map and visualise stuff.

Anyone else having location based issues? :frowning:

finally notification LED :partying_face: that’s an unexpected suprise :smile:
It promts the questions why Fairphone didn’t communicate that they work on it, as so many requested the implementation (or did I miss it?)

1 Like

Me. My phone is update to date with Patch Level December 5th.

Ah, that’s a pity. If someone provides a download link for the update from the previous step (i.e. 5 February 2020 patches, so I would need A.0111 –> A.0118 ), I’ll finally be able to try the manual installation procedure.

1 Like

OK. The Update is done, but were is the LED configuration in the menu???

1 Like

Settings - Apps & notifications - Notifications - Blink light (On/Off switch)

(Seriously, if you would go as far as not labelling it with something people would find via searching the Settings for “LED”, then I would have labelled it “Blinkenlights”, but that’s just me :slight_smile: .)

5 Likes

OTA url (A.0111 to A.0118): https://android.googleapis.com/packages/ota-api/fairphone_fp3_fp3/5eb21a4176987155a3821bab53edff045d6a33ae.zip

4 Likes

Thank you, but it seems I cannot install it via SD card in recovery mode.
(“E:Error in /sideload/package.zip (Status 1)”, then “Installation aborted”.)

1 Like

For a good time, run telnet towel.blinkenlights.nl

4 Likes

There are already several posts regarding this in the forum, there is no /sbin/update_engine_sideload in the boot image. I think Fairphone needs to enable something in the build process for this to work.

1 Like

I know the notification light has religious followings both for and against, but to all those who think notification lights belong dead: thank you for taking a few seconds to disable it so the rest of us who do want it can enjoy it. :heart:

3 Likes

I don’t care about notifications but I bought an FP because it is supposed to last me several years but I am still on the update from December. I am using Dutch Vodafone. What do you recommend? Should I contact Vodafone or Fairphone about this issue? It’s really starting to grind my gears! I live alone and don’t have access to anyone’s SIM from another provider right now, but have any Dutchies been successful updating with another SIM and if so, how did you do it?

If you trust @Amber then you should just be a little bit patient (see here, here or here - sorry the latter two posts are in German only).

4 Likes

Thanks, I really hope it is true. In the meantime I am still interested in hearing from people who successfully updated using another SIM with specific details on how they did it (which provider, which slot, etc.)

2 Likes

I’ve just turned on an FP3 here without a SIM card, and if I go to System > System update, it shows the available update. I know you’ve tried that before but it really ought to work - but if it doesn’t, I think contacting Vodafone may be the way to go.