English

Has anybody received the latest security update yet?

The last update I received on my FP3 was 5th Decemeber 2019 so I haven’t even got the January one yet. I have run check for update several times and it says “successfully completed” but no new updates are available. So anyone with a January pack is already doing better than I am. I dont know if it makes any difference, I cant see why it would, but I’m in the UK.

It would not be the country in that sense making a difference, but it could be your network provider.
There was an update delay situation earlier with Orange in France, which was resolved later.

What’s your network provider?

I agree. If you haven’t had the January update yet, I would recommend trying in Airplane mode with just Wifi activated or taking your SIM card out.
There have been issues with providers who sell FP3s and don’t make the difference between FP3s bought through them (for which they provide the updates with their bloatware) and FP3s bought on the Fairphone website.
The trick is to update with another SIM if you have one or deactivate/remove your current SIM

1 Like

Hi,
I have the same issue. Still december security update and it shows that everything is up to date. Bought the FP3 from Vodafone Germany. I also tried to Update without Sim and in airplane Mode. I have send an e-mail to the FP Service but no reply so far.
Any Idea how to get the latest update?

Hello,
the same here. Still december security update and no further update available. I bought the FP3 from the reseller Vireo for myself and the provider is Vodafone Germany. Any Updates in Airplane mode not available, too.

Hello ,

I have the same problem .The latest is the december security update .FFP3 says is up to date .
I bought the fairphone from vireo. My provider is vodafon germany .Try without a sim card and in airplane mode do not work

Hello,

No the last system update received is same as you…

hello gamtrad,

I didn’t express myself well .currently is build FP3 A.0110, on my device is Build A.0105.20191217

Hello,

I have the same problem here: still on security level December.
Bought mine from memo AG in Germany in October last year.
I had since then two updates (or maybe only one - sorry, can’t remember yet) without problems.
I contacted the support today. I hope, they have an answer.

2 Likes

Similar problem in the UK - still on Android 9 and the December security patch. I’m with Vodafone, which FP recently got a contract with (but I bought my FP3 directly from FP), so I thought it might be similar to the situation described above, with Orange in France. So I tried to check for updates with my SIM card deactivated, but that didn’t help.

I’d be interested to know if other UK Vodafone customers here had a better result (and a similar problem!)

2 Likes

I had the same problem, am using Vodafone NL (but bought it directly via Fairphone). Could it be related to Vodafone?

I did end up manually flashing, but did lose all my data in the process (no biggie for me, YMMV).

I’m looking forward to receiving the Februari patch update as it contains a fix for an RCE in Bluetooth.

2 Likes

Having read @RuthiB’s and @JeroenH’s replies, I asked two members of our German language FB group who also reported that they still haven’t received the late January update. Both have now confirmed they are Vodafone customers (in Germany), too (but both did not buy the FP3 through Vodafone).

P.S.: Oooops, I see now that @Kerku already reported this here earlier :angel:

1 Like

No problem. I didn’t mention Vodafone :slight_smile:

1 Like

Since I am also still on December patch level and for the records: I have also a Vodafone SIM card (Germany), having bought the FP3 directly over the Fairphone webpage. So maybe it’s indeed Vodafone related, although I cannot really imagine why it should because I am usually checking/downloading over WiFi.

1 Like

As strange as it sounds, that appears to be irrelevant (as it also was irrelevant in an other discussion where it mattered which provider someone had). Why exactly, I don’t know. Perhaps if you disable the SIM? Or remove it physically? Anyone mind trying? I would if I could, but I already manually upgraded (because I found it an important update).

I just did that, means turned off the phone, removed the Sim-Card, turned on again. Effect unfortunately 0 regarding the update problem. I will leave the Sim-Card outside until tomorrow morning and try again then, maybe G00gle caches these update requests a bit.

How did you do that? I find these updates also important …

Reading back the whole Orange-isn’t-updating story, it seems that before Orange fixed their update server / GSM configuration the only way people were getting the update was by switching data to their other (non-Orange) SIM. Presumably this caused the Orange config to be dropped, whereas removing a SIM doesn’t change the settings.
The setting that determines where android looks for updates applies to both Wifi and Mobile data - though it’s configuration appears to depend on the settings pushed by the mobile data network provider…

2 Likes
2 Likes

Did lose all my settings, so maybe wait for the February patch.