English

Has anybody received the latest security update yet?

Not “Vodafone decided”, but there seem to have happened a “misconception” in the process between Fairphone and Vodafone. Maybe due to Corona? I don’t know. Something didn’t work out in the agreed concept between the two companies. Will become better in the future, as both work hard for.

2 Likes

Just installed A.0118 and cheering about the notification LED finally being back again, yeah!

How did I get it so quickly despite my Vodafone SIM card? Well, my old expired SIM from Lao Telecom helped out again, with it the update installed immediately. My trick is that I have now permanently installed the SIM from Laos as SIM 2. Normally, I have SIM 1 (Vodafone) enabled and SIM 2 (Lao Telecon) disabled. For the update I do the opposite, disable 1 + enable 2 and the update installs without any trouble.

4 Likes

For the Dutch readers here: I finally got A.0118 offered after checking for updates with an XS4ALL SIM enabled in slot 2. Yay! :wink:

4 Likes

:netherlands: A.0120 (from A.0118) worked for me via Vodafone without having to enable the T-Mobile sim (which I had to do before).

1 Like

Yes, A.0120 came for everybody, including the effort from Vodafone for their network. Unfortunately there were created multiple threads for the same topic, seems I forgot to update here.

My new FP3 arrived last Friday, with build A.011 installed. I use it with a SIM from 1&1 (Vodafone reseller), and everything works fine so far except that no OS update has arrived as of now. I tried numerous times already (Settings -> System -> System Update), but it always claims that the version from “5 February 2020” is up-to-date.

Are the Vodafone problems with updates still relevant, or have they been resolved and I maybe have a different kind of problem with the update?

Welcome to the community forum.

According to Vodafone users here this was resolved.
In fact it’s currently the other way around … Vodafone users got A.0124 while non-Vodafone users don’t get updated from A.0120.

Make sure you have a working Wi-Fi connection.
Else … You could update manually to A.0120 (currently) with this here …

… and then see whether the Updater offers you A.0124.

3 Likes

Wi-Fi is definitely working. I also tried with flight mode on and off: no difference. I had already seen the page about the update using a computer but didn’t want to try it yet because, seriously, if there’s a self-update function it should really just work, without such a workaround.

Seems like that’s what I have to try it now. Thanks for the welcome and the feedback :slight_smile:

I wonder if it is only the previous update (A.0120 I guess), which solved the problem for Vodafone customers, so if you don’t have that (I forget if that is the one with the Feb security patch or a later one), you will still have to get the update manually. Sort of - what I found to work is just putting another SIM card in the phone, even a defunct one. My phone could then find the new update. Weirdly it didn’t work with no SIM at all!

1 Like

I’m on A.0124 now, yay! I did the update to A.0120 using a computer as mentioned above, which worked fine. After that - with the SIM card and my SD card still removed because of the update via computer - I went to Settings -> System -> System Update to check for even newer updates, and it immediately offered the update to A.0124. Which also worked fine.

In hindsight, one thing which may have worked as well to get the update to A.0120 but which I didn’t try was to remove the SIM card and see if Settings -> System -> System Update then offers me the update to that version. Anyway, glad now :slight_smile:

5 Likes

Short question:
Is there still only safety patchlevel April 5th, 2020?

My phone has a June 2020 patch.

If I got it right, for non-vodafone users indeed.

Yes, but you put another sim in the phone to install the update.

3 Likes

Actually that was the first update where I didn’t have to replace the sim in order to get it. I assume the previous update (that gives you the April 2020 patch I think) fixed that issue.

3 Likes

Well, tried again but phone says it is up to date and safety updates are from April. My provider is Maxxim (Drillisch O2). I have to mention that I returned from custom ROM again to stock Fairphone software which was from April. Installing FP3 stock went quick and well! Could this delay be in connection with April software?

Just found this post from teezeh and see I am not alone with missing updates. Only some Vodaphone customers received updates.

Hey everyone,

for further information for the June / July security update and why its delayed look at the following topic:

Greetings,
JuengerJesu

Today i got A.0134 with Patchlevel June 5th.

1 Like

Hi everyone,

I have an old problem with updating the OS:
It is still on the buid verson 8901.2.A.0095.20190926 and when I try to update it, it says: “Your system is up to date / Android security update september 5th 2019
I took a screenshot.

I think I’ll try to update it manually with a PC connection.

Be aware that the current version of the manual install seems to require an unlocked bootloader.
If you have a locked bootloader now, as is the default if you didn’t actively unlock it yourself earlier, unlocking it now will wipe your data (locking it again will do that, too, it’s a security feature).

3 Likes