Google Play Disappears after each new Software Update

Google Play - disappeared after the last software updated and again with this update. I have had to factory reset to be able to install Google Play, which is extremely frustrating.

No way to get this back it seems. Google play dissapeard (along with my contacts, certain apps and a lot of customizations)… I want to be able to get Google play store back, please help.

(this 1.8 upgrade is a disaster - I’m not buying anything from you guys again, this is non-tested amateurism)

You should be able to get it back using the “Google Apps installer” widget.
This support topic should get you on track:

That should bring back the Play store and other Google apps. (Here it seems to have worked yesterday).
If the widget is greyed out, or you get the message the updater is running in the background, try opening the Fairphone updater app, as you might need to do an extra reboot from there.

I hope this gets you further.

Thank you, but `I have already tried that. The google widget is always grey. I have been through this process once before after the last update. The only way to restore google play is to reset my phone to factory settings as I did before. Which is highly annoying.

Since the update to 1.8 my google apps widget also offers the option to reinstall google apps even after they are installed.
Have you checked yours?

There are numerous thread about this, with various replies. Please read the forum before making another topic. I understand the frustrations and problems, but let’s try and keep the forum a bit organised :wink:

From previous updates:

1 Like