Missing Google Play Store and other Google Apps after upgrading to Cherry 1.6

Hello dear fellows,

The facts:

  1. My FP was not able to use mobile data network, even allowing roaming (just in case).

  2. The I tried to upgrade to Cherry 1.6 to see if this eventually could solve the problema.

  3. After upgrading, the phone said that “Google play stopped working” and some Google Apps (Gmail, etc.) weren’t able to be executed (they seem to crash or “vanish” 1 milisecond after clicking on its icon).

  4. Then I tried to upgrade to Jelly Bean 4.2.2 but after doing this it seemed my whole Google Account were missing and also all the icons in my screen.

  5. I upgraded again to Cherry 1.6., and I tried to dowload Google Apps again.

Current situation:

  1. Google Play Store seems to be inexistent in my phone. No icon in the apps list. And when I try to reinstall it from google (Chrome web browser), after signing in with my Google Account. it says that “You haven’t accesed the Google Play Store app on your device with this mail account”.

  2. I still have no mobile data connection.

Can you suggest any fix?



For your mobile data connection (which should work without gapps) make sure you have set the correct APN for your network and provider/carrier.
Usually your provider/carrier should have the settings you need on his website.
Access your APN configuration:

  1. Tap “more” under the wireless/networks tab in settings
  2. Tap “mobile networks”
  3. Tap "access point names"
    Then choose your network and tap on an access point to change the config or hit the menu button on the phone (bottom left) to create a new one.
    Also be sure you have mobile data as part of your contract.

The solution for your gapps problem is much more trivial:
Find the widget “Google apps installer” in your widget drawer and drag it onto your homescreen.
Then tap it to install gapps.
Edit: more thorough instructions here:

Thanks for the quick response,

  1. The APN menu item in “Settings->More->Mobile Networks->APN” shows nothing, just a full dark black screen, which not even allows to go back by clicking in its title. Any idea of the problem?

2.Thanks for the Google Apps hint: The Google Apps installer widget appear greyed and auto-labeled as “Google Apps Uninstaller”. Then I went to “Admin Apps” option and there it was the Google Play Store App. Then I decided to uninstall updates and it seems it is running. BUT, this just did not work for the Gmail App: every time I try to execute it, it shows the message “The App has stoped working”. Any idea?

Thanks again,



Searching in the forums about APN I have found out that I have to add one APN, according to the settings of my mobile network provider. Now I am trying to find that through the web but hopefully I will solve it this way.

The GMail App issue is still happening.



What are the Google apps you have currently installed on your phone?
You weren’t supposed to install the Play Store from google’s website in the first place.
Google apps integrate pretty deeply into the operating system, so to make them work flawlessly you really should use the installer widget.
The reason why gapps vanished after installing aosp 4.2.2 is that aosp android comes completely without gapps.
Also, they will stop working after any of the official upgrades of fairphone OS.
I don’t really understand why there even is a play store app on your phone right now.
Sadly, I have no idea why your widget is labeled “uninstaller”.

What you could do, to get a clean starting situation is reinstall fp OS 1.6 via the updater app and then try reinstalling Gapps via the widget if that’s not possible atm.

I understand, thanks for the info, I am quite new to Android.

What I do not understand is why after upgrading to Cherry 1.6 for the first time, all the Google Apps where still showing icons on my main screens by when I clicked on them there was an error message, something like “Google service stop running” (I don’t remember exactly).

Then I installed aosp 4.2.2 and then Chenpi 1.5 and then Cherry 1.6 for the second time. Then, thanks to your help, I installed Google Apps from the gadget, but they did not work (same problem as before). The problem got fixed when I went into the list of apps, found Google Play Store and I clicked on “uninstall last updates”.

At this point everything looks fine less the GMail App. Is there any way to uninstall it and reinstall it again?

Thanks for your time Xeidal,


Thanks for clearing that up.
It’s quite weird that Gapps still crash after installing from the widget.
Have you tried out the other Gapps (google+, photos, etc)?
Just see if they run, no need to register or connect anything :wink:
Since your play store seems to be working, maybe you can update gmail from there. I’m sure there should be one available if you haven’t done so already.

Also, have you followed the procedure provided in the link when you installed Gapps? The thing with the superuser might be important for the installation to succeed.

Thanks for the quick response Xaedil, it is being helpful,

Bit a bit I am getting familiar with Android and things make sense.

After updating GMail App from the Play Store it works fine !!!

Other Apps (google+) seem to work fine.

Now I only have two other problems (sorry to insist):

  1. How to enable the dial tones to be able to communicate with call centers (when the automated call center says “Press 2 to access technical service, press 1 for commercial, …”). Now, when I press 1 or 2, the phone does not generate any sound and therefore the call center machine does not recognize any option, so then I cannot choose and navigate through the options to reach the department I need.

  2. Once solved the previous one I will be able to call my mobile network provider to clarify the APN configuration.

These complications are part of the technological odissey of the 21st century :slight_smile: !

1 Like

@timbuktu explained to you in the other thread:

[quote]You can activate the dial tones under
System Settings (you get it by touching the left “hardware” button)
General *
Under system you can activate / deactivate the dial tones.


*When you see ‘General’ you have to tap on the icon on the right of the word ‘General’

Thank you very much !!

At this point, and thanks to the help of the fellows in this forum, I have solved everything !!!

So now (cross fingers) everything is fine with my FP and I am proud of having a “fair trade” phone,

Thanks !!!


Glad you have solved this.

This topic is now closed. New replies are no longer allowed.