Google Play store doesn´t work anymore (tried everything I could find)

So I cannot use google play store anymore, it immediately crashes.
I used several different launcher. I uninstalled all of them, installed google play store apk, when I try to launch: it immediately crashes. Had this problem I guess since I used some of these launchers or since I upgraded to JB 4.2.2. But I actually don´t know what I did there, I am really new to android and played around.
Did a reset, reinstalled google play store -> same error
I did a hard reset, reinstalled google play store -> same error. It is extremely annoying and frustrating, already working on this for at least 10 hours.

Help highly appreciated

Same here, Yvestantin. I’ve been at it all day! :frowning:

Did you clear the cache?

  1. Battery should be well-charged (at least 80%), and remove any cables connected to the phone
  2. Turn your phone OFF
  3. Press and hold the Volume Up and the Power button combined until you see the green Android robot on the screen
  4. Press the ON/OFF button shortly and the “Android System Recovery” screen with orange text will appear
  5. With the Volume Down button scroll down and select “Wipe cache partition”
  6. Confirm with the Volume Up button
  7. You will return in the “Android system recovery” menu
  8. Select “Reboot system now”
  9. Confirm with the Volume Up button
  10. Now your Fairphone will boot up normally

Yes I did exactly that.

You say you upgraded to JB - do you mean you are using the AOSP install of Android 4.2.2 which you could download from under the ‘Stock OS’ in the Fairphone Updater app?

If so this is probably your problem as there won’t be the right google services installed to allow the play store to work. Before you attempt to fix it, is there a reason you are using the ASOP install rather than the Fairphone V1.6 software? If the answer is no, then I would revert back to this. If you have a reason, then try following this guide to install google apps on the AOSP install

Hey! What worked for me was going to Settings > Apps > Downloaded Apps and then uninstall updates for every Google App (including Google Services). This somehow tricked the phone into downloading updates again, and this time they worked.

Good luck!

1 Like

No particular reason: how do I revert to 1.6? Just installing it via Fairphone Updater is sufficient? Or do I have to do this with an SD card like explained here?

Which method would be less time consuming, keeping in mind that I dont want to buy an SD card, only if I really have to…

Yes, just installing it through the updater app should do the trick. What I wonder: If you are currently using AOSP (plain Android), is the FP updater app available there?

The Fairphone Updater is not working, when clicking on Fairphone OS it doesn´t do anything…


That sometimes happens, don’t know why. Try again in a few minutes. Tapping repeatedly may help, too.
If nothing else happens, or if you lose your patience, there’s always the option to do a manual install.

Mine does something weird.
First i go onto Google Play Store, it loads for 2 seconds and says there is a “server error” and next to it, it says Retry, i press it and nothing happens, it loads but “server error” pops up again

Didn’t work my Google play my gmail the launch nothing works

Are you on version 1.8.7?

Same here wtf I getting soo upset with this crap

You may have better chances of success if you would actually provide details such as the information Lidwien was asking for (but probably more). Nobody can guess at what system you’re running (AOSP/FP? 1.X?) or when problems started occurring (OS update? Phone crash?), which is information that will help people to help you.

Oh wow, i just rebooted as per the instructions above and my fair phone is now running through factory settings…i am worried that it won’t work again now…it is currently just a black screen with some green red and blue stripes and some text and nothing is happening…

loud beeping testing the camera, help!!! i want to go back to iPhone, this is so hard…

Take out the battery! :slight_smile: (I wonder if you could take your iPhone’s battery out… ;))

1 Like