Problems with play store even after 'hard reset'

Hey there, i tried to find a solution myself, but didnt manage so far. I am not an expert on these kind of things also… Problem: I have a first edition fairphone and after an update in august the play store didnt work any longer (there was no play store). Also all google ‘files’ vanished and I couldnt get them back. So I only used the very few apps left :slight_smile: Yesterday I did (several) 'hard reset’s on my fairphone as no other hint in forums or where ever would work. And even now I cant find any of the folders (Google app installer,… no folder with the word google in it actually) in apps/widgets. I’ve got the impression not everything got erased. All the data (pics,…) are gone, but still some few icons (as camera, picture folder,…) are still in the same place as I put them before, even after the reset.
Thanks for your help!

Did you reinstall the google play store after the hard reset.
You find instructions here

Thanks for your fast reply!! I already tried to re-install it, following the same instruction you send me. But I cant find the tools I would need for that. Also I just read I won’t be able to download the play store. So if its not on my phone (and I cant find the needed things in widgets as written in the instructions) I won’t be able to use it. Hm… out of ideas.

Hi @tanzdermolekuele,

You can always download its APK and install it from your SD :slight_smile:

I hope it will be fixed soon.


Hi there!

Do you still have the Fairphone Updater? Is it possible the by accident, you did not upgrade to Fairphone OS 1.6 but “Vanilla” Jelly Bean 4.2.2?

The upgrader is a bit misleading i think it is easy to get confused.

If you actually did “update” to Jelly Bean not Fairphone OS, this would be an explanation.

On a side note: The Google Apps installer is a widget, not an app.

Yes! Thats it! And that’s causing the problems? I thought if I reset everything, everything would start from the beginning and troubles would be gone :wink: But nothing really changed. So I still have this Jelly Bean 4.2.2 Version. Do you have any advice what to do now? iiiiii have nooo clou - sorry…

See if you have the fairphone updater app on your phone. It should tell you what version you’re using.
It should also give you the option to upgrade to fairphone OS 1.6.
You might want to do that unless you aren’t running that already.

As for the resetting, there probably wasn’t a reason to do that in the first place.
Google apps get broken everytime you update the device.
The reason for this is that fairphone doesn’t have a “contract” with Google to ship their device with the apps pre installed. And they probably can’t update them either.
All you probably needed to do was find the widget “Google apps installer” and follow the instructions @Lidwien provided in the 2nd post. (no tools needed, really)

So verify which version you are running and which you want (probably fpOS 1.6)
Then install that one via the updater app and then install Google apps.

Oh, and just so you know. When you reset your device it will not revert to older software versions, only do a basic routine resetting all kinds of settings and deleting some files.

The updater is only part of Fairphone OS, not Jelly Bean, so this does not help here.

Yeah, i have. First backup everything on the device!

You will have to manually install FP OS 1.6 on your device. This may sound scary, but it is certainly doable. Again: Backup everything, fully charge your phone and proceed with this guide by Fairphone Support: Read carefully and choose the right version matching your phone and storage settings. Come back here if you have any questions. Maybe you can find an Android Pro or Fairphone Enthusiast in your area to help you out, if you do not want to take this steps yourself.


Thanks you guys a lot!!! Learning everyday… I managed to get everything sorted.

So for everyone who has the same problems:

First and most important step - manually install of fp OS cherry 1.6:

After realizing that this is the problem and having this done everything is easy.

Glad you sorted it.

This topic is now closed. New replies are no longer allowed.