Fairphone 2 camera cannot focus

I think I found the root cause of the focusing issue.

After reading through all the post here I concluded it has to be an hardware problem, not wanting to wait for a long time and being without a phone I descided to open the phone and check the camera module for hardware issues. My first suspect was bad contacts but they all looked ok. After removing the camera sensor out of the module housing I noticed that the sticky foam used to mount the sensor in the housing was the real issue. The piece of foam has been misalligned and physically limiting the movemont of the camera lens causing the focus problems. Carefully removing it and alligning it how it should be fixed all my focus issues. Now my camera works like a charm.

So the good news here is, it’s easy to fix. To bad that a few cents of double sticking foam caused all these issues.


This definitely did the trick for me, thanks @Npsm! Focussing now works a lot better than before! Just for those of us, who need some help with disassembling the camera module…

First remove the camera module as described in:

(you can change the language settings in the top menu)

As soon as you have removed the camera module, you will see one more tiny screw that needs to be removed to disassemble the camera module:

Also remove the latches (2 on one side and one more on the other side):

Then you should be able to easily remove the back cover of the camera module (perhaps you might want to use a tiny screwdriver as a lever). The open camera module should look like this (the actual camera within the red circle):

You will actually need a screwdriver now to carefully remove the camera from its mount as it is firmly attached to the mount by sticky foam (the foam that is actually causing the focus problems). Once removed from the mount, you can realign the sticky foam so that it does no longer disturb the movement of the lens of the camera. It should look like this in the end:

Reassemble all the parts carefully and enjoy your new FP2 camera feeling:

(taken on my FP2 with the realigned sticky foam)

Thanks to @Npsm for this great solution!


Nice one. I wonder if someone from FP will confirm this. Can you tell us if it is just too much foam or if the foam is just in the the wrong spot? I can’t really tell from the pictures.

1 Like

Sorry, my old digital camera is not too good… No, the foam is simply misaligned…


So right in the middle & center at the front of the camera sensor is the right place, right?

Updated, so that nobody gets confused.

1 Like

Yes, so that the hole in the foam sits just over the camera lens… Otherwise the foam jams the lens… I have edited the respective picture in my above post… It should become pretty obvious once you have opened the module …


Jochen17, Great guide on fixing it!


Totally worked! Thanks a lot!

On my side, taking pictures works perfectly. The focus problem occurs only when i record some video. Does anyone else have the same issue ?


Just in case you haven’t found this topic using the search function in the meantime:


Exactly ! I don’t know why i didn’t find this topic before… It’s seems a lot of people have the same issue as me. Thanks for the link.

Thank you so much for this fix!
It was quite easy and camera now works perfectly!

1 Like

Hey there, you will also find relevant information about how to proceed in the support article:


Please be careful with doing this.
Opening (and performing self-repair on) modules voids the warranty of the specific module.


Has anybody tried this fix for the video focussing problem??

1 Like

Yes I did replace the foam, and now the focus is working great !
So this looks like a factory assembly issue.

Just to be sure, the focus works without issues in videos after the foam replacement?
Because I got a new camera module, which fixed the focus errors for still pictures but I still get occasional focussing errors with video captures…

A post was merged into an existing topic: Video capture losing focus: Broken camera?

Well not at all for video, 1 or 2 seconds after pressing the record button, the focus goes wild and the video is blurry… I think it’s more of a software issue, as the photos are OK

Hi Jochen, I also have the same focus problem with my FP camera. When I try to disassembly the module by following your pictures, I can’t I get to remove the last tiny screw. Did you any special screwdriver to do it? Thanks.