English

Android 10 - MicroSD as phone storage

Hello
I just updated my FP3 to android10. From that moment i was able to use my SD card as phone storage. Once i have configured it, telegram & whatsapp but also gmail (at the moment i notice just this apps) cannot use media anymore. I mean, i can write and read message but cannot download and upload images or audio or anything else. It just said: download failed. any clue? thank you

Welcome to the community forum!
:warning: Don’t format you sd card as internal storage except if you are sure of the implications!
Formatting the sd card as phone storage is known for breaking things on the phone, and you’re not the first one to report problems that occurred when doing this under android 10. Please reformat your card as external storage and use it like this, although there are some inconveniences with this. I’m also afraid this means you’ll need a #dic:factorydatareset or even a data formatting and a reinstallation from scratch. Keeping my fingers crossed for you :crossed_fingers:

Please also have a look at the #sdcardguide, it is well detailed.

Edits: Typos

9 Likes

:scream: :scream: :scream:
thank you for your answer… I’ll see what to do :crossed_fingers:

2 Likes

Soo,
I used my FP3 since last October without an extra SD-Card, everything worked more or less fine. With storage slowly filling up I decided to get a SD card this week.

I got a 128 GB SD Card, inserted it and choose to use it as an extra internal storage. After formatting I got asked if I want to transfer files to free up space on the “real” internal storage which I accepted. And restarted the phone afterwards.

Now the problem begins,
after the restart, a system pop up tells me that the sd card is missing. But in the storage setting it shows me, that the card is inserted and that I got tons of free space. Problem still there after a couple restarts. I tried putting it out and in several times physically as well as in the Storage settings. Nothing changes.

This brings the following problems:

  • Brave Browser doesn’t start at all.
  • Camera App opens, lets me take pictures, but doesn’t save them
  • Whatsapp works but all my previously downloaded pictures are gone and I am not able to download new ones. Also I can’t take pictures in the app neither can I record voice messages.

In general I have the feeling most apps have storage reading problems.

Maybe important to mention that I updated to Android 10 2 weeks ago.

Any tips, advice before I try a factory reset?
Anyone had similar problems?

I moved your post here, as you have the same problem. Please read the explanation in the second post.

4 Likes

Am I correct in thinking that as an sd card previously used successfully in a Samsung Galaxy does not show up anywhere on the device that the phone does not like the card? Presumably the device is as fussy with the sd cards as it is with the charging cables. Cables that charge any number of other devices do not work with the Fairphone and when a useable cable is found the charging rate is ridiculously slow.

I guess I just have to be more patient and accept the idiosyncrasies. I reinserted the sd card and suddenly there it was. I have no idea what happened.

My mother in law has the same problem after the FF3 update. We tried to reinsert the sd card, but nothing happened…

Dear community,
as the new FP3+ Android 10 version did not in any way warn about the problems with using a SD card as internal memory (as opposed to mobile memory) – see all the problems listed in this forum (and I had a few more) – I had to completely restart my FP3 from scratch (reset, reinstall all apps and configurations). I did this without the SD card inserted. Only when the phone functioned correctly in all respects (it did!), I reinserted the SD card and let it reformat as external/mobile. Worked well. Now the music files, fotos and documents have been manually moved to the SD card and the communication between the FP3+ and the SC card is as it should be.
Cheers!

4 Likes

@rae: When the Fairphone 3 came out with Android 9, the easy possibility to incorporate an SD card into Internal storage wasn’t there. It was only possible to get this functionality via more obscure ways.
Our understanding here was that Google had removed the easy GUI access to the feature in AOSP, and with reason, because using an SD card as Internal storage was never ever a good idea technically.

Now with Android 10 the easy access to the feature seems to be back, and it has caused some grief for several users already.

Could Fairphone please investigate whether the easy possibility to let an SD card be formatted as Internal storage could be removed from Fairphone OS again to avoid trouble?

5 Likes