WhatsApp can't handle media when SD card installed as phone storage

I have a Fairphone 3+ and tried setting it up with an SD card formatted as phone storage. Unfortunately it never worked right. Apps stored on the SD card would crash on startup. And most annoyingly, WhatsApp gives several errors related to media and the camera: when trying to take a photo, I get the error “camera failed”, and when I try to send a picture, I get the error that the media doesn’t exist on the SD card. I tried this with a 64GB and a 128 GB SD card. When formatted as portable device, none of these errors appear, but many apps including WhatsApp have trouble getting to files on the SD card.

Is this a WhatsApp thing or a FairPhone thing? Is there a fix out there?

For the time being, the only solution is the one you have already arrived at: Do not use an SD card as phone storage, set it up as portable storage instead. This is a longstanding issue since the upgrade to Android 10, and I don’t know if it affects other phones as well.

The downside to this solution is that some popular apps (like Whatsapp, yes) won’t store any media on an SD card formatted as portable storage. While you might be able to manually move (via file manager) the media embedded into Whatsapp to the SD card, it will make them not show in Whatsapp anymore.


Huge bummer. I found mention of this in a thread and I’ll report it to support. Rather than use an SD card as portable storage, I’ll use the old-fashioned portable storage option: connecting with my PC and getting the media off that way.

Thanks for the quick response!

Just bear in mind that as of now, using the SD card formatted as “phone storage” will keep causing lots of problems like the ones you described when taking photos.


Oh yeah, I didn’t keep it installed. I re-formatted as portable and removed it.


I have problems with my SD card. I didn’t read about the problems before and I can’t remember how I formatted the card (internal/external)…How can I see how it is formatted? And I’m a bit worried that my photos and videos has disapperad. At first the SD card indicated that it was about half full. Now it’s only 0,5 %. And I can’t take a screenshot, “not enough space”. The same when I try to uppdate my apps, but when I look at storing space (I try to translate from Swedish) it says 37GB of 64 and the SD card 1,5 GB of 32. The card is a Sandisk Ultra 32GB 120Mb/s A1. What can I do?

Thats how it looks when formatted as portable so SD clearly listed as separate storage under mobile storage

1 Like

The eject symbol on yvmuell’s screenshot is the thing to look for :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.