Software update Cherry 1.6

Well, that indeed is the same issue as I had on all the OS-updates of my FairPhone.
Are you sure you
1- Reinstalled the Playstore after the update. Then
2- deleted the updates from both Google Play services and Play store via app-management. Then
3- rebooted the phone, and as last step
4- went to the playstore to updat all?

Hey, I also updated from 1.3 to 1.6 and I have the same problems with the display (flickering) as Isabell and Samuel. Reset and reboot did not help. Is it possible to delete/ uninstall the update and go back to 1.3?

Sorry to say.
Yesterday I heard from Support that isn’t possible to downgrade to 1.3

@Herm56: Do you maybe use the Google Now Launcher? This seems to cause some trouble - see here: Tip: Avoid issues updating Fairphone OS when Google Now Launcher is installed

@Reid_Sommerville - Can I suggest you start a specific topic for this issue so the community can offer some support for your specific issue, it’s good to note your issue in here too :smile:

@mgkoeln - glad it went smoothly for you (mind did too :white_check_mark:). I note you haven’t run the partition update and I can understand why not because it can be a pain getting everything back to how it was. Just be aware that you may have to run it as some point to continue getting support updates (it’s going to be hard for FP to constantly release 2 versions of every update).

@Mist, see this thread about the flickering screen issue, maybe worth asking on there if anyone has tried to downgrade. I’m pretty sure if you use the flash tools for MTK you can do this (method is in here and @Elchi might be able to help you and has had some experience using this method)

1 Like

Ooops… the updated battery level indication seems to be a total mess, though. My phone just went from 25% to 15% (warning sign) to 3% and then switching off all within minutes. I’m a little bit shocked after being used to run the phone for at least a few hours on the seemingly everlasting 14% level. Hopefully, this is just a learning phase during the first battery cicle after updating.

EDIT: It was only the first circle, by the way. Now it works perfectly fine - although I almost miss the 14% buffer now… :wink:


i managed to downgrade to version 1.3 with a backup i had made with droid - tools. I used flash-tools, formatted the partition (without bootloader), then flashed the backup-recovery. everything went fine, i have Fairphone 1.3 again and the flickering is gone. it definitely has to do with the update!
but remember to write down the imei1 and emei2, because i had to restore them after the flashing, (its easy done with droid-tools). i think its important to know, that this flashing-back to fp1-1.3 was necessary on my daughters fairphone because of the screen-flickering, it was almost unreadable. with my own fp1 i had no problems at all after the update to 1.6.

Hi Joagri,
thanks for your post! Your solutions seems to be easy, but I don’t know how to do this. Is droid-tools an app? What is flash-tools? Could you describe your solution step by step?

I am an ordinary user without experience in develop software - this method is not handable for me (I tried some steps without success). The problem seems to concern to many users. Hopefully the support brings out a solution.

I sent now a video to the Fairphone Customer Care… It shows the problems with the display!

Hey guys. I heard of a issue when downloading the new update: download in the Fairphone OS Upater starts but abrupts shortly afterwards. Any suggestens for this problem except downloading it and install it manually (in safe mode)?

have a look at
good luck

Just installed Cherry, and reinstalled the Google app store. Now I doubt if I checked “remember choice forever” for the super user access. Can I verify this somehow? Ans correct this if it turns out to be incorrect?

Hi Frans,

We have a support article on the site about this:


Hi, i also got poblems with my graphics/screen showing almost the wrong resolution and ghost trails of previous views. Setting the phone in standby for a while sometimes clears the old away but i cant get the screen back in its full glory.

I had some issues when installing the 1.6 update and the uniformed partition update. My screen is not what it used to be. Its darker, the graphics is just like a closeup of an old TV - so there must be something wrong with the resolution, it got ghosted/spooky memories from old views. Setting the phone in standby sometimes clears out the ghosts. The screen also does not register touch correctly. I cant have more than one keyboard now - before i could switch while i write. I have not tested any GPS or Bluetooth, MMS or SMS yet but WiFi seemed to work fine. I have not reinstalled any apps yet either.

After installing the uniform update is it possible to install the 1.6 again to possible get rid of the problems? What is Chenipi-1.5 in the FP updater app?

I noticed after doing some configuration that the touch functionality was more damaged than i first thought. When entering the settings and all its checkboxes they get checked on and off randomly just lika a ghost whas hacking my phone - my phone is haunted! I need an exorcist!

Just noticed that all screenshots are looking OK…strange!

Reinstalled 1.6 - still bad graphics.
Booted in recoverymode made and made Step 6:
"Now, select “Wipe cache partition”, and wait till you see “Wipe cache complete”."
The screen looks good :slight_smile:
installing Google Play Store
The screen looks bad :frowning:
Wipe cache partition again
The screen looks good :slight_smile:
make the phone go to sleep and then wake it up
The screen looks bad :frowning:
I am out of options again
Installed JellyBean through the updater
The screen looks good :slight_smile:
make the phone go to sleep and then wake it up
The screen looks bad :frowning:
Made a factory reset after installing a google play apk that did not work
The screen looks good :slight_smile:
Keeping the good screen by setting the screen not to go to sleep for 30 min
Everything looks good sofar - dowloading and installing 1.6 again so i get the google play store back.
Lesson: dont let the screen go to sleep and jellybean seems to use less power as my battery lasted longer or maybe its the lack of installed apps - dont know.

I have the same problems too… I sent a video with this graphic problems to the customer care, and i am waiting now… If i will hear something, I’ll post as fast as i can…

had the same problem. I charged my phone while I tried to do the update and that seemed to be the reason for the problem.

And now, the problem still exists??? Only because that??

This didn’t work. The screen “Remember choice forever” didn’t appear. Now the Fairphone OS and the Fairphone updater are both gone from the list, and also gone from the trashbin. Superuser screen now says “there are no apps with root access” (my translation).
Do you have any further suggestions?