Software update Cherry 1.6

It’s a good thing that there are no apps with root access.
This means that the next time an app need root access, you will be asked again if you want to enable root access for that particural app.

With for example an update I grant Fairphone just for this time root access. In this way I know that I will be asked each time what I want.

Hey all,

are you using the FP1 orginail cover?
I discovered sometimes if I unplug the phone from the charger that it is unusable due to inresponsiveness or wrong responses of the touchscreen.
Rebooting the phone helped (if I got there) but what does the trick for me is just remove the protective case and put the phone back in.
I suspecct there is some static electricity which causes this.
But it helps for me :slight_smile:


@Samuel_Wyss and @Nordlig: just wanted to give you a quick update on the screen issues that appeared for you after the update: we passed on all the information and videos you all took to our developers - who are looking into a solution. Thanks for bearing with us here.

This seems to be an issue not many people are having, but if you do, please make sure to submit a support ticket through our website. That way we get to know the scope of the issue, if you have any details about the issue/videos - please include them- it really helps us find the fix.

@mgkoeln & @Rob_van_der_Does: I was getting annoyed of all specialised ITtalk here, so I stopped trying for a while. But the problem is still there, so here I am again.
I found out that I do have a widget Google Now, but only in the widget-section. As far as I know I used the Fairphone Launcher, and pressing the Google Now launcher it asks to be activated, so I suppose it’s not. But as it’s not in the list of Apps, I can’t delete it. Besides that according to GPStore it’s not installed, as it shows the option to Install.
Anyway, I need to do something to be able to use and update Apps, while some don’t work properly. And the ‘tip avoid issues…’ is closed for reactions.
GPStore and GPServices don’t show a ‘delete updates’ button anymore, so probably they need to be updated. But I can’t find out how, as I don’t see any button to update, Both of them don’t show in my Google Play store, so that’s no source. Should I delete GPServices and GPStore, is it safe, and how to proceed? ‘Stop’ and ‘deactivate’ give warnings about ‘unexpected behaviour of Apps’ so I was afraid of continuing. I would be grateful for any suggestion, or support link.

@Herm56: If you didn’t install the Google Now Launcher it definitely isn’t the cause of your problems. :wink:

I found this advice on some German message boards: In Android’s app settings menu go to “Google Play Store”, force stop the app and then delete the app data. Do the same with “Google Services Framework” and then re-boot. You’ll probably have to re-enter your Googlemail-adress when opening the Play Store again and then everything might work.

That is great. I have submitted a support ticket and are waiting a responce. I made some screendumps with the phone but to my surprise they were all great and showed a perfect screen instead of the dark spooky view I am presented with. I will try a diffrent camera and send the file with with the returning mail from support, unless you have another suggestion where I can send such moviefiles and images.

Thank you for your effort. I hope, you 'll find a solution as fast as you can… Greetings Samy

Thanks for this information! As my phone is still unusable, would it help, if I sent it back to you, so you can have a look on what is going on?

@mgkoeln thanks for your suggestion. Tried it, but to no effect. ‘No connection’ keeps coming up. Although it started to occur after the last Fairphone update, it seems to be a problem of Google Play store, as lots of people around the world on all kinds of devices reported the same for more then a year. Quite a few solutions are offered. Tried some of them from instructions on internet and YouTube too, like date and time selections, install a root manager and edit the ‘hosts’-file, but still no success. Search continues…

I couldn’t get the update started either.
After reading this I tapped the button like 10 times very quickly, then it finally started the download. :slight_smile:


I did the storage Upgrade as of today. All is working very well! I’m happy! Thanks to @anon90052001 and the rest of the fairphone Team!


I have the same problem as well. The five differerent sides / screens are lying over each other, you always see the shadows of the other display-sides.

i installed the update to my FP1 and everything was just fine.

then I tried to install the “unified 1.6 update” which worked but the problems begun:

  1. backup ist not really a backup for the apps but just a way to reinstall the apps I had installed without any settings. you could have written that somewhere, not a fun way to find that out, when reopening your apps.

  2. the update to the 1.6 unifyed also messed with my SD card and deleted files and put new ones there. not something I was expecting. you could have written that somewhere, luckily I had a backup of the SD card.

3. after merging the partitions I cannot acces the phone storage on my PC (mac osx 10.9.4). not directly as a drive. the android fil transfer tool works, but i get the impression it does not have all abilities finder/explorere provides. how do I get acces to the phone storage again?

As all my settings are gone anyway I am open to reinstall the phone from scratch.

Hi there,
I have the update installed successfully Cherry 1.6 with unified memory on my Fair Phone FP1.
The installation and the menu navigation was very easy, everything was great!
I have not experienced any problems with the update.

The backup feature of Android is a horror … I backed up all apps and data on the SD card. From a recovery can not be there talking about.
Somehow the apps were all there, but no longer worked and had to be uninstalled to then reinstall again …

The arrangement on the home screen was ordered to be done manually.

I use next to the Fair Phone also a IPhone - Google should take a look at Apple’s something a backup function can make all !!

Yeah the backup app is really bad. Somehow (besides app data) it also deleted my videos. Only the images got recovered…

Thanks! Now my storage-problems are over!

I have exactly the same problem. Updater shows that I have FP 1.3 Chestnut, and when I tap the Install new version button (cherry 1.6) nothing happens.

Make sure you have at least 250 MB of internal storage space left, and press the install button many times in a row. This unorthodox way worked for several users. Also, follow the steps in here:
I see no software update sent to my Fairphone. What can I do?

Software update v1.6 log - August 2014 states that there are some “security fixes”. Unfortunately I haven’t found anything else on the matter.
Is upgrading really necessary besides the mentioned accommodations?
If so maybe more detailed release notes would be nice.


The unified storage partition was what made me really want to do the update :slight_smile: